digikam depends on konqueror

Bug #1011211 reported by karaluh
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
digikam (Ubuntu)
Fix Released
Wishlist
Harald Sitter
Quantal
Won't Fix
Wishlist
Harald Sitter
Raring
Fix Released
Wishlist
Harald Sitter

Bug Description

As in summary. It isn't mentioned in dependencies http://www.digikam.org/drupal/download/dependencies

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: digikam (not installed)
ProcVersionSignature: Ubuntu 3.2.0-25.40-generic-pae 3.2.18
Uname: Linux 3.2.0-25-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu9
Architecture: i386
Date: Sun Jun 10 18:12:48 2012
InstallationMedia: Kubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
ProcEnviron:
 LANGUAGE=
 TERM=xterm
 LANG=pl_PL.UTF-8
 SHELL=/bin/bash
SourcePackage: digikam
UpgradeStatus: No upgrade log present (probably fresh install)
modified.conffile..etc.apparmor.d.usr.sbin.mysqld.digikam: [deleted]

Revision history for this message
Harald Sitter (apachelogger) wrote :

me@osiris:~$ apt-cache show digikam|grep Depends|grep konqueror
me@osiris:~$

It does however *Recommend* www-browser, which is among other packages provided by konqueror:

Reverse Provides:
xemacs21-nomule 21.4.22-3.2ubuntu1
xemacs21-mule-canna-wnn 21.4.22-3.2ubuntu1
xemacs21-mule 21.4.22-3.2ubuntu1
uzbl 0.0.0~git.20120514-1
surf 0.4.1-7
netsurf-gtk 2.9-2
netsurf-fb 2.9-2
netsurf 2.9-2
netrik 1.16.1-1.1
midori 0.4.3-1ubuntu1
links2 2.6-2
links 2.6-2
epiphany-browser 3.5.1-0ubuntu1
elvis-console 2.2.0-11.1
elvis 2.2.0-11.1
elinks-lite 0.12~pre5-7ubuntu1
elinks 0.12~pre5-7ubuntu1
dillo 3.0.2-2
chromium-browser 18.0.1025.151~r130497-0ubuntu1
chimera2 2.0a19-7ubuntu1
arora 0.11.0-0ubuntu1
w3m 0.5.3-5ubuntu1
rekonq 0.9.2-0ubuntu1
lynx-cur 2.8.8dev.12-2
konqueror 4:4.8.80a-0ubuntu1
firefox 14.0~b6+build2-0ubuntu2

Which was introduced ages ago with the following changelog entry:
  * Recommends: dolphin (Open FileManager), www-browser (ReportBug, About)

All in all I am not quite sure what the bug is about. If you feel that you have more information regarding what the issue here is, please feel free to reopen the bug and provide that information.

Thanks.

Changed in digikam (Ubuntu):
status: New → Invalid
Revision history for this message
karaluh (karaluh) wrote :

That's strange, the bug is probably somewhere else then. I have Install-Recomends disbled in apt.conf, and rekonq, chromium and firefox installed. Yet, when I installed Digikam yesterday, konqueror was installed along with it.

Changed in digikam (Ubuntu):
status: Invalid → New
Revision history for this message
Harald Sitter (apachelogger) wrote :

You still did not use no-recommends. There is a direct recommends on konqueror in kipi-plugins, which itself is a recommends of digikam.

me@osiris:~/src/bzr/oxygen-icons$ sudo apt-get -s --no-install-recommends install digikam
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  digikam-data libkdcraw-data libkdcraw20 libkface-data libkface1 libkgeomap-data libkgeomap1 liblensfun-data liblensfun0
  libmarblewidget13 libopencv-calib3d2.3 libopencv-core2.3 libopencv-features2d2.3 libopencv-flann2.3 libopencv-highgui2.3
  libopencv-imgproc2.3 libopencv-legacy2.3 libopencv-objdetect2.3 libopencv-video2.3 libtbb2 marble-data
Suggested packages:
  digikam-doc
Recommended packages:
  kipi-plugins mplayerthumbs marble-plugins
The following NEW packages will be installed:
  digikam digikam-data libkdcraw-data libkdcraw20 libkface-data libkface1 libkgeomap-data libkgeomap1 liblensfun-data liblensfun0
  libmarblewidget13 libopencv-calib3d2.3 libopencv-core2.3 libopencv-features2d2.3 libopencv-flann2.3 libopencv-highgui2.3
  libopencv-imgproc2.3 libopencv-legacy2.3 libopencv-objdetect2.3 libopencv-video2.3 libtbb2 marble-data

affects: digikam (Ubuntu) → kipi-plugins (Ubuntu)
Changed in kipi-plugins (Ubuntu):
importance: Undecided → Wishlist
Revision history for this message
Harald Sitter (apachelogger) wrote :

from changelog:
  * Added konqueror as recommend because flickr-plugin needs it.

kipi-plugins was since merged into the digikam sources FWIW

affects: kipi-plugins (Ubuntu) → digikam (Ubuntu)
Changed in digikam (Ubuntu):
status: New → Confirmed
Revision history for this message
Harald Sitter (apachelogger) wrote :

at least in 2.8 the flickr plugin does no longer use konqueror directly, so we can simply remove the explicit konqueror reference.

Changed in digikam (Ubuntu Raring):
status: New → Confirmed
Changed in digikam (Ubuntu Quantal):
status: Confirmed → Triaged
Changed in digikam (Ubuntu Raring):
status: Confirmed → Triaged
assignee: nobody → Harald Sitter (apachelogger)
Changed in digikam (Ubuntu Quantal):
assignee: nobody → Harald Sitter (apachelogger)
Changed in digikam (Ubuntu Raring):
importance: Undecided → Wishlist
Changed in digikam (Ubuntu Raring):
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package digikam - 4:3.0.0~beta3-0ubuntu1

---------------
digikam (4:3.0.0~beta3-0ubuntu1) raring; urgency=low

  * New upstream release
    - Add build-deps : libhupnp-dev, libqtgstreamer-dev, libmagickcore-dev
  * Merge from debian, remaining changes:
    - Make sure libqt4-opengl-dev, libgl1-mesa-dev and libglu1-mesa-dev only
      install on i386,amd64 and powerpc
    - Depend on libtiff-dev instead of libtiff4-dev
    - Drop digikam breaks/replaces kipi-plugins-common since we're past the
      LTS release now
    - digikam to recommend mplayerthumbs | ffmpegthumbs. We currently only
      have latter in the archives, even though former is also supposed to
      be part of kdemultimedia. (LP: #890059)
    - kipi-plugins to recommend www-browser rather than konqueror directly
      since 2.8 no direct usage of konqueror is present in the flickr
      plugin anymore (LP: #1011211)
    - Keep kubuntu_mysqld_executable_name.diff
    - Don't install libkipi translations
    - Keep deps on libcv-dev, libcvaux-dev
    - Keep split packaging of libraries
    - Replace icons from KDE 3 time in debian/xpm.d/*.xpm with the new
      versions (LP: #658047)
  * Update debian/not-installed
 -- Rohan Garg <email address hidden> Mon, 26 Nov 2012 18:24:20 +0000

Changed in digikam (Ubuntu Raring):
status: Fix Committed → Fix Released
Revision history for this message
Rolf Leggewie (r0lf) wrote :

quantal has seen the end of its life and is no longer receiving any updates. Marking the quantal task for this ticket as "Won't Fix".

Changed in digikam (Ubuntu Quantal):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers