package emacs24 24.4+1-4ubuntu5 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1441754 reported by PA Monwall on 2015-04-08
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
dictionaries-common (Ubuntu)
High
Unassigned

Bug Description

.

ProblemType: Package
DistroRelease: Ubuntu 15.04
Package: emacs24 24.4+1-4ubuntu5
ProcVersionSignature: Ubuntu 3.19.0-7.7-generic 3.19.0
Uname: Linux 3.19.0-7-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.17-0ubuntu1
Architecture: amd64
Date: Wed Apr 8 19:02:45 2015
DuplicateSignature: package:emacs24:24.4+1-4ubuntu5:subprocess installed post-installation script returned error exit status 1
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2015-02-13 (54 days ago)
InstallationMedia: Ubuntu MATE 15.04 "Vivid Vervet" - Alpha2 amd64 (20150123)
RelatedPackageVersions:
 dpkg 1.17.24ubuntu1
 apt 1.0.9.7ubuntu4
SourcePackage: emacs24
Title: package emacs24 24.4+1-4ubuntu5 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

PA Monwall (pa-monwall) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in emacs24 (Ubuntu):
status: New → Confirmed
Changed in emacs24 (Ubuntu):
importance: Undecided → High
era (era) wrote :

As per attached DpkgTerminalLog.txt, reassigning to dictionaries-common.

Setting up emacs24 (24.4+1-4ubuntu5) ...
Install emacsen-common for emacs24
emacsen-common: Handling install of emacsen flavor emacs24
Wrote /etc/emacs24/site-start.d/00debian-vars.elc
Wrote /usr/share/emacs24/site-lisp/debian-startup.elc
Install dictionaries-common for emacs24
install/dictionaries-common: Byte-compiling for emacsen flavour emacs24
Wrote /usr/share/emacs24/site-lisp/dictionaries-common/debian-ispell.elc

In toplevel form:
ispell.el:4012:1:Error: Autoloading failed to define function define-minor-mode
Eager macro-expansion failure: (error "Autoloading failed to define function define-minor-mode")

In toplevel form:
flyspell.el:61:1:Error: Autoloading failed to define function define-minor-mode
ERROR: install script from dictionaries-common package failed
dpkg: error processing package emacs24 (--configure):
 subprocess installed post-installation script returned error exit status 1

affects: emacs24 (Ubuntu) → dictionaries-common (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers