package myspell-st 20070206-4 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #980130 reported by Emin Tastan on 2012-04-12
358
This bug affects 51 people
Affects Status Importance Assigned to Milestone
dict-st (Ubuntu)
Medium
Unassigned
Trusty
Medium
Unassigned
Utopic
Medium
Unassigned

Bug Description

Errors Bucket
-------------
https://errors.ubuntu.com/problem/5b4d09e93387518a948363d42dafe41547c48934

no detailsDescription: Ubuntu precise (development branch)
Release: 12.04

ProblemType: PackageDistroRelease: Ubuntu 12.04
Package: myspell-st 20070206-4
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
Uname: Linux 3.2.0-23-generic-pae i686
ApportVersion: 2.0.1-0ubuntu2
Architecture: i386
Date: Thu Apr 12 19:17:44 2012
DuplicateSignature:
 Setting up myspell-st (20070206-4) ...
 Error: update-openoffice-dicts not present or executable. Missing dependency on dictionaries-common?
 dpkg: error processing myspell-st (--configure):
  subprocess installed post-installation script returned error exit status 1
ErrorMessage: subprocess installed post-installation script returned error exit status 1InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
PackageArchitecture: allSourcePackage: dict-st
Title: package myspell-st 20070206-4 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to precise on 2012-02-26 (46 days ago)

[Impact]

"update-openoffice-dicts" got removed from dictionaries-common in version 1.12.0. But the postinst of myspell-st didn't get updated since then and makes the package uninstallable (fails in postinst).

[Test Case]

Installing myspell-st fails in the postinst with the above mentioned error in postinst.
Installing the fixed package finishes without error.

Emin Tastan (memint) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in dict-st (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
Robert Griffin (ichi-1) wrote :

I started to get this bug after installing all of the language packs for Ubuntu 12.04.1. This bug seems to not really affect anything. Just seems to be a random error message.

Changed in dict-st (Ubuntu):
status: Confirmed → Fix Committed

artur cryczek, please do not toggle the Status without a comment regarding why. For more on Status please see https://wiki.ubuntu.com/Bugs/Status .

Changed in dict-st (Ubuntu):
status: Fix Committed → Confirmed
Kaulbach (mystic-scientist) wrote :

Temporary workaround:
sudo touch /usr/sbin/update-openoffice-dicts && sudo chmod +x /usr/sbin/update-openoffice-dicts

Ian Sayabo (iansayabo1) wrote :

sudo touch /usr/sbin/update-openoffice-dicts && sudo chmod +x /usr/sbin/update-openoffice-dicts

asking . after this code entered what the next to do?

Ian Sayabo (iansayabo1) wrote :

anyone please i need your help>>>>>>>>>>>>>>>>>>>>>

Ian,

I'm afraid this bug has been long standing and if anyone has a solution
aside from uninstalling the package, it is beyond our knowledge. I simply
learned to remove that particular spell pack to fix the problem. Otherwise,
there is no known fix. I don't suppose you actually need that particular
language package? If so, maybe, someone could come up with a solution for
one that doesn't involve simply telling us to uninstall the package in
question?
On Sep 27, 2013 4:16 AM, "Ian Sayabo" <email address hidden> wrote:

> anyone please i need your help>>>>>>>>>>>>>>>>>>>>>
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/980130
>
> Title:
> package myspell-st 20070206-4 failed to install/upgrade: subprocess
> installed post-installation script returned error exit status 1
>
> Status in “dict-st” package in Ubuntu:
> Confirmed
>
> Bug description:
> no detailsDescription: Ubuntu precise (development branch)
> Release: 12.04
>
> ProblemType: Package
> DistroRelease: Ubuntu 12.04
> Package: myspell-st 20070206-4
> ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
> Uname: Linux 3.2.0-23-generic-pae i686
> ApportVersion: 2.0.1-0ubuntu2
> Architecture: i386
> Date: Thu Apr 12 19:17:44 2012
> DuplicateSignature:
> Setting up myspell-st (20070206-4) ...
> Error: update-openoffice-dicts not present or executable. Missing
> dependency on dictionaries-common?
> dpkg: error processing myspell-st (--configure):
> subprocess installed post-installation script returned error exit
> status 1
> ErrorMessage: subprocess installed post-installation script returned
> error exit status 1
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
> PackageArchitecture: all
> SourcePackage: dict-st
> Title: package myspell-st 20070206-4 failed to install/upgrade:
> subprocess installed post-installation script returned error exit status 1
> UpgradeStatus: Upgraded to precise on 2012-02-26 (46 days ago)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/dict-st/+bug/980130/+subscriptions
>

Jan Groenewald (jan-aims) wrote :
Download full text (3.2 KiB)

Hi

This bug persists on raring.

I fetched the source for dict-st, and searched for update-openoffice in all
files, and did not find it.
And there is no postinst. It will require some digging around. It seems the
maintainer is not on the list of people subscribed to this bug?

0 jan@osprey:~$apt-cache show myspell-st|grep Maint
Maintainer: Matthias Klose <email address hidden>

Regards,
Jan

On 27 September 2013 14:16, Christopher M. Vanderwall-Brown <
<email address hidden>> wrote:

> Ian,
>
> I'm afraid this bug has been long standing and if anyone has a solution
> aside from uninstalling the package, it is beyond our knowledge. I simply
> learned to remove that particular spell pack to fix the problem. Otherwise,
> there is no known fix. I don't suppose you actually need that particular
> language package? If so, maybe, someone could come up with a solution for
> one that doesn't involve simply telling us to uninstall the package in
> question?
> On Sep 27, 2013 4:16 AM, "Ian Sayabo" <email address hidden> wrote:
>
> > anyone please i need your help>>>>>>>>>>>>>>>>>>>>>
> >
> > --
> > You received this bug notification because you are subscribed to the bug
> > report.
> > https://bugs.launchpad.net/bugs/980130
> >
> > Title:
> > package myspell-st 20070206-4 failed to install/upgrade: subprocess
> > installed post-installation script returned error exit status 1
> >
> > Status in “dict-st” package in Ubuntu:
> > Confirmed
> >
> > Bug description:
> > no detailsDescription: Ubuntu precise (development branch)
> > Release: 12.04
> >
> > ProblemType: Package
> > DistroRelease: Ubuntu 12.04
> > Package: myspell-st 20070206-4
> > ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
> > Uname: Linux 3.2.0-23-generic-pae i686
> > ApportVersion: 2.0.1-0ubuntu2
> > Architecture: i386
> > Date: Thu Apr 12 19:17:44 2012
> > DuplicateSignature:
> > Setting up myspell-st (20070206-4) ...
> > Error: update-openoffice-dicts not present or executable. Missing
> > dependency on dictionaries-common?
> > dpkg: error processing myspell-st (--configure):
> > subprocess installed post-installation script returned error exit
> > status 1
> > ErrorMessage: subprocess installed post-installation script returned
> > error exit status 1
> > InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386
> (20091028.5)
> > PackageArchitecture: all
> > SourcePackage: dict-st
> > Title: package myspell-st 20070206-4 failed to install/upgrade:
> > subprocess installed post-installation script returned error exit status
> 1
> > UpgradeStatus: Upgraded to precise on 2012-02-26 (46 days ago)
> >
> > To manage notifications about this bug go to:
> >
> >
> https://bugs.launchpad.net/ubuntu/+source/dict-st/+bug/980130/+subscriptions
> >
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/980130
>
> Title:
> package myspell-st 20070206-4 failed to install/upgrade: subprocess
> installed post-installation script returned error exit status 1
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+so...

Read more...

Download full text (5.6 KiB)

Thanks Jan.

Could we force the maintainer onto the bug list and contact them directly
so to remedy this bug once and for all? It would be a wonderful
improvement, since it has been around for ages--far too long.

With the whole OS vulnerable due to those recent bug discoveries, I think
now is about time we start clearing up the code.

If the maintainer won't fix it, could we please get some volunteers? Simple
broken code like this scares off adoption and makes nonprofit adoption less
viable due to tech support problems.

Chris
On Sep 27, 2013 8:01 AM, "Jan Groenewald" <email address hidden> wrote:

> Hi
>
> This bug persists on raring.
>
> I fetched the source for dict-st, and searched for update-openoffice in all
> files, and did not find it.
> And there is no postinst. It will require some digging around. It seems the
> maintainer is not on the list of people subscribed to this bug?
>
> 0 jan@osprey:~$apt-cache show myspell-st|grep Maint
> Maintainer: Matthias Klose <email address hidden>
>
>
> Regards,
> Jan
>
>
>
> On 27 September 2013 14:16, Christopher M. Vanderwall-Brown <
> <email address hidden>> wrote:
>
> > Ian,
> >
> > I'm afraid this bug has been long standing and if anyone has a solution
> > aside from uninstalling the package, it is beyond our knowledge. I simply
> > learned to remove that particular spell pack to fix the problem.
> Otherwise,
> > there is no known fix. I don't suppose you actually need that particular
> > language package? If so, maybe, someone could come up with a solution for
> > one that doesn't involve simply telling us to uninstall the package in
> > question?
> > On Sep 27, 2013 4:16 AM, "Ian Sayabo" <email address hidden> wrote:
> >
> > > anyone please i need your help>>>>>>>>>>>>>>>>>>>>>
> > >
> > > --
> > > You received this bug notification because you are subscribed to the
> bug
> > > report.
> > > https://bugs.launchpad.net/bugs/980130
> > >
> > > Title:
> > > package myspell-st 20070206-4 failed to install/upgrade: subprocess
> > > installed post-installation script returned error exit status 1
> > >
> > > Status in “dict-st” package in Ubuntu:
> > > Confirmed
> > >
> > > Bug description:
> > > no detailsDescription: Ubuntu precise (development branch)
> > > Release: 12.04
> > >
> > > ProblemType: Package
> > > DistroRelease: Ubuntu 12.04
> > > Package: myspell-st 20070206-4
> > > ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
> > > Uname: Linux 3.2.0-23-generic-pae i686
> > > ApportVersion: 2.0.1-0ubuntu2
> > > Architecture: i386
> > > Date: Thu Apr 12 19:17:44 2012
> > > DuplicateSignature:
> > > Setting up myspell-st (20070206-4) ...
> > > Error: update-openoffice-dicts not present or executable. Missing
> > > dependency on dictionaries-common?
> > > dpkg: error processing myspell-st (--configure):
> > > subprocess installed post-installation script returned error exit
> > > status 1
> > > ErrorMessage: subprocess installed post-installation script returned
> > > error exit status 1
> > > InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386
> > (20091028.5)
> > > PackageArchitecture: all
> > > SourcePackage: dict-st
> >...

Read more...

Jan Groenewald (jan-aims) wrote :
Download full text (6.8 KiB)

Hi

I cc'ed the maintainer on my last post. Perhaps he was not awware of this
but can help point us at the right person to fix it, or fix it, or at least
investigate. Let's give him a few days to have time to look at this message.

Regards,
Jan

On 27 September 2013 17:06, Christopher M. Vanderwall-Brown <
<email address hidden>> wrote:

> Thanks Jan.
>
> Could we force the maintainer onto the bug list and contact them directly
> so to remedy this bug once and for all? It would be a wonderful
> improvement, since it has been around for ages--far too long.
>
> With the whole OS vulnerable due to those recent bug discoveries, I think
> now is about time we start clearing up the code.
>
> If the maintainer won't fix it, could we please get some volunteers? Simple
> broken code like this scares off adoption and makes nonprofit adoption less
> viable due to tech support problems.
>
> Chris
> On Sep 27, 2013 8:01 AM, "Jan Groenewald" <email address hidden> wrote:
>
> > Hi
> >
> > This bug persists on raring.
> >
> > I fetched the source for dict-st, and searched for update-openoffice in
> all
> > files, and did not find it.
> > And there is no postinst. It will require some digging around. It seems
> the
> > maintainer is not on the list of people subscribed to this bug?
> >
> > 0 jan@osprey:~$apt-cache show myspell-st|grep Maint
> > Maintainer: Matthias Klose <email address hidden>
> >
> >
> > Regards,
> > Jan
> >
> >
> >
> > On 27 September 2013 14:16, Christopher M. Vanderwall-Brown <
> > <email address hidden>> wrote:
> >
> > > Ian,
> > >
> > > I'm afraid this bug has been long standing and if anyone has a solution
> > > aside from uninstalling the package, it is beyond our knowledge. I
> simply
> > > learned to remove that particular spell pack to fix the problem.
> > Otherwise,
> > > there is no known fix. I don't suppose you actually need that
> particular
> > > language package? If so, maybe, someone could come up with a solution
> for
> > > one that doesn't involve simply telling us to uninstall the package in
> > > question?
> > > On Sep 27, 2013 4:16 AM, "Ian Sayabo" <email address hidden> wrote:
> > >
> > > > anyone please i need your help>>>>>>>>>>>>>>>>>>>>>
> > > >
> > > > --
> > > > You received this bug notification because you are subscribed to the
> > bug
> > > > report.
> > > > https://bugs.launchpad.net/bugs/980130
> > > >
> > > > Title:
> > > > package myspell-st 20070206-4 failed to install/upgrade: subprocess
> > > > installed post-installation script returned error exit status 1
> > > >
> > > > Status in “dict-st” package in Ubuntu:
> > > > Confirmed
> > > >
> > > > Bug description:
> > > > no detailsDescription: Ubuntu precise (development branch)
> > > > Release: 12.04
> > > >
> > > > ProblemType: Package
> > > > DistroRelease: Ubuntu 12.04
> > > > Package: myspell-st 20070206-4
> > > > ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
> > > > Uname: Linux 3.2.0-23-generic-pae i686
> > > > ApportVersion: 2.0.1-0ubuntu2
> > > > Architecture: i386
> > > > Date: Thu Apr 12 19:17:44 2012
> > > > DuplicateSignature:
> > > > Setting up myspell-st (20070206-4) ...
> > > > Erro...

Read more...

Download full text (9.0 KiB)

Thanks Jan.

Yes, a few days would be a good idea. I'm marking this for reply later just
in case we don't hear anything.

Thanks again!

Chris
On Sep 27, 2013 8:38 AM, "Jan Groenewald" <email address hidden> wrote:

> Hi
>
> I cc'ed the maintainer on my last post. Perhaps he was not awware of this
> but can help point us at the right person to fix it, or fix it, or at least
> investigate. Let's give him a few days to have time to look at this
> message.
>
> Regards,
> Jan
>
>
> On 27 September 2013 17:06, Christopher M. Vanderwall-Brown <
> <email address hidden>> wrote:
>
> > Thanks Jan.
> >
> > Could we force the maintainer onto the bug list and contact them directly
> > so to remedy this bug once and for all? It would be a wonderful
> > improvement, since it has been around for ages--far too long.
> >
> > With the whole OS vulnerable due to those recent bug discoveries, I think
> > now is about time we start clearing up the code.
> >
> > If the maintainer won't fix it, could we please get some volunteers?
> Simple
> > broken code like this scares off adoption and makes nonprofit adoption
> less
> > viable due to tech support problems.
> >
> > Chris
> > On Sep 27, 2013 8:01 AM, "Jan Groenewald" <email address hidden> wrote:
> >
> > > Hi
> > >
> > > This bug persists on raring.
> > >
> > > I fetched the source for dict-st, and searched for update-openoffice in
> > all
> > > files, and did not find it.
> > > And there is no postinst. It will require some digging around. It seems
> > the
> > > maintainer is not on the list of people subscribed to this bug?
> > >
> > > 0 jan@osprey:~$apt-cache show myspell-st|grep Maint
> > > Maintainer: Matthias Klose <email address hidden>
> > >
> > >
> > > Regards,
> > > Jan
> > >
> > >
> > >
> > > On 27 September 2013 14:16, Christopher M. Vanderwall-Brown <
> > > <email address hidden>> wrote:
> > >
> > > > Ian,
> > > >
> > > > I'm afraid this bug has been long standing and if anyone has a
> solution
> > > > aside from uninstalling the package, it is beyond our knowledge. I
> > simply
> > > > learned to remove that particular spell pack to fix the problem.
> > > Otherwise,
> > > > there is no known fix. I don't suppose you actually need that
> > particular
> > > > language package? If so, maybe, someone could come up with a solution
> > for
> > > > one that doesn't involve simply telling us to uninstall the package
> in
> > > > question?
> > > > On Sep 27, 2013 4:16 AM, "Ian Sayabo" <email address hidden> wrote:
> > > >
> > > > > anyone please i need your help>>>>>>>>>>>>>>>>>>>>>
> > > > >
> > > > > --
> > > > > You received this bug notification because you are subscribed to
> the
> > > bug
> > > > > report.
> > > > > https://bugs.launchpad.net/bugs/980130
> > > > >
> > > > > Title:
> > > > > package myspell-st 20070206-4 failed to install/upgrade:
> subprocess
> > > > > installed post-installation script returned error exit status 1
> > > > >
> > > > > Status in “dict-st” package in Ubuntu:
> > > > > Confirmed
> > > > >
> > > > > Bug description:
> > > > > no detailsDescription: Ubuntu precise (development branch)
> > > > > Release: 12.04
> > > > >
> > > > > ProblemType: Package
> > > > > ...

Read more...

Michael Bienia (geser) on 2014-04-26
description: updated
Michael Bienia (geser) wrote :

dict-st (20070206-5) utopic; urgency=low

  * No-change rebuild to regenerate the myspell-st postinst script
    (fixes installation error in postinst, lp: #980130)

 -- Michael Bienia <email address hidden> Sat, 26 Apr 2014 10:19:57 +0200

Michael Bienia (geser) wrote :

dict-st (20070206-4ubuntu1) trusty-proposed; urgency=low

  * No-change rebuild to regenerate the myspell-st postinst script
    (fixes installation error in postinst, lp: #980130)

 -- Michael Bienia <email address hidden> Sat, 26 Apr 2014 10:19:57 +0200

Changed in dict-st (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → Medium
Changed in dict-st (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Brian Murray (brian-murray) wrote :

I've uploaded this thanks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dict-st - 20070206-5

---------------
dict-st (20070206-5) utopic; urgency=low

  * No-change rebuild to regenerate the myspell-st postinst script
    (fixes installation error in postinst, lp: #980130)
 -- Michael Bienia <email address hidden> Wed, 30 Apr 2014 12:16:35 -0700

Changed in dict-st (Ubuntu Utopic):
status: Triaged → Fix Released

Hello Emin, or anyone else affected,

Accepted dict-st into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/dict-st/20070206-4ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in dict-st (Ubuntu Trusty):
status: Triaged → Fix Committed
tags: added: verification-needed
description: updated
Download full text (5.5 KiB)

If the bug is finally fixed, I'd laugh on the floor rolling. I really
appreciate the effort. Got to admit, though, this has taken way too damn
long. :P
On May 1, 2014 9:05 AM, "Brian Murray" <email address hidden> wrote:

> Hello Emin, or anyone else affected,
>
> Accepted dict-st into trusty-proposed. The package will build now and be
> available at http://launchpad.net/ubuntu/+source/dict-
> st/20070206-4ubuntu1 in a few hours, and then in the -proposed
> repository.
>
> Please help us by testing this new package. See
> https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to
> enable and use -proposed. Your feedback will aid us getting this update
> out to other Ubuntu users.
>
> If this package fixes the bug for you, please add a comment to this bug,
> mentioning the version of the package you tested, and change the tag
> from verification-needed to verification-done. If it does not fix the
> bug for you, please add a comment stating that, and change the tag to
> verification-failed. In either case, details of your testing will help
> us make a better decision.
>
> Further information regarding the verification process can be found at
> https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in
> advance!
>
> ** Changed in: dict-st (Ubuntu Trusty)
> Status: Triaged => Fix Committed
>
> ** Tags added: verification-needed
>
> ** Description changed:
>
> + Errors Bucket
> + -------------
> +
> https://errors.ubuntu.com/problem/5b4d09e93387518a948363d42dafe41547c48934
> +
> +
> no detailsDescription: Ubuntu precise (development branch)
> Release: 12.04
>
> - ProblemType: Package
> - DistroRelease: Ubuntu 12.04
> + ProblemType: PackageDistroRelease: Ubuntu 12.04
> Package: myspell-st 20070206-4
> ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
> Uname: Linux 3.2.0-23-generic-pae i686
> ApportVersion: 2.0.1-0ubuntu2
> Architecture: i386
> Date: Thu Apr 12 19:17:44 2012
> DuplicateSignature:
> Setting up myspell-st (20070206-4) ...
> Error: update-openoffice-dicts not present or executable. Missing
> dependency on dictionaries-common?
> dpkg: error processing myspell-st (--configure):
> subprocess installed post-installation script returned error exit
> status 1
> - ErrorMessage: subprocess installed post-installation script returned
> error exit status 1
> - InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
> - PackageArchitecture: all
> - SourcePackage: dict-st
> + ErrorMessage: subprocess installed post-installation script returned
> error exit status 1InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release
> i386 (20091028.5)
> + PackageArchitecture: allSourcePackage: dict-st
> Title: package myspell-st 20070206-4 failed to install/upgrade:
> subprocess installed post-installation script returned error exit status 1
> UpgradeStatus: Upgraded to precise on 2012-02-26 (46 days ago)
>
> [Impact]
>
> "update-openoffice-dicts" got removed from dictionaries-common in
> version 1.12.0. But the postinst of myspell-st didn't get updated since
> then and makes the package uninstallable (fails in postinst).
>
> [Test Case]
>
>...

Read more...

Jan Groenewald (jan-aims) wrote :
Download full text (9.6 KiB)

Hi

On Trusty, this seems fixed with the new proposed package. First from
trusty main, then from trusty-proposed main:

1 jan@osprey:~$sudo apt-get install myspell-st
[sudo] password for jan:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  myspell-st
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 56,0 kB of archives.
After this operation, 205 kB of additional disk space will be used.
Get:1 http://za.archive.ubuntu.com/ubuntu/ trusty/main myspell-st all
20070206-4 [56,0 kB]
Fetched 56,0 kB in 1s (53,7 kB/s)
Selecting previously unselected package myspell-st.
(Reading database ... 417924 files and directories currently installed.)
Preparing to unpack .../myspell-st_20070206-4_all.deb ...
Unpacking myspell-st (20070206-4) ...
Processing triggers for postgresql-common (154) ...
Building PostgreSQL dictionaries from installed myspell/hunspell packages...
ERROR: no ecoding defined in /usr/share/hunspell/ar.aff, ignoring
  en_au
  en_ca
  en_gb
  en_us
  en_za
  fr
  st_za
Removing obsolete dictionary files:
Setting up myspell-st (20070206-4) ...
Error: update-openoffice-dicts not present or executable. Missing
dependency on dictionaries-common?
dpkg: error processing package myspell-st (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 myspell-st
E: Sub-process /usr/bin/dpkg returned an error code (1)
100 jan@osprey:~$echo "deb
http://archive.ubuntu.com/ubuntu/trusty-proposed main" | sudo tee -a
/etc/apt/sources.list.d/trusty-proposed.list
deb http://za.archive.ubuntu.com/ubuntu/ trusty-proposed main
0 jan@osprey:~$sudo apt-get update >/dev/null
0 jan@osprey:~$sudo apt-cache policy myspell-st
myspell-st:
  Installed: 20070206-4
  Candidate: 20070206-4ubuntu1
  Version table:
     20070206-4ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ trusty-proposed/main amd64
Packages
 *** 20070206-4 0
        500 http://za.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status
0 jan@osprey:~$sudo apt-get install myspell-st
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
  myspell-st
1 upgraded, 0 newly installed, 0 to remove and 64 not upgraded.
1 not fully installed or removed.
Need to get 26,2 kB of archives.
After this operation, 42,0 kB disk space will be freed.
Get:1 http://archive.ubuntu.com/ubuntu/ trusty-proposed/main myspell-st all
20070206-4ubuntu1 [26,2 kB]
Fetched 26,2 kB in 0s (27,2 kB/s)
(Reading database ... 417935 files and directories currently installed.)
Preparing to unpack .../myspell-st_20070206-4ubuntu1_all.deb ...
Unpacking myspell-st (20070206-4ubuntu1) over (20070206-4) ...
Processing triggers for postgresql-common (154) ...
Building PostgreSQL dictionaries from installed myspell/hunspell packages...
ERROR: no ecoding defined in /usr/share/hunspell/ar.aff, ignoring
  en_au
  en_ca
  en_gb
  en_us
  en_za
  fr
  st_za
Removing obsolete dictionary files:
Setting up myspell-st (20070206-4ubuntu1) ...
0 jan@osprey:~$sudo mv...

Read more...

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dict-st - 20070206-4ubuntu1

---------------
dict-st (20070206-4ubuntu1) trusty-proposed; urgency=low

  * No-change rebuild to regenerate the myspell-st postinst script
    (fixes installation error in postinst, lp: #980130)
 -- Michael Bienia <email address hidden> Wed, 30 Apr 2014 11:59:43 -0700

Changed in dict-st (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for dict-st has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Um. Thanks. Only took us two years. :P Well, let's hope it works.
On May 8, 2014 4:41 PM, "Brian Murray" <email address hidden> wrote:

> The verification of the Stable Release Update for dict-st has completed
> successfully and the package has now been released to -updates.
> Subsequently, the Ubuntu Stable Release Updates Team is being
> unsubscribed and will not receive messages about this bug report. In
> the event that you encounter a regression using the package from
> -updates please report a new bug using ubuntu-bug and tag the bug report
> regression-update so we can easily find any regresssions.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/980130
>
> Title:
> package myspell-st 20070206-4 failed to install/upgrade: subprocess
> installed post-installation script returned error exit status 1
>
> Status in “dict-st” package in Ubuntu:
> Fix Released
> Status in “dict-st” source package in Trusty:
> Fix Released
> Status in “dict-st” source package in Utopic:
> Fix Released
>
> Bug description:
> Errors Bucket
> -------------
>
> https://errors.ubuntu.com/problem/5b4d09e93387518a948363d42dafe41547c48934
>
>
> no detailsDescription: Ubuntu precise (development branch)
> Release: 12.04
>
> ProblemType: PackageDistroRelease: Ubuntu 12.04
> Package: myspell-st 20070206-4
> ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
> Uname: Linux 3.2.0-23-generic-pae i686
> ApportVersion: 2.0.1-0ubuntu2
> Architecture: i386
> Date: Thu Apr 12 19:17:44 2012
> DuplicateSignature:
> Setting up myspell-st (20070206-4) ...
> Error: update-openoffice-dicts not present or executable. Missing
> dependency on dictionaries-common?
> dpkg: error processing myspell-st (--configure):
> subprocess installed post-installation script returned error exit
> status 1
> ErrorMessage: subprocess installed post-installation script returned
> error exit status 1InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release
> i386 (20091028.5)
> PackageArchitecture: allSourcePackage: dict-st
> Title: package myspell-st 20070206-4 failed to install/upgrade:
> subprocess installed post-installation script returned error exit status 1
> UpgradeStatus: Upgraded to precise on 2012-02-26 (46 days ago)
>
> [Impact]
>
> "update-openoffice-dicts" got removed from dictionaries-common in
> version 1.12.0. But the postinst of myspell-st didn't get updated
> since then and makes the package uninstallable (fails in postinst).
>
> [Test Case]
>
> Installing myspell-st fails in the postinst with the above mentioned
> error in postinst.
> Installing the fixed package finishes without error.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/dict-st/+bug/980130/+subscriptions
>

Hans Joachim Desserud (hjd) wrote :

Hello, I came across this bug due to bug 1471075 which I belive is a duplicate. I see there fix was released for 14.04 in an SRU. Any thoughts on a fix for 12.04?

To post a comment you must log in.