Newlines effective in text even if --cr-wrap is not used

Bug #1611969 reported by Jarno Suni on 2016-08-10
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
dialog (Debian)
Fix Released
Unknown
dialog (Ubuntu)
Undecided
Unassigned

Bug Description

e.g.
dialog --infobox "a
b" 10 10

a and b are in separate lines on the dialog. Manual page says:
--cr-wrap
Interpret embedded newlines in the dialog text as a newline on the screen. Otherwise, dialog will only wrap lines where needed to fit inside the text box.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: dialog 1.3-20160209-1
ProcVersionSignature: Ubuntu 4.4.0-31.50-generic 4.4.13
Uname: Linux 4.4.0-31-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CurrentDesktop: XFCE
Date: Wed Aug 10 23:49:35 2016
EcryptfsInUse: Yes
InstallationDate: Installed on 2015-11-21 (263 days ago)
InstallationMedia: Xubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
SourcePackage: dialog
UpgradeStatus: Upgraded to xenial on 2016-06-24 (47 days ago)

Jarno Suni (jarnos) wrote :
Antoine BERNARD (abernard) wrote :

Bug confirmed on debian sid.

It seems to be a bug in upstream. The bug is still present in 1.3-20170509.

I made a diff based on last upstream release.

Changed in dialog (Ubuntu):
status: New → Confirmed
Changed in dialog (Debian):
importance: Undecided → Unknown
status: New → Unknown
Changed in dialog (Debian):
status: Unknown → Confirmed

The attachment "dialog_c_wrap.diff" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Jarno Suni (jarnos) wrote :

Currently newline character become ineffective only, if --trim is used or there is "\n" in the text and --no-nl-expand is not used (except for the newlines expanded from "\n").

It must not be that complicated. If the default is that newlines are converted (except for expanded ones) it should be so; there should be no effect by --trim or --no-nl-expand or embedded "\n", but only by --cr-wrap. --trim is just for eliminating leading blanks, right?

Changed in dialog (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.