No network error when making call

Bug #1512851 reported by Ari Börde Kröyer on 2015-11-03
26
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Bill Filler
dialer-app (Ubuntu)
Critical
Tiago Salem Herrmann

Bug Description

When the dialer app is not running and I get redirected to it in order to make a call, the first time I hit the "call" button I invariably get the error message: "no network" even though the phone is connected to the GSM network. (My phone has the language set to Norwegian, so I am guessing this is the English equivalent to the message I get.)

Here is what I do in detail:
- I choose a number from the contacts list
- I hit the phone icon next to the number to make a call,
- the dialer app screen opens
- I hit the "call" button,
- message "no network"

The status bar at the top shows the phone has a GSM connection the whole time.

When I try again a couple of seconds later, the call gets placed normally.

The same thing happens when switching from the messaging app to the dialer in order to call the person I have been texting.

However, if I wait a moment after entering the dialer before pressing the "call" button, everything runs normally.

If the dialer-app is already active in the background when the redirection happens, the bug does not occur.

Some kind of slow start issue? Screen appearing before the app is actually ready to take the command?

Related branches

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, what device and image version are you using?

Changed in dialer-app (Ubuntu):
importance: Undecided → High

I am using the BQ aquaris E4.5 running 15.04 r26.
Ari

Den 04. nov. 2015 08:18, skrev Sebastien Bacher:
> Thank you for your bug report, what device and image version are you
> using?
>
> ** Changed in: dialer-app (Ubuntu)
> Importance: Undecided => High
>

Bill Filler (bfiller) on 2015-11-04
Changed in dialer-app (Ubuntu):
assignee: nobody → Gustavo Pichorim Boiko (boiko)
status: New → Triaged
Changed in canonical-devices-system-image:
milestone: none → backlog
assignee: nobody → Bill Filler (bfiller)
importance: Undecided → High
status: New → Triaged
Cédric Bellegarde (gnumdk) wrote :

Same here, OTA7 and meizu phone.

Operator: Orange France

Bill Filler (bfiller) on 2015-11-10
Changed in canonical-devices-system-image:
milestone: backlog → ww02-2016
Changed in dialer-app (Ubuntu):
importance: High → Critical
Changed in canonical-devices-system-image:
importance: High → Critical
Krishna (phanikbr) wrote :

Few more steps to reproduce this issue -

Open Today's Scope > Touch any favourite contact > Hit Call > Takes you to Dialer App > Hit Dial icon> No Network Found >Hit Dial icon again. The call is placed.

Device - BQ Aquaris E5
Current Version - OTA 8

Bill Filler (bfiller) on 2015-12-01
Changed in dialer-app (Ubuntu):
assignee: Gustavo Pichorim Boiko (boiko) → Tiago Salem Herrmann (tiagosh)
Changed in canonical-devices-system-image:
status: Triaged → In Progress
Changed in dialer-app (Ubuntu):
status: Triaged → In Progress
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dialer-app - 0.1+16.04.20151207-0ubuntu1

---------------
dialer-app (0.1+16.04.20151207-0ubuntu1) xenial; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.
  * Resync trunk.

  [ Tiago Salem Herrmann ]
  * Disable call button while telepathy is not ready. (LP: #1512851)

 -- Tiago Salem Herrmann <email address hidden> Mon, 07 Dec 2015 17:54:37 +0000

Changed in dialer-app (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers