[phone-app] + [messaging-app] + [address-book-app] list tug actions should collapse after user moves view

Bug #1383870 reported by Olga Kemmet on 2014-10-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Music App
Undecided
Andrew Hayzen
Ubuntu UX
High
Olga Kemmet
address-book-app
Undecided
Renato Araujo Oliveira Filho
address-book-app (Ubuntu)
Undecided
Unassigned
dialer-app (Ubuntu)
Undecided
Unassigned
messaging-app (Ubuntu)
Undecided
Unassigned
ubuntu-ui-toolkit (Ubuntu)
High
Zsombor Egri
Vivid
Undecided
Unassigned
ubuntu-ui-toolkit (Ubuntu RTM)
Undecided
Unassigned

Bug Description

build r120

Steps to reproduce:
1. open phone app
2. carry out a bottom edge swipe to access your RECENT
3. swipe any list item to the left or right
4. now scroll your list view a little bit down or up, make sure the list item actions stay in view

Actual Result: the actions remain on the screen, they only collapse if it hides behind the header or bottom of the view

Expected result: if user starts to scroll the list view while a list item shows additional actions, the list item should collapse.
Users are carrying out a different actions in that case and are likely not being interested anymore in the revealed list item actions.

Same behaviour applies for the messaging app and the address-book-app.

Related branches

summary: - [phone-app] list tug actions should collapse after user moves view
+ [phone-app] + [messaging-app] + [address-book-app] list tug actions
+ should collapse after user moves view
description: updated
Changed in ubuntu-ux:
assignee: nobody → Olga Kemmet (olga-kemmet)
importance: Undecided → High
status: New → Fix Committed
Tim Peeters (tpeeters) wrote :

I am marking this bug as invalid for ubuntu-ui-toolkit, because the UITK does not have support (yet) for left/right swiping of list actions (that will be added in Ubuntu.Components 1.2, not for rtm). The apps currently have a custom implementation of this feature so it needs to be fixed there.

Changed in ubuntu-ui-toolkit:
status: New → Invalid
Olga Kemmet (olga-kemmet) wrote :

Marking back to "new" because the tag says ota-1. We are aware that this can not be done for rtm.

Changed in ubuntu-ui-toolkit:
status: Invalid → New
Tim Peeters (tpeeters) on 2014-11-17
Changed in ubuntu-ui-toolkit:
assignee: nobody → Zsombor Egri (zsombi)
Zsombor Egri (zsombi) on 2014-11-17
Changed in ubuntu-ui-toolkit:
status: New → Triaged
importance: Undecided → High
status: Triaged → In Progress
Zoltan Balogh (bzoltan) on 2014-11-24
Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Zsombor Egri (zsombi)
importance: Undecided → High
status: New → In Progress
Zoltan Balogh (bzoltan) on 2014-11-24
no longer affects: ubuntu-ui-toolkit
Zsombor Egri (zsombi) wrote :

The new ListItem can operate on this, however needs 1.2 imports, which is yet in unstable state. AFAIK the apps linked are not using the toolkit's list items, thus for RTM and OTA-1, their fix must be proprietary one. Depending which OTA will take Vivid, this can be ported to use teh new ListItem from toolkit.

Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 1.1.1364+15.04.20141209-0ubuntu1

---------------
ubuntu-ui-toolkit (1.1.1364+15.04.20141209-0ubuntu1) vivid; urgency=medium

  [ Zsombor Egri ]
  * Theming fixes: application theming, binding loop fix, auto-theming
    moved into MainView and it is applicable only on Ambiance and
    SuruDark, SuruGradient is no longer auto-themed.
    Fixes: LP: #1213043, LP: #1277647, LP: #1330510, LP: #1356779,
           LP: #1389792.
  * ServiceProperties component to Ubuntu.Components 1.1.
    Fixes: LP: #1391877.
  * New ListItem component base. Support for leading/trailing actions.
    Exported in Ubuntu.Components 1.2 UNSTABLE release.
    Fixes: LP: #1097728, LP: #1372592, LP: #1383870.
  * removing failing ServiceProperties and app-theming branches
  * Application theming ant other theming related binding loop fixes
  * ServiceProperties DBus property watcher

  [ Christian Dywan ]
  * Do the default theme check properly: for non-debug and without
    build errors.
  * Don't activate the control in ListItem.Standard implicitly.
    Fixes: LP: #1372563.
  * Improve AutoPilot caret dragging test cases.
  * Use new qt_gl_set_global_share_context setter with Qt 5.4.
    Fixes: LP: #1397979.
  * Add sortCaseSensitivity to the SortFilterModel example.
    Fixes: LP: #1391034.
  * Change offending links into bold font. Fixes: LP: #1395011.

  [ Daniel d'Andrada ]
  * This is needed by unity8 for the "shell rotation" feature (ie
    shell does all the rotation work instead of apps rotating
    themselves). unity8's dialogs (like the power dialog when you
    long press the power button) should follow its parent item
    rotation and size, as one would expect, and not be sneakily
    reparented to the scene root item, in which case the shell
    UI would be rotated but its dialog would not.
    Related bug LP: #1394511. Fixes: LP: #1394511.

  [ Tim Peeters ]
  * Remove the old header separator style. Fixes: LP: #1372590.

  [ Loïc Molinari ]
  * Made the UCAlarmPrivate destructor private.

  [ Ubuntu daily release ]
  * New rebuild forced
 -- Ubuntu daily release <email address hidden> Tue, 09 Dec 2014 11:47:33 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Fix Committed → Fix Released
Andrew Hayzen (ahayzen) on 2015-01-09
Changed in music-app:
assignee: nobody → Andrew Hayzen (andrew-hayzen)
status: New → In Progress

Fix committed into lp:music-app at revision 773, scheduled for release in music-app, milestone music-app-14.10-week-40

Changed in music-app:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package address-book-app - 0.2+15.04.20150111-0ubuntu1

---------------
address-book-app (0.2+15.04.20150111-0ubuntu1) vivid; urgency=low

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Renato Araujo Oliveira Filho ]
  * Reset ListWithAction swipe state if list view start to flicking (LP:
    #1383870)
  * Replaced "X" (close icon) to "<" (back icon) on application header.
    (LP: #1373517, #1373494)
  * Implemented search for unaccented contact names. (LP: #1367906)
  * Fix check for keyboard visibility. (LP: #1404309)
 -- Ubuntu daily release <email address hidden> Sun, 11 Jan 2015 23:38:55 +0000

Changed in address-book-app (Ubuntu):
status: New → Fix Released
Andrew Hayzen (ahayzen) on 2015-01-15
Changed in music-app:
status: Fix Committed → Fix Released
Changed in address-book-app:
status: New → Fix Committed
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
no longer affects: messaging-app
no longer affects: dialer-app (Ubuntu)
affects: dialer-app → dialer-app (Ubuntu)
Changed in address-book-app:
status: Fix Committed → Fix Released
Olga Kemmet (olga-kemmet) wrote :

I am not sure why this is marked as "fix released" because this issue still persist on vivid. At least for the telephony apps.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers