ofono dropping requests to SendTones

Bug #1268648 reported by Pat McGowan on 2014-01-13
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
dialer-app (Ubuntu)
Critical
Tiago Salem Herrmann
ofono (Ubuntu)
Critical
Tony Espy
telepathy-ofono (Ubuntu)
Undecided
Unassigned

Bug Description

Anytime the user needs to enter numbers while in a call, as in a conference call or automated service, not all of the keys that are shown in the app are actually sent. This bug has been present for over 6 months as part of bug #1187453. FIing separately here as the other is really a different issue.

This may be a timing thing depending on how fast you type, it does not seem very consistent.
It definitely does not occur when long deliberate presses are used.

Turned debug on in ofonod then
tail -f /var/log/syslog | grep DTMF

You will often see the number of the phone app UI but not in the log

Related branches

Pat McGowan (pat-mcgowan) wrote :

To enable tracing, edit the /etc/init/ofono.conf file and add these two lines before the exec

env OFONO_RIL_TRACE=y
export OFONO_RIL_TRACE

Tiago Salem Herrmann (tiagosh) wrote :

This seems to happen even when using the ofono simulator:

Tones sent to ofono by tp-ofono:

method call sender=:1.2545 -> dest=org.ofono serial=55 path=/phonesim; interface=org.ofono.VoiceCallManager; member=SendTones
   string "1"
method call sender=:1.2545 -> dest=org.ofono serial=56 path=/phonesim; interface=org.ofono.VoiceCallManager; member=SendTones
   string "2"
method call sender=:1.2545 -> dest=org.ofono serial=57 path=/phonesim; interface=org.ofono.VoiceCallManager; member=SendTones
   string "3"
method call sender=:1.2545 -> dest=org.ofono serial=58 path=/phonesim; interface=org.ofono.VoiceCallManager; member=SendTones
   string "4"

Actual tones processed by the simulator:

AT+VTS=1 :
OK

AT+VTS=2 :
OK

AT+VTS=4 :
OK

Bill Filler (bfiller) on 2014-01-13
Changed in ofono (Ubuntu):
assignee: nobody → Tony Espy (awe)
importance: Undecided → Critical
summary: - Not all key presses are sent during calls
+ ofono dropping requests to SendTones
Changed in ofono (Ubuntu):
status: New → In Progress
Changed in dialer-app (Ubuntu):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package telepathy-ofono - 0.2+14.04.20140117-0ubuntu1

---------------
telepathy-ofono (0.2+14.04.20140117-0ubuntu1) trusty; urgency=low

  [ Tiago Salem Herrmann ]
  * Check if the previous sendTones() succeeded before sending more
    tones. (LP: #1268648)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 59
 -- Ubuntu daily release <email address hidden> Fri, 17 Jan 2014 01:01:57 +0000

Changed in telepathy-ofono (Ubuntu):
status: New → Fix Released
Jamie Strandboge (jdstrand) wrote :

I upgraded to r132 then installed this package manually, and rebooted. I then dialed voicemail a couple of times and put my PIN in as fast as I could and it worked great. For my purposes, this bug is resolved, but I'll let others decide to close dialer-app and ofono. Thanks!

Changed in dialer-app (Ubuntu):
status: In Progress → Fix Released
Changed in ofono (Ubuntu):
status: In Progress → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers