UML drawing tools' comment fields are too small to be usable

Bug #1011446 reported by Brian Allbee on 2012-06-11
96
This bug affects 21 people
Affects Status Importance Assigned to Milestone
dia (Ubuntu)
Undecided
Unassigned

Bug Description

Start dia, pull up the UML diagram items, create a class. Note that the comment on the main class window is a bit short - it's still usable, but it's definately short.

The comment field on the attributes tab is 1-3 pixels tall. Same for both comment-fields in the Operations tab.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: dia-gnome 0.97.2-5
ProcVersionSignature: Ubuntu 3.2.0-24.39-generic 3.2.16
Uname: Linux 3.2.0-24-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.0.1-0ubuntu8
Architecture: amd64
Date: Mon Jun 11 00:55:08 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
ProcEnviron:
 LANGUAGE=en_US:en
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: dia
UpgradeStatus: No upgrade log present (probably fresh install)

Brian Allbee (brian-allbee) wrote :
Brian Allbee (brian-allbee) wrote :

Attaching screencaps...

Brian Allbee (brian-allbee) wrote :
Brian Allbee (brian-allbee) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in dia (Ubuntu):
status: New → Confirmed
Michael Bewley (michael-bewley) wrote :

This is a pretty annoying bug... I see it exactly the same as the original poster.

brianbourke75 (brianbourke75) wrote :

I also have an issue with the current state of the comment section. As an interesting note while I have the properties dialog open and then switch themes to "High Contrast" this remedies the problem and you can then revert back to your usual theme. But if you switch to "High Contrast" and open a new properties dialog the comment section reverts back to the bugged state. So it appears like the act of switching remedies the issue.

Michael Bewley (michael-bewley) wrote :

brianbourke75's solution doesn't work for me (with property dialog open, switching theme makes no difference to the comment field size).

Marco Sturiale (marcosturiale) wrote :

brianbourke75's solution doesn't work for me too!
Anyone can fix this problem?

Pedro Torruella (ptorru) wrote :

Yes I can confirm this wron behavior as well

Rob Parker (rfdparker) wrote :

I too can confirm this bug with dia-gnome 0.97.2-5 on Ubuntu 12.04.3 (amd64).

I did however find another workaround - from http://osdir.com/ml/dia-list/2013-09/msg00034.html - whereby starting Dia with an environmental variable set to disable Ubuntu's overlay scrollbar does seem to stop the unwanted behaviour.

Therefore it would appear to me that this bug could well be down to an incompatibility between Dia and the aforementioned overlay scrollbar ('overlay-scrollbar'?).

Rob Parker (rfdparker) wrote :

Relating to the link in my last comment, the email at which it points appears to be from a GNOME bugzilla report - https://bugzilla.gnome.org/show_bug.cgi?id=689162 - regarding the issue, but that seems to be marked as a duplicate of https://bugzilla.gnome.org/show_bug.cgi?id=662728 which appears to have been closed with the conclusion that the root cause seems to be "some misbehaviour" in overlay-scrollbar.

I am still having the same issue with Ubuntu 13.10, Gnome Desktop and Dia 0.97.2. I have fixed it by editing the start script /usr/bin/dia to have the LIBOVERLAY_SCROLLBAR=0 before the dia launch. /usr/bin/dia is now as follows:

#!/bin/sh
#
# Wrapped that calls dia in integrated version
#

LIBOVERLAY_SCROLLBAR=0 dia-normal --integrated "$@"

This fixes the issue with the comment boxes as far as I can tell and still allows launching by calling dia from Alt+F2 or terminal.

Adam Novak (interfect) wrote :

I can confirm that the patch to /usr/bin/dia works on 12.04 as well. Can we get the maintainer to update the package to include the patch?

mobidyc (mobidyc-gmail) wrote :

Issue confirmed on Ubuntu 14.04 LTS.

running dia through the command:
LIBOVERLAY_SCROLLBAR=0 dia

solves the issue.

As a complete workaround, you can edit the desktop entry file : /usr/share/applications/dia.desktop

Exec=env LIBOVERLAY_SCROLLBAR=0 dia %F

Diego González (diegonz) wrote :

Same issue also confirmed on Ubuntu 16.04 LTS and 16.10.

The cleaner workaround I've achieved is to create a custom desktop entry with different file and app name (Name=Dia-X or whatever) on your "~/.local/share/applications/", adding "Exec=env LIBOVERLAY_SCROLLBAR=0 dia %F"
as mobidyc pointed.

Mauricio Ocón (mauocon) wrote :

I confim the issue in Ubuntu 16.04 LTS

daniel-underwood13's solution worked for me

$ sudo nano /usr/bin/dia

Change to

#!/bin/sh
#
# Wrapped that calls dia in integrated version
#

LIBOVERLAY_SCROLLBAR=0 dia-normal --integrated "$@"

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.