dhelp doesn't work with webserver

Bug #224763 reported by gborzi on 2008-04-30
2
Affects Status Importance Assigned to Milestone
dhelp (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: dhelp

Ubuntu version: Ubuntu 8.04
Package: dhelp version 0.6.6ubuntu3

I have installed dhelp along with a small webserver (boa) to be able to browse the docs in my system using firefox. I used dhelp+lighttpd on Gutsy 32bit 7.10 and it worked fine. But on Hardy (64bit) it doesn't work. When I run dhelp I can see the index but clicking on a document link all I get is a blank page. The only working documents are the "Debian Maxima Manual -- usage tips" located under /usr/share/doc/maxima-doc/tips/ui-tips.shtml. These are the only documents that have the .shtml extension. I tried lighttpd instead of boa, but there is the same problem, so I think it's a dhelp bug.

gborzi (gborzi) wrote :

I have solved the problem by running
sudo scrollkeeper-rebuilddb
followed by
sudo install-docs -I
and, in order to make searches
sudo /etc/cron.weekly/dhelp
This bug can be closed.

Bhavani Shankar (bhavi) wrote :

Closing this bug.

Changed in dhelp:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers