dhelp postinst error on gutsy->hardy upgrade

Bug #205308 reported by Macron on 2008-03-22
2
Affects Status Importance Assigned to Milestone
dhelp (Ubuntu)
High
Colin Watson

Bug Description

Binary package hint: update-manager

error during distribution upgrade 7.10 to 8.04 beta

ProblemType: Package
Architecture: i386
Date: Sun Mar 23 05:22:16 2008
DistroRelease: Ubuntu 8.04
ErrorMessage: ErrorMessage: SystemError in cache.commit(): E:Sub-process /usr/bin/dpkg returned an error code (1)

Package: update-manager 1:0.87.14
PackageArchitecture: all
SourcePackage: update-manager
Title: package update-manager 1:0.87.14 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): E:Sub-process /usr/bin/dpkg returned an error code (1)
Uname: Linux 2.6.22-14-generic i686

Related branches

Macron (macronsfx) wrote :
Michael Vogt (mvo) wrote :

Thank you for reporting this bug. It is confirmed but before I set it that way I want to ask for some more information. If even one replies with that information this bug can we considered as confirmed. Please attach the following files:
/var/log/dist-upgrade/main.log
/var/log/dist-upgrade/apt.log
/var/log/dist-upgrade/term.log
This can help us decide if this bug is really in update-manager or maybe in libc6.

Thanks in advance.

Changed in update-manager:
status: New → Incomplete

On Sun, Mar 23, 2008 at 5:22 PM, Michael Vogt <email address hidden>
wrote:

> Thank you for reporting this bug. It is confirmed but before I set it that
> way I want to ask for some more information. If even one replies with that
> information this bug can we considered as confirmed. Please attach the
> following files:
> /var/log/dist-upgrade/main.log
> /var/log/dist-upgrade/apt.log
> /var/log/dist-upgrade/term.log
> This can help us decide if this bug is really in update-manager or maybe
> in libc6.
>
> Thanks in advance.
>
>
> ** Changed in: update-manager (Ubuntu)
> Status: New => Incomplete
>
> --
> package update-manager 1:0.87.14 failed to install/upgrade: ErrorMessage:
> SystemError in cache.commit(): E:Sub-process /usr/bin/dpkg returned an
> error code (1)
> https://bugs.launchpad.net/bugs/205308
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Here is what causes the error:

Setting up doc-linux-html (2007.11-1) ...
/usr/lib/ruby/1.8/dhelp.rb:21:in `require': no such file to load -- bdb (LoadError)
        from /usr/lib/ruby/1.8/dhelp.rb:21
        from /usr/sbin/dhelp_parse:27:in `require'
        from /usr/sbin/dhelp_parse:27
dpkg: error processing doc-linux-html (--configure):
 subprocess post-installation script returned error exit status 1

Changed in update-manager:
importance: Undecided → High
milestone: none → ubuntu-8.04
status: Incomplete → Confirmed

Reproducible in a hardy system:

$ sudo apt-get install dhelp doc-linux-html
...
Setting up doc-linux-html (2007.11-1) ...
/usr/lib/ruby/1.8/dhelp.rb:21:in `require': no such file to load -- bdb (LoadError)
 from /usr/lib/ruby/1.8/dhelp.rb:21
 from /usr/sbin/dhelp_parse:27:in `require'
 from /usr/sbin/dhelp_parse:27
dpkg: error processing doc-linux-html (--configure):
 subprocess post-installation script returned error exit status 1

Colin Watson (cjwatson) wrote :

The problem here is that dhelp_parse is called before the package is configured, and the bdb.rb alternative isn't put in place until libdb4.2-ruby1.8 is configured, which happens to be after doc-linux-html. dhelp is only used opportunistically, so there's no dependency in place, which means this is going to be a bit tedious to fix.

Colin Watson (cjwatson) on 2008-04-06
Changed in dhelp:
assignee: nobody → kamion
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dhelp - 0.6.6ubuntu3

---------------
dhelp (0.6.6ubuntu3) hardy; urgency=low

  * Exit zero if the bdb module is not available; this usually indicates
    that dhelp is not configured yet (LP: #205308).

 -- Colin Watson <email address hidden> Sun, 06 Apr 2008 13:12:50 +0100

Changed in dhelp:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers