Please merge dhelp 0.6.5 (universe) from Debian unstable (main)

Bug #174239 reported by Marco Rodrigues on 2007-12-05
10
Affects Status Importance Assigned to Milestone
dhelp (Ubuntu)
Wishlist
Unassigned

Bug Description

dhelp (0.6.5) unstable; urgency=low
 .
   * Index *.pdf and *.txt. Otherwise, it seems only PDF files are indexed.
   * Add a rule for converting PS files to text prior to indexing.
   * Move pstotext to dependencies, because it is needed for indexing.
   * Add dhelp_fetcher.rb, a script to get the contents of a doc-base
     registered documentation file. It uncompresses PDF and PS files for easy
     viewing inside a browser.
   * Only index files, never directories (directories can be specified
     implicitly by a glob, but those aren't part of the documentation).
   * Fix a couple of problems on upgrade (Closes: #452873).
   * Fix some issues with offline mode.
   * Fix subsubsections in the generated documentation directory.
   * Add a hack to avoid 3rd party error messages at installation time.

Changed in dhelp:
assignee: nobody → gothicx
status: New → In Progress
importance: Undecided → Wishlist
Marco Rodrigues (gothicx) wrote :

The latest Ubuntu change from 0.5.25ubuntu1 isn't valid for 0.6.0, the Makefile works in a different way, so bashism is not present.

Another thing is that Sasa Bodiroza last release didn't include Sarah's changelog for version 0.5.24-0.1ubuntu1.

Marco Rodrigues (gothicx) wrote :
Changed in dhelp:
assignee: gothicx → nobody
status: In Progress → Confirmed
Richard Johnson (nixternal) wrote :

Something isn't right here. The last version (0.5.25) was sync'd from Debian, and wouldn't doing so remove Sarah's changelog entry which would also mean their aren't/weren't any remaining Ubuntu changes?

Also, if you were to make changes to the Makefile, wouldn't you do so with a patch and what is the reason for changing the version in the Makefile anyways?

Marco Rodrigues (gothicx) wrote :

You're right, I just need to keep the ubuntu changelog after the last sync, only Sasa Bodiroza one and not Sarah's.

I didn't make a patch, because this package doesn't provide a .diff.gz (i checked the last ubuntu release 0.5.25ubuntu1 and the way the changes are done ... directly in the files).

If I don't change VERSION it doesn't build, because the directory must be changed to "dhelp-0.6.0ubuntu1" (dch -i also do it automatically when adding the entry to changelog).

Marco Rodrigues (gothicx) wrote :
Marco Rodrigues (gothicx) wrote :

I've also reported a bug to Debian BTS about add "firefox" to Recommends, so I hope soon this can be synced. http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=454517

New version 0.6.5 was released yesterday :-(
http://packages.qa.debian.org/d/dhelp/news/20071206T231702Z.html

this is likely crack. Please don't upload this until i speak to pkern.

Uh? Would you mind saying *why* you're adding random recommends? You have a bug listed next to the change, which is this one. If that were right, this bug would be saying why the change should be done.

Surely iceweasel, which doesn't appear to be in ubuntu, should be changed to firefox, not the recommend added after it.

Changed in dhelp:
status: Confirmed → Incomplete
Daniel Holbach (dholbach) wrote :

Sarah: random recommends?
-Recommends: iceweasel | www-browser, xpdf-utils
+Recommends: iceweasel | firefox | www-browser, xpdf-utils

Firefox is what we support in Ubuntu. We do the same thing in other packages. I personally think that both methods (either adding 'firefox' or replacing 'iceweasel' with 'firefox') are OK. Both don't hurt, this one in fact hurts less!

And please, please, please try to be less hostile. It's definitely not OK to talk to each other like that in bug reports.

"(LP: #174239)" could be in the line above to indicated it's all about the merge bug. But that's only a minor thing.

Changed in dhelp:
assignee: nobody → gothicx
status: Incomplete → In Progress
description: updated

last i checked, the idea was to give reasons why we were making changes, for future merges, or other people touching the package, etc. Has this changed?

Ubuntu often gets blasted for changes with not much of a rationale given - added build deps, etc, and debian doesn't end up taking these changes. Surely we do not want to encourage people in this trend, where even ubuntu people cannot figure out the reasons for changes?

Daniel Holbach (dholbach) wrote :

There's nothing wrong asking for reasons. "this is likely crack." is something different.

Marco Rodrigues (gothicx) wrote :
Changed in dhelp:
assignee: gothicx → nobody
status: In Progress → Confirmed
Marco Rodrigues (gothicx) wrote :

Now with patch system implemented.. It's ok now ?

Sarah: I don't take crack =) only addicted to nicotine :(

LaserJock (laserjock) wrote :

I've uploaded the debdiff in comment 17, the one without using the patch system, as this is a native package. Additionally, it'd be nice to have a clearer and more detailed changelog entry. Thanks for the contribution.

Changed in dhelp:
status: Confirmed → Fix Committed
Marco Rodrigues (gothicx) wrote :

dhelp (0.6.5ubuntu1) hardy; urgency=low

  * Merge from Debian unstable. Remaining Ubuntu changes (LP: #174239):
    - Add firefox to Recommends in debian/rules.
    - Add "ubuntu1" to VERSION in Makefile.
    - Modify Maintainer value to match Debian-Maintainer-Field Spec.

dhelp (0.6.5) unstable; urgency=low

  * Index *.pdf and *.txt. Otherwise, it seems only PDF files are indexed.
  * Add a rule for converting PS files to text prior to indexing.
  * Move pstotext to dependencies, because it is needed for indexing.
  * Add dhelp_fetcher.rb, a script to get the contents of a doc-base
    registered documentation file. It uncompresses PDF and PS files for easy
    viewing inside a browser.
  * Only index files, never directories (directories can be specified
    implicitly by a glob, but those aren't part of the documentation).
  * Fix a couple of problems on upgrade (Closes: #452873).
  * Fix some issues with offline mode.
  * Fix subsubsections in the generated documentation directory.
  * Add a hack to avoid 3rd party error messages at installation time.

dhelp (0.6.0) unstable; urgency=low

  * Changed all the indexing system so it now searches in the registered
    document, instead of in the HTML directory generated by dhelp.
  * Make .dhelp files obsolete, just use doc-base files directly. They contain
    more information, maintenance is easier over all (we get rid of pointless
    conversions), and we get rid of bugs
    (Closes: #19076, #429233, #334789, #347980, #155054, #177668, #19076).
  * Clean up dhelp.pot file weirdness (Closes: #448211).
  * Removed the hardcoded HTML in favour of using templates, redesign the
    appearance of all pages, and made all those templates translatable to
    different languages using gettext.
  * Added configuration file to specify directories to search for doc-base
    files (Closes: #81405).
  * Add a special, "all" section with all the documents (Closes: #188258).
  * Show relevant portions of the results when searching (Closes: #272953).
  * Order sections (Closes: #283402).
  * Remove remaining debconf traces. Apart from not being used anymore, it was
    making the postinst wait for the indexing even if it was run in the
    background.
  * Depend on swish++ instead of just recommending it.
  * Recommend or suggest different packages that give preview on search
    results
  * Change mozilla-firefox dependency to iceweasel.

 -- Marco Rodrigues <email address hidden> Fri, 07 Dec 2007 18:11:44 +0000

Changed in dhelp:
status: Fix Committed → Fix Released
Marco Rodrigues (gothicx) wrote :

Thank you... can you tell me what's missing from the changelog ? so next time I won't forgot it...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.