Wireless network interface (ipw2200) does not have IP address after boot

Bug #34505 reported by Jordy Potman on 2006-03-11
32
Affects Status Importance Assigned to Milestone
dhcp3 (Ubuntu)
High
Unassigned

Bug Description

On an updated (11-03-2006) Dapper Flight 4 install the wireless network interface (ipw2200) on my Compal CL56 laptop does not get an IP address after boot. After running dhclient manually it does have an IP until the next reboot.

Immediately after boot:
$ ifconfig
eth1 Link encap:Ethernet HWaddr 00:0E:35:64:3E:EC
          inet6 addr: fe80::20e:35ff:fe64:3eec/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:21 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:60 (60.0 b) TX bytes:768 (768.0 b)
          Interrupt:10 Base address:0xe000 Memory:d0000000-d0000fff

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:5 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:272 (272.0 b) TX bytes:272 (272.0 b)

Run dhclient to get an IP address
$ sudo dhclient eth1
Password:
Internet Systems Consortium DHCP Client V3.0.3
Copyright 2004-2005 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

Listening on LPF/eth1/00:0e:35:64:3e:ec
Sending on LPF/eth1/00:0e:35:64:3e:ec
Sending on Socket/fallback
DHCPREQUEST on eth1 to 255.255.255.255 port 67
DHCPACK from 192.168.1.1
bound to 192.168.1.5 -- renewal in 104773 seconds.

Run ifconfig again to verify that eth1 now has an IP address
$ ifconfig
eth1 Link encap:Ethernet HWaddr 00:0E:35:64:3E:EC
          inet addr:192.168.1.5 Bcast:192.168.1.255 Mask:255.255.255.0
          inet6 addr: fe80::20e:35ff:fe64:3eec/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:30 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:650 (650.0 b) TX bytes:1104 (1.0 KiB)
          Interrupt:10 Base address:0xe000 Memory:d0000000-d0000fff

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:5 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:272 (272.0 b) TX bytes:272 (272.0 b)

Contents of /etc/network/interfaces (WEP keys X'ed out):
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface

iface eth1 inet dhcp
        # wireless-* options are implemented by the wireless-tools package
        wireless-mode managed
        wireless-essid HOME_WLAN
        wireless-key1 XXXXXXXXXXXXXXXXXXXXXXXXXX
        wireless-key XXXXXXXXXXXXXXXXXXXXXXXXXX

iface eth0 inet dhcp

iface ppp0 inet ppp
provider ppp0

auto eth1

Jeroen Lamain (jeroenlamain) wrote :

Also seen on DELL Inspiron D600 with Intel 2200BG.
Both Wireless and Broadcom onboard LAN don't get assigned an IP address.
Can be fixed by manually running dhclient eth0 and dhclient eth1

Also running /etc/init.d/networking restart does not fix it.
I choose DHCP in install.
I'm running Dapper flight 5.

Jordy Potman (jordypotman) wrote :

I also still see this on a fully updated (2006-03-23) Dapper Flight 5, but only on the wireless network interface. The wired network interface (RealTek RTL8139) works fine.

After sudo dhclient eth1host lookup in Firefox is very slow (Looking up launchpad.net... is visible in the status bar for a long time). Ping launchpad.net is instant though.

Output of dmesg | grep eth after running sudo dhclient eth1:
[4294686.603000] eth0: RealTek RTL8139 at 0xe0986000, 00:02:3f:08:0a:01, IRQ 10
[4294686.603000] eth0: Identified 8139 chip type 'RTL-8100B/8139D'
[4294725.662000] eth1: no IPv6 routers present

If any other information is needed for debugging, let me know!

Matt Zimmerman (mdz) on 2006-04-05
Changed in ifupdown:
assignee: nobody → keybuk

Please attach /var/log/udev and /var/run/network/ifstate from *before* you run dhclient manually.

Changed in ifupdown:
status: Unconfirmed → Needs Info

The fact the interface is UP is interesting, it suggests that ifup was run correctly and that dhclient simply failed to obtain an IP address.

Could you also attach a copy of "ps aux" from before you run dhclient manually.

Thanks

Jordy Potman (jordypotman) wrote :

I have just installed Dapper Flight 6 (not fully updated yet) and this problem has become a lot harder to reproduce. I've seen it only twice up to now in about 10 boots. I've saved the output of one of those times, see the following attachments.

I remember seeing something similar in Dapper Flight 4 (if I remember correctly). There the wireless network interface initially obtained an IP address after boot just fine, but that stopped working when I made some configuration changes required for the LaptopTestingTeam tests. I will continue testing Flight 6 to see if the problem occurs more often.

/var/log/udev when wireless network interface failed to get an IP.

/var/run/network/ifstate when wireless network interface failed to get an IP.

Output of ps aux when wireless network interface failed to get an IP.

dhclient3 is running, so this is almost certainly some kind of problem with dhclient3. This could also be a wireless-tools problem I guess, if assosciation hasn't happened yet. I'll remain subscribed to this.

Changed in ifupdown:
assignee: keybuk → nobody
Toby Smithe (tsmithe) wrote :

It seems that this is still the case in Dapper current. I have observed this for a period of time now, on my system, and it appears that dhclient still will not get a new IP even when the system is associated. That suggests to me it is not a wireless-tools problem, but one with the default dhclient configuration. I may look into tweaking my settings and reporting back with a patch, but don't count on it.

Toby Smithe (tsmithe) wrote :

What kind of info does this report still need?

Jordy Potman (jordypotman) wrote :

I have installed and tested the Dapper Release Candidate today and so far the wireless network interface always had an IP after boot. So this bug seems to be fixed (at least for me).

On Fri, 2006-05-26 at 20:43 +0000, Jordy Potman wrote:
> I have installed and tested the Dapper Release Candidate today and so
> far the wireless network interface always had an IP after boot. So this
> bug seems to be fixed (at least for me).
>

Have you tried booting up in an area with no signal from the Access
Point described in /etc/interfaces and then moving back into the area? I
use NetworkManager now, though, so this bug no longer affects me.

Nikopol (markboydell) wrote :

The issue seems to have become worse for me as not even dhclient will get me an IP address after boot on my ipw2200 (Dell Inspiron 1300). The only resolution to the problem is opening networkconfig and decativating then reactivating the wireless card. That will make it get an IP address but only then will that work.

Qishuai Liu (lqs) wrote :

Maybe dhclient doesn't know the wireless connection is not associated to an AP at this moment, and thinks the DHCP server is down.

Mark R. Johnson (johnsonmr) wrote :

It seems like I only have this problem after an IP lease expires. Rebooting does not fix the problem unless I do a "ifdown eth1" first. That will release the old IP address, but an "ifup eth1" will not assign a new address. I must reboot to get that working.

I'm also getting a couple of errors in the log file that might help. The first one is:

Oct 10 20:28:01 localhost ifplugd(eth1)[4525]: client: wpa_supplicant: failed to locate ctrl_interface socket, exiting

The second one is the repeated several times. It is:

Oct 10 20:28:55 localhost kernel: [17179823.272000] TKIP: replay detected: STA=00:13:10:d2:cf:98 previous TSC 000000000441 received TSC 00000000016a

Followed by:

Oct 10 20:29:04 localhost dhclient: No DHCPOFFERS received.
Oct 10 20:29:04 localhost dhclient: No working leases in persistent database - sleeping.

At that point, "iwconfig" will start showing some "RX invalid frag" errors.

eth1 (my cisco wireless card) is up after boot, but no ip address is assigned; running "/etc/init.d/networks restart" solves the problem.

I had no such hassle under dapper - could this be related?

Gregor (aguafuertes) wrote :

Hi,

very new to all this wireless stuff, so hopefully don't post something stupid, but I think I have a similar problem, using Edgy:

- my wireless adapter (Netgear WG111v2) is recognized and up, but I don't get an IP

- after runnig dhclient manually, everything works fine

- I first stumbled upon bug #37697, but then thought that it seems more like a dhclient problem.

Please let me know if I can help with any information.

Mark R. Johnson (johnsonmr) wrote :

I've looked at bugs 37697 and 37821. They describe many of the same issues, but are related to madwifi. I'm not using madwifi. I will look to see if I'm getting the AP MAC listed.

Jonathan H (jhuizingh) wrote :

I have what seems to be the same issue. I use the ipw2200 driver in feisty. knetworkmanager can not bring up a wep connection. If I disable knetworkmanager and run iwconfig and dhclient manually, the connection comes up perfectly.

I got to this point in a threat on ubuntuforums here: http://ubuntuforums.org/showthread.php?p=2637999

Please let me know if there is anymore information I can give.

I'm not sure this is the same issue, but it seems to be similar.

I generally put my laptop to sleep (echo mem > /sys/power/state) when transporting it between home and work. But when switching networks - or perhaps when a lease has expired? - it fails to bring interfaces back up. That is, they are up, but with no IP address assigned.

I've tried to do ifdown, which prints a message about releasing the previous IP, followed by ifup, which prints the usual DHCP broadcasts, but fails to get any reply. Normally, I'd question the DHCP server, but this has happened on several different networks now, and a reboot always fixes it.

I've tried to /etc/init.d/networking stop, and also killed NetworkManager and ..Dispatcher, as well as removed the (wired) LAN module (tg3) - the ipw3945 WiFi module seems to be in use, and I can't unload that.

I'm not running Gnome, btw, but I don't think networking should depend on a particular UI.

-k

Ketil Malde (ketil-ii) wrote :

Sorry, I guess I should add that this is on current Feisty, specifically:

Linux nmd9999 2.6.20-15-generic #2 SMP Sun Apr 15 07:36:31 UTC 2007 i686 GNU/Linux
  dhcp3-client 3.0.4-12ubuntu4
  network-manager 0.6.4-6ubuntu7

I wonder if that problem is actually a (single) problem of DHCP.

- I am using ndiswrapper (Broadcom Chipset, bcm43xx native driver disabled)
- NetworkManager cannot establish a connection at all (that is maybe a different problem. I uninstalled it completely)
- a network configuration was established via /etc/network/interfaces and wpa_supplicant; ifdown/ifup commands were registered in rc.local (without any effect!)
- After Ubuntu has started up in many cases a connection to the access point has not been established; I need to set it up manually (first "ifdown eth1" in order to close an existing connection, then ifup eth1)
- After connection has been corrupted (i. e. standby mode) I have to retry disconnecting/connection several times (my wlan device eth1 is not displayed in the ifconfig printout anymore after a wakeup from standby). The DHCP client first seemed to be the problem (did not get an IP address), but even after static IP configuration the problem has NOT been solved. However, connection on bootup is started correctly with a static IP.
- the dmesg printout often contains the error message "eth1: no IPv6 routers present". I tried to disable the ipv6 module - no effect
- I think I could reduce the number of disconnecting/connection retrials needed to connect by setting the ap_scan variable in wpa_supplicant.conf to 2 (formerly 1) but I don't know

I don't know if my problem is really the same problem as described above, but perhaps I can help to solve that bug on Ubuntu. Please contact me if you need further information!

Regards,

Rubeosis

/etc/network/interfaces

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

auto eth1
iface eth1 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

# iface eth1 inet static
# address 192.168.2.99
# netmask 255.255.255.0
# gateway 192.168.2.1
# wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
# auto eth1

# auto eth2
# iface eth2 inet dhcp

# auto ath0
# iface ath0 inet dhcp

# auto wlan0
# iface wlan0 inet dhcp

/etc/wpa_supplicant/wpa_supplicant.conf

ap_scan=2

network={
        ssid="XXX"
        scan_ssid=1
        proto=WPA
        key_mgmt=WPA-PSK
        pairwise=TKIP
        psk="XXX"
}

Rubeosis (faspie) wrote :

Sorry, this was the wrong place to report my problem. I am using Feisty 7.0.4.

Axel Bojer (axelb) wrote :

I am using Kubuntu 7.04 amd64 and I have the same problem with my wireless connection.
I can get an Internet connection by running dhclient ra0, but after restart I am without net again.
I have recently done a fresh install and on the old installation (also Kubuntu 7.04 amd64, but initially kubuntu 5.10 I think, then upgraded step by step to 7.04) it worked flawless, so I am not quite sure what the difference is.
diff /media/hda1/etc/dhcp3/dhclient.conf /etc/dhcp3/dhclient.conf (old/new dhclient file) gives nada, nothing.
diff /etc/network/interfaces /media/hda1/etc/network/interfaces also gives nothing significant.

I suspect though that the problem is, that I can not choose dhclient under "Execute script on connect" under "Kcontrol -- Internet and network -- Wireless network" This is because I have "Vendor 1"

right at the end, and I find no way of turning that off or changing it. I want to use my own "Configuration 1", but currently find no way of doing so.
I vaguely remember having wrestled with turning that "Vendor 1" off at another time, but can not remember how I did it :-(

Axel Bojer (axelb) wrote :

FIXED!

iface ra0 inet dhcp
wireless-essid My_network_name

in /etc/network/interfaces solved the problem. :-)
I do not know why this did not work at first just by choosing the same configuration with "System Settings -- Network settings" (which gives the same dialog as above mentioned). Oh well ...

I believe my problems were due to a different issue, namely excessive packages loss due to some kind of incompatibility between the Linux ipw3945 driver and my access point.

(See bug #103210 for more details)

-k

Launchpad Janitor (janitor) wrote :

[Expired for dhcp3 (Ubuntu) because there has been no activity for 60 days.]

Roman Yepishev (rye) wrote :

As a workaround, I commented out

ACTION=="add", RUN+="/sbin/start-stop-daemon --start --background --pidfile /var/run/network/bogus --startas /sbin/ifup -- --allow auto $env{INTERFACE}"

inside /etc/udev/rules.d/85-iupdown.rules.

It turns out that as soon as driver module gets loaded into the kernel, udev starts ifup which is not capable of bringing wpa_supplicant but still marks the interface as up (writing wlan0=wlan0 to the interfaces state list). During the boot sequence ifup is started again but won't do anything as the interface is already marked as "up".

Can it be fixed in some non-destructive way? i.e. prevent udef to start during the first module load but start afterwards...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers