[edit-patch] should take -p and -P options

Bug #620721 reported by Barry Warsaw on 2010-08-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
devscripts (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: ubuntu-dev-tools

I wrote up this page to describe one way to turn a Bazaar loom thread into a patch system patch:

https://wiki.ubuntu.com/DistributedDevelopment/Documentation/PatchSystem

It would be nice to be able to use edit-patch instead of quilt directly, but you also want edit-patch to accept the diff on stdin. To make this work correctly, at least with quilt, you'd need edit-patch to also supply quilt import's -P option to properly name the patch file it read from stdin.

Also, because bzr diff's default is -p0 but quilt import's default is -p1, you'd need edit-patch to accept quilt import's -p option to set the proper prefix level.

Benjamin Drung (bdrung) on 2010-11-24
Changed in ubuntu-dev-tools (Ubuntu):
importance: Undecided → Wishlist
Benjamin Drung (bdrung) on 2010-12-18
summary: - edit-patch should take -p and -P options
+ [edit-patch] should take -p and -P options
Benjamin Drung (bdrung) on 2011-05-29
affects: ubuntu-dev-tools (Ubuntu) → devscripts (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers