debuild clean fails on bionic

Bug #1764799 reported by David Lechner on 2018-04-17
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
devscripts (Ubuntu)
Undecided
Unassigned

Bug Description

When I run `debuild clean` (in a debian package source directory), I get the following error message:

---

 dpkg-buildpackage -rfakeroot -us -uc -ui clean
dpkg-buildpackage: error: unknown option or argument clean

Use --help for program usage information.
debuild: fatal error at line 1152:
dpkg-buildpackage -rfakeroot -us -uc -ui clean failed

---

I don't think this has to do with my source package, but just in case, it is available at https://github.com/ev3dev/opencv.git.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: devscripts 2.17.12ubuntu1
ProcVersionSignature: Ubuntu 4.15.0-13.14-generic 4.15.10
Uname: Linux 4.15.0-13-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.9-0ubuntu4
Architecture: amd64
CurrentDesktop: GNOME
Date: Tue Apr 17 11:29:15 2018
InstallationDate: Installed on 2013-05-13 (1799 days ago)
InstallationMedia: This
SourcePackage: devscripts
UpgradeStatus: No upgrade log present (probably fresh install)

David Lechner (dlech) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in devscripts (Ubuntu):
status: New → Confirmed
David Lechner (dlech) wrote :

I found a workaround:

    debuild -- clean

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers