devkit-disks-daemon crashed with SIGSEGV in dbus_g_method_return_error()

Bug #452208 reported by Tormod Volden on 2009-10-15
984
This bug affects 177 people
Affects Status Importance Assigned to Milestone
obsolete
Fix Committed
Undecided
Unassigned
devicekit-disks (Ubuntu)
High
Omar
Declined for Jaunty by Martin Pitt
Nominated for Lucid by Ryubluedragon
Karmic
Medium
Unassigned

Bug Description

Binary package hint: devicekit-disks

If you have been directed to this bug by apport, you have encountered a low-impact crash in the devicekit-disks package while running under the Ubuntu 9.10 liveCD environment. This crash has no known impact on the usability of the system, and is reported only because apport crash detection is enabled by default on the liveCD. We apologize for any inconvenience caused you by this crash dialog, and assure you that this error can be ignored. Please continue to report any other problems you encounter when using Ubuntu.

ProblemType: Crash
.etc.fstab:
 aufs / aufs rw 0 0
 tmpfs /tmp tmpfs nosuid,nodev 0 0
Architecture: i386
Date: Thu Oct 15 16:30:43 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/lib/devicekit-disks/devkit-disks-daemon
LiveMediaBuild: Ubuntu 9.10 "Karmic Koala" - Alpha i386 (20091015)
Package: devicekit-disks 007-2ubuntu2
ProcCmdLine: BOOT_IMAGE=/casper/vmlinuz noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz -- break=bottom console-setup/layoutcode=no
ProcCmdline: /usr/lib/devicekit-disks/devkit-disks-daemon
ProcEnviron:

ProcVersionSignature: Ubuntu 2.6.31-14.46-generic
SegvAnalysis:
 Segfault happened at: 0x19af1d <dbus_g_method_return_error+29>: mov 0x10(%esi),%edi
 PC (0x0019af1d) ok
 source "0x10(%esi)" (0x00000010) not located in a known VMA region (needed readable region)!
 destination "%edi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: devicekit-disks
StacktraceTop:
 dbus_g_method_return_error ()
 ?? ()
 ?? ()
 ?? ()
 ?? ()
Title: devkit-disks-daemon crashed with SIGSEGV in dbus_g_method_return_error()
Uname: Linux 2.6.31-14-generic i686
UserGroups:

dmi.bios.date: 09/26/2005
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F8
dmi.board.name: 8I945P Pro
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF8:bd09/26/2005:svn:pn:pvr:rvnGigabyteTechnologyCo.,Ltd.:rn8I945PPro:rvrx.x:cvn:ct3:cvr:

Tormod Volden (tormodvolden) wrote :

StacktraceTop:dbus_g_method_return_error (context=0x0, error=0x9f1c640)
throw_error (context=0x0, error_code=4,
devkit_disks_daemon_local_check_auth (daemon=0x9f11808,
devkit_disks_device_drive_ata_smart_refresh_data (
refresh_ata_smart_data (daemon=0x9f11808)

Changed in devicekit-disks (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public
JMFTheVCI (jmfthevci) wrote :

I had this bug. It caused my ext3 filesystem that it was attempting to shrink, instaling karmic alongside jaunty with dual-boot, to crash. The fsck -y /dev/sda5 took over 18 hours to complete to remove all the errors.

For this reason I think the bug should have a higher importance than medium!

papukaija (papukaija) on 2009-10-26
Changed in devicekit-disks (Ubuntu):
status: New → Confirmed
Matthew Lye (matthew.lye) wrote :

I had this one too, clean install using 2 ext4 partitions and a Swap with manual partitioning.
The partitions were preformatted and Ubuntu just had to install into them. Single disk with / partition and encrypted /home partition. I think this should be a higher priority.

manzur (sl-solaris) wrote :

I suggest that before delivering karmic koala we should fix this kind of bug in order to have a clean release, do you people agree?

David Wetta (david-wetta) wrote :

I had my bugs 462062, 461911, 461467 and 461454 marked as duplicates of this bug.

However I encounter this bug IMMEDIATELY after partman launches, and the partman page becomes unresponsive. This occurs when I have a USB stick or SD card plugged into my Asus EeePC 701G during the install (in addition to the USB stick I have the UNR 9.10 RC install media on).

No useful error messages appear in dmesg, /var/log/syslog, /var/log/messages or /var/log/partman.

[yes, me filing 4 bugs was excessive. I've used Ubuntu since dapper drake, but this is the first time I'm actively using Launchpad. And I had trouble tracking my bugs. Sorry about the multiple bug posts, but I'm doing better now.]

David Wetta (david-wetta) wrote :

RE: Importance: I'm unable to install UNR to a USB stick or SD card as a result of this bug. I've had no trouble doing so in other releases, including UNR 9.04. This is important to me, because I want to test a distro before committing it to my 4Gb SSD drive. This bug is preventing me from adopting UNR 9.10 on my netbook.

Also, I failed to mention above, installing with ubiquity -d doesn't seem to capture any relevant info in /var/log/debug either.

bwallum (rbw2) wrote :

Bug event when trying to install from CD

Marc Deslauriers (mdeslaur) wrote :

I got this trying to install netbook-remix 20091028.3 on a Dell Mini 9.

Marc Deslauriers (mdeslaur) wrote :

I can reproduce this every time. Install network-remix and when the installation is complete, wait 10-15 minutes and apport will show up in the notification area.

Martin Pitt (pitti) on 2009-10-28
Changed in devicekit-disks (Ubuntu Karmic):
assignee: nobody → Martin Pitt (pitti)
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

Wontfix for karmic. It primarily affects installation (we don't have anything else which makes use of inhibition), and it does not really break installation either. As a D-Bus activated service, dk-disks will just respawn if required, and apport is disabled in the final release, so users won't get spammed about the crash.

Changed in devicekit-disks (Ubuntu Karmic):
assignee: Martin Pitt (pitti) → nobody
status: In Progress → Won't Fix
Martin Pitt (pitti) wrote :

It's not trivially reproducible, though:

$ sudo devkit-disks --inhibit -- sleep 3600 &
$ devkit-disks --ata-smart-refresh /dev/sda
Refreshing ATA SMART data failed: Daemon is inhibited

and no crash. Trying harder..

Martin Pitt (pitti) wrote :

Ah, the previous test case wouldn't work because the devkit-disks tool uses d-bus calls which do have a DBusGMethodInvocation context. However, this crash is triggered by a daemon-internal call of ATA smart refresh (through the 30 minute timer), which does not have a context. So it's pretty clear what the problem is.

Reproducer: In src/devkit-disks-daemon.c, change ATA_SMART_REFRESH_INTERVAL_SECONDS to "30" so that it will refresh every 30 seconds, then let the daemon run, and inhibit it with "sudo devkit-disks --inhibit sleep 3600".

**** Refreshing ATA SMART data for /sys/devices/pci0000:00/0000:00:1f.1/host0/target0:0:0/0:0:0:0/block/sda
Segmentation fault

Martin Pitt (pitti) wrote :

I sent a detailled analysis to the upstream bug report. There are two valid approaches to fixing this, and I'll discuss with David first.

Martin Pitt (pitti) wrote :

Patch sent upstream for review/inclusion.

Changed in devicekit-disks (Ubuntu):
status: In Progress → Fix Committed

I'm adding this from the installation disk - I have not yet rebooted.

VERY long wait at 85% complete on the installation, finally completed, but the crash report symbol appeared in the upper tray (next to the clock, etc.). Apport claimed that this was a duplicate bug but suggested I add anything that I could think of, so here it is:

Dell Inspiron 530N
uname -a
     Linux ubuntu 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i686 GNU/Linux
1 GIG RAM
Ubuntu 9.10 RC valid iso burned to disk on 10-28-09, installation started 10-29-09 at approximately 7:00 AM MST (07:00 UTC-7 or 14:00 UTC). MD5SUM checked on iso prior to burning.

lowlux (lowlux) wrote :

CLEAN install... MD5 Checked. using desk top live CD

fix the damn bugs!

kira (kyrandesa) wrote :

I've just had the same.

Clean install from USB-boot medium with manual partitioning. I've told Ubuntu to install itself on my former windows partition, so I've formated that one. And the installer wanted to format my swap, a process that I couldn't turn off. The rest of my partitions should not have been touched.

I downloaded the IPV6 torrent about an hour ago.

Herber (bdj9999) wrote :

Using livedisk CD to install 9.10 and error occured. Installing on Dell inspiron 7000.

Jean-Luc Thirion (jlinho) wrote :

Using live CD to install 9.10. MD5 ok. Error appeared during installation process.
I used manual partitoning and EXT4 partitions on a Acer Aspire computer

wanderinrain (roc-tang) wrote :

Using live CD to install 9.10. MD5 ok. Error appeared during installation process.
I used manual partitioning and EXT4 partitions on a HP DV4 laptop (four partitions and all are primary: /boot, /, /home, swap).

r000t (vistro) wrote :

Error occurred when installing Karmic from install CD on Dell Latitude D610, Samsung Spinmaster 160GB HDD, Dell factory DVD+/- R/RW MediaBay drive.

I'm a tad worried to see how much my install just got fudged... hopefully nothing.

juancholo (juanrqg) wrote :

Regards to all
To my also me this mistake has appeared more or less on having completed 85 % of the instalcion.

That I must do? Is it something that should worry?

Even I have not restarted agredeceria very much a response..

Thank you..

Omegamormegil (omegamormegil) wrote :

You can more or less just ignore the problem, as the program that is failing restarts automatically.

Steve Langasek (vorlon) on 2009-10-30
description: updated
Dimbwinkle (glenwoodtelephone) wrote :

Happened twice during live installation. Disks are striped, other than that your typical system...

I'm installing 32bit 9.10 on a AMD X2 be-2400 with an ASUS board that has one 500gb SATA drive, sorry I'm not sure which info is relevant... I got this error during live install and the apt portion took a long time so I eventually suspected that the crash report might have damaged the install and started skipping portions that took a long time, I'm going to reboot and reinstall without going through the live desktop (I only started there because I needed to move some data around use GParted a little...)

Changed in devicekit:
status: Unknown → Confirmed
Serge K (sergek) wrote :

Detected while installing on Acer 3680-2682 laptop. Pentium-M 440 processor, 1,5 Gb RAM. Connected to te Internet via built-in Atheros Wi-Fi.

Analog Pilgrim (mailto-jon) wrote :

Error received in live desktop while installing 9.10 to 20GB ext4 primary partition of 1TB USB HD, created during manual configuration, beginning of drive, formatted during install, 0 swap space, boot loader not installed. Install is continuing (89%)... writing report from live desktop.

Analog Pilgrim (mailto-jon) wrote :

Repeated install just for fun... Same settings.. Error received during language pack download/install this time. Previous error popped during apt config.

Craig Jackson (craigmjackson) wrote :

Can confirm "Analog Pilgrim"'s version of the bug above. Occurred during language pack download/install. Any time there is a bug report it may turn off new users, so I personally consider this a high priority.

gdi2k (gdi2k) wrote :

Experienced this bug installing from amd64 Desktop CD using default settings (no encryption, auto partitioning). It occurred while configuring apt at around 80%. Installation did eventually continue after a very long pause.

Johan De Cauwer (jdeca57) wrote :

I'm currently installing and the bug occurred during the creation of the ext4 file system and it seemed to hang the installation (very long wait at 5%). It now continues. I remained patient thanks to previous comments. Thank you all and an advice for future victims: just wait.

Changed in devicekit:
status: Confirmed → Fix Released
Fredrik Staxäng (fstx01) wrote :

I get this when trying to install 9.10. I don't know if it is related to that I can't see my disk in ubiquity/partman.

Frisco Rose (friscorose) wrote :

install from livecd died and this was the notification. Install qwas to ext4 formatted root on sata disk. If this causes install to fail it should be higher than medium priority.

Martin Pitt (pitti) wrote :

Fixed in 009 in lucid.

Changed in devicekit-disks (Ubuntu):
status: Fix Committed → Fix Released
Zeniff (zeniffmartineau) wrote :

Decided to install a new 9.10 on my desktop after upgrading on my laptop (which got different bugs, not this one). Installing from the LiveCD desktop environment to ext3, not ext4.
Not sure when the crash happened, but I finally noticed the icon right before committing to the install.

Mr. Pitt said, "dk-disks will just respawn if required, and apport is disabled in the final release, so users won't get spammed about the crash."
But, I'm confused because I am using the final release and still get this crash, so I'm deciding to reboot and redo my options and commit to the install as fast as possible to see if I can avoid it before the install finishes...just in case.

Also, @Maria Klonner in comment #19, I had the opposite issue. I can not change the checkbox to allow swap to be formatted, but I thought it was supposed to format? I wonder if it's intended not to let us change the format/not format option for swap? Back when I first installed 9.04 I tried installing twice, but had some error about swap not being able to be mounted or something during install... But, after the having weird stuff happen on the first reboot, it seemed fine...

Nhorning (neilhorning) wrote :

This bug should have high priority.

When installing Karmic on a friends computer it was stalled at the point that it said "configuring apt." We waited a few minutes and then got this crash report. Then we waited another 2 and there was no movement, so we decided to hit "skip." This resulted in "apt" not being installed on his system.

I'm in here because I just had the same thing happen to me, and had the presence of mind not to hit "skip" this time. This bug will likely cause thousands of newbs like us to hit "skip" at a very important part of the installation process.

Dave Efflandt (efflandt) wrote :

I was installing from 9.10 release install CD on USB (generated from System, Adminstration, USB Startup Disk Creator before rearranging some partitions for fresh install). But install appears to have successfully completed, so I guess I will see if I have any issues when I reboot.

filip (bandit-s-fw) wrote :

I tried to install karmic on an external usb hdd. The installer crashes when writing grub to the disk. I think it is due to this bug.
To test i installed the lucid package and its dependency libdbus-glib-1-2 when running the livecd. Then the installer completed succesfully. Now i can boot but the bootproces keeps corrupting my filesystem, ext4 errors but i think that is an other bug.

Changed in devicekit-disks (Ubuntu):
assignee: Martin Pitt (pitti) → roohollah (roohollah-torshizi)
Allan Caeg (allancaeg) wrote :

I got a devkit-disks-daemon crash while installing Karmic 32bit. It appeared at about 80%. I'm not sure if it's exactly the same bug and am anxious about it. Maybe, I'm just being compulsive.

I didn't report it with apport. I just booted now on my fresh install and googled devkit-disks-daemon. Is there a chance that it's another bug. If so, how can it affect my system?

I feel like reformatting. hehe

Bengt Grahn (bengt-vikingsw) wrote :

It appears as if installing a media player, such as VLC, worsens the situation. I have been running 9.04 daily now for quite a while, and the problem appeared once. After installation of VLC, the problem appears a lot more frequently. Coincidence???

I got this bug installing from livecd, it shows Starting up the partitioner, scanning disks and gets stucked at 47%

Medium? are you people for real? i can't install it should be more important than that!

tags: added: iso-testing
Martin Pitt (pitti) wrote :

Well, I bumped the importance, but it won't change anything. It is fixed in lucid, and fixing it in karmic-updates won't help it happening on the final karmic CDs. We won't re-roll the karmic CDs.

This bug does not really break the installation, it just causes a confusing crash report in the live system. If the installer gets stuck, you have a different problem.

Changed in devicekit-disks (Ubuntu):
assignee: roohollah (roohollah-torshizi) → Martin Pitt (pitti)
importance: Medium → High
paulb104 (paulb104) wrote :

According to marcobra (Marco Braida) I've encountered this bug. See my description here:
https://answers.launchpad.net/ubuntu/+source/unr-meta/+question/91600

Is this bug my problem?

Jaap-Willem Dooge (japydooge) wrote :

I had this problem when installing 9.10 on a Dell Latitude D400 with a damaged (bad sectors) 60GB Siemens disk.

suguru (oouc) wrote :

I was trying to install 9.10 on a Toshiba Satellite with a new hard disk. I used PMagic 4.5 to copy Vista from the original hd and then copied all the Linux partitions from another hd. Since the Lx hd already had 9.10 but would not boot, I thought I would make a partition with 7.04 and data into home without formating the hd. The window locked up and would not let me do anything. It would not respond to forward, back, quit, delete, change, revert, or even to the close window . But other windows continued to work.

suguru (oouc) wrote :

I was trying to install 9.10 on a Toshiba Satellite with a new hard disk. I used PMagic 4.5 to copy Vista from the original hd and then copied all the Linux partitions from another hd. Since the Lx hd already had 9.10 but would not boot, I thought I would make a partition with 7.04 and data into home without formating the hd. The window locked up and would not let me do anything. It would not respond to forward, back, quit, delete, change, revert, or even to the close window . But other windows continued to work.

I moved forward by hitting the - button and getting another window and having the system rescan for partitions.

Ted (ted-kell) wrote :

According to Martin Pitt, "This bug does not really break the installation, it just causes a confusing crash report in the live system. " That may be true but when I boot the installed result, none of the windows I open once I login (ie, I click on any of my forders or start any process) have the minimize, full screen, or kill buttons inabled at the top of the window. Is this a result of this bug? If so, the resulting installation is unusable and needs to be fixed.

Ted [2009-11-28 23:14 -0000]:
> Is this a result of this bug?

No, that's completely unrelated. Most probably a problem with the
theme, did you install a custom theme in the past?

Hemant (h-patel) wrote :

tried several times and keeps producing the Error after 47% of the install. This on Toshiba Tecra 8100 with 9.48GB Disk and using the entire disk option.

jay (aztec1129) on 2009-12-23
Changed in devicekit-disks (Ubuntu):
status: Fix Released → Fix Committed
Martin Pitt (pitti) on 2009-12-23
Changed in devicekit-disks (Ubuntu):
status: Fix Committed → Fix Released
Peter Belew (peterbe) wrote :

This bug report popped up at the very end of an installation of Karmic from the live CD, on an Averatech 3280 laptop.

hm4af (delwar60) on 2010-01-04
Changed in devicekit-disks (Ubuntu):
status: Fix Released → Incomplete
Martin Pitt (pitti) on 2010-01-05
Changed in devicekit-disks (Ubuntu):
status: Incomplete → Fix Released
zombieaja (zondoank) on 2010-01-06
Changed in devicekit-disks (Ubuntu):
assignee: Martin Pitt (pitti) → zombieaja (zondoank)
elquds (rischa-23) on 2010-01-08
Changed in devicekit-disks (Ubuntu):
status: Fix Released → New
raul1175 (raul-reyes90) on 2010-01-11
Changed in devicekit-disks (Ubuntu):
status: New → Fix Committed
karla (karlota) on 2010-01-11
visibility: public → private
Martin Pitt (pitti) on 2010-01-12
visibility: private → public
Martin Pitt (pitti) on 2010-01-13
Changed in devicekit-disks (Ubuntu):
status: Fix Committed → Fix Released
assignee: zombieaja (zondoank) → Martin Pitt (pitti)
eman482 (luckyman482) on 2010-01-13
Changed in devicekit-disks (Ubuntu):
assignee: Martin Pitt (pitti) → eman482 (luckyman482)
Martin Pitt (pitti) on 2010-01-14
Changed in devicekit-disks (Ubuntu):
assignee: eman482 (luckyman482) → Martin Pitt (pitti)
www.tovar.nl (tovar-2009) wrote :

When I was installing Ubuntu Karmic Koala 64bit with a Brand NEW computer AMD64
I did get this bug. See the Picture. And I did it also get is when i was installing this
version ubuntu 9.10 on a Dell optiplex GX260 more then one time i did see the bug flying in my computer.
That's a BIG problem. Caus then when i restart the system. All the work for installing Ubuntu was and
will be blocked by this error over en over again and again.

Changed in devicekit-disks (Ubuntu):
status: Fix Released → Confirmed
status: Confirmed → Incomplete
Martin Pitt (pitti) on 2010-01-17
Changed in devicekit-disks (Ubuntu):
status: Incomplete → Fix Released
scalabrf (scalabrf) on 2010-01-18
Changed in devicekit-disks (Ubuntu):
status: Fix Released → Confirmed
Martin Pitt (pitti) wrote :

Pretty please do not change the status of this bug without explanation. It has been fixed in Lucid a while ago, and with every change you do you needlessly spam 65 people.

Changed in devicekit-disks (Ubuntu):
status: Confirmed → Fix Released
Hemant (h-patel) wrote :

Apologies. I am looking at how the fix to my problem can be applied such
that I can complete the install of the version 9.10.

Cheers
Hemant

Martin Pitt wrote:
> Pretty please do not change the status of this bug without explanation.
> It has been fixed in Lucid a while ago, and with every change you do you
> needlessly spam 65 people.
>
> ** Changed in: devicekit-disks (Ubuntu)
> Status: Confirmed => Fix Released
>
>

mazzini (odilon-mazzini) on 2010-01-23
Changed in devicekit-disks (Ubuntu):
status: Fix Released → Incomplete
Martin Pitt (pitti) on 2010-01-24
Changed in devicekit-disks (Ubuntu):
status: Incomplete → Fix Released
Changed in devicekit-disks (Ubuntu):
assignee: Martin Pitt (pitti) → mcmanigle (brian-mcmanigle)
Martin Pitt (pitti) on 2010-01-26
Changed in devicekit-disks (Ubuntu):
assignee: mcmanigle (brian-mcmanigle) → Martin Pitt (pitti)
ntarkos (ntarkos) wrote :

I got this trying install from a usb flash the ubuntu-karmik-amd64.
the usb flash i make with uneboot.

Mathilda Young (gtrsdk) wrote :

I just got it when booting off of a live disc from Canonical and when using the option to try Ubuntu.

metrjohn (metrjohn) wrote :

The bug occured while installing Ubuntu at the progress about 86-87% (loading language packages). The installation has paused. Waiting for continue.

Changed in devicekit-disks (Ubuntu):
assignee: Martin Pitt (pitti) → mdwiprasetyono (mdwiprasetyono)
Chris Coulson (chrisccoulson) wrote :

Will people please stop changing the status and assignee of this bug report. Every time you do this, you spam dozens of people who are subscribed.

Changed in devicekit-disks (Ubuntu):
assignee: mdwiprasetyono (mdwiprasetyono) → Martin Pitt (pitti)
walrus (bkfadeoner) on 2010-02-07
Changed in devicekit-disks (Ubuntu):
assignee: Martin Pitt (pitti) → walrus (bkfadeoner)
Changed in devicekit-disks (Ubuntu):
status: Fix Released → Confirmed
Martin Pitt (pitti) on 2010-02-07
Changed in devicekit-disks (Ubuntu):
assignee: walrus (bkfadeoner) → Martin Pitt (pitti)
status: Confirmed → Fix Released
Rohan (golwalkar-rohan) wrote :

This error came up while i was installing Ubuntu 9.10.
using 1 swap partition,root and home partition.
Installation is in progress as of now (86%) - will report if there are any other crashes.

Jonay (jonay-santana) wrote :

During install, it came up. Right now it seems to affect in no way the installation progress.

owlcity (matrix-d-n) on 2010-02-13
Changed in devicekit-disks (Ubuntu):
assignee: Martin Pitt (pitti) → owlcity (matrix-d-n)
Changed in devicekit-disks (Ubuntu):
assignee: owlcity (matrix-d-n) → Martin Pitt (pitti)
eviltizzy (eviltizzy) wrote :

installing ubuntu 9.10 alongside my vista partition using live cd..
nothing really happened other than the apport message (that is noticeable)..
compaq presario CQ60

Toby Gaffney (toby-gaffney) wrote :

again and again upon installing

dross (ross9885-gmail) wrote :

I got the apport message while deciding how to partition my new Eee PC 1001P. I hope the install from USB stick goes ok! I'll take my chances I guess.

mbele3000 (mbele3000) wrote :

  I got the bug report right before the installation finished.

panda69 (kamykaze69) on 2010-03-01
Changed in devicekit-disks (Ubuntu):
status: Fix Released → Fix Committed
Changed in devicekit-disks (Ubuntu):
assignee: Martin Pitt (pitti) → Jennifer_burt2002 (jennifer-burt2002)
status: Fix Committed → Fix Released
ScubaDoc (gpartha72) wrote :

Yet another me 2. Same problem on an Intel Atom with a 750 Gig + 500 Gig SATA HDD and 2GB RAM config. But there's still hope in the world. After about 10 minutes of a nail biting wait at 80% Installing apt, the installation did proceed smoothly. So guys reading this while installing from the live CD, have patience, the experts are right. The install does go on after a while. Cheers, Ubuntu rocks.

Ken James (krjames-jr) wrote :

Okay, I'm not excessively experienced here, so maybe I'm missing something, but what am I supposed to DO? Does this just mean "tough luck, you can't install on your netbook," or what?

MamaAmy (anuchild) wrote :

Same problem for me, except I also receive an Error 5 report about the live cd. I have tried every trick and still nothing works and I can't get past 81% install on a 200 gig sata w 2gb memory.

bersyl91 (choppy-free) wrote :

Problem still existig on alpha3 release in french environment.

Teun (ton-valkering) wrote :

I cannot install Ubuntu, because in step 4 it doesn't find my harddisk, so it cannot install the operating system. Continuing with step 6 (the screen in step 5 is empty) is not possible.

howa (hegeowa) on 2010-03-27
Changed in devicekit-disks (Ubuntu):
status: Fix Released → Fix Committed
zororo (azureroron) on 2010-03-27
Changed in devicekit-disks (Ubuntu):
assignee: Jennifer_burt2002 (jennifer-burt2002) → zororo (azureroron)
Martin Pitt (pitti) on 2010-03-28
Changed in devicekit-disks (Ubuntu):
status: Fix Committed → Fix Released
assignee: zororo (azureroron) → Martin Pitt (pitti)
Webserver (someplace-special) wrote :

Im a new user, this is the same problem I have, LINUX STILL SUCKS

no comment

Changed in devicekit:
importance: Unknown → Undecided
status: Fix Released → New
Sophia J. Ha (synsophia) wrote :

I got this bug when I install 9.10 using Ubuntu CD(Not from canonical. I downloadad iso image and burn it.)

Yaniv Mazir (thehunnted) on 2010-08-31
Changed in devicekit-disks (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
Changed in devicekit-disks (Ubuntu):
assignee: Martin Pitt (pitti) → feri wahyu hijrianto (feriwahyu39)
Changed in devicekit-disks (Ubuntu):
assignee: feri wahyu hijrianto (feriwahyu39) → Santosh Param Sivam (santosh-sivam1991)
randy (randyravancho) wrote :

good

Changed in devicekit:
status: New → Incomplete
john jensen (bonhovede) on 2011-09-25
Changed in devicekit-disks (Ubuntu):
assignee: Santosh Param Sivam (santosh-sivam1991) → john jensen (bonhovede)
Changed in devicekit:
status: Incomplete → Fix Committed
Omar (odelsantos) on 2011-11-08
Changed in devicekit-disks (Ubuntu):
assignee: john jensen (bonhovede) → Omar (odelsantos)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.