Karmic: DVDs cannot be mounted in GNOME

Bug #438065 reported by philinux on 2009-09-28
148
This bug affects 27 people
Affects Status Importance Assigned to Milestone
brasero (Ubuntu)
High
Sebastien Bacher
Nominated for Jaunty by Abelardo Jara-Berrocal
Karmic
High
Sebastien Bacher
devicekit-disks (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by Abelardo Jara-Berrocal
Karmic
Undecided
Unassigned
linux (Ubuntu)
High
Unassigned
Nominated for Jaunty by Abelardo Jara-Berrocal
Karmic
High
Unassigned

Bug Description

Binary package hint: devicekit-disks

No errors in messages only this in dmesg.
[ 148.460279] sr 4:0:0:0: [sr0] unaligned transfer
[ 148.460344] sr 4:0:0:0: [sr0] unaligned transfer
[ 148.460353] sr 4:0:0:0: [sr0] unaligned transfer
[ 148.460636] sr 4:0:0:0: [sr0] unaligned transfer
[ 148.460705] sr 4:0:0:0: [sr0] unaligned transfer
[ 148.460762] sr 4:0:0:0: [sr0] unaligned transfer

Once dvd is in drive it cannot be ejected. Logout and login then dvd will mount and play fine.

ProblemType: Bug
Architecture: amd64
Date: Mon Sep 28 11:51:34 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: devicekit-disks 007-0ubuntu1
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
SourcePackage: devicekit-disks
Uname: Linux 2.6.31-11-generic x86_64

Related branches

philinux (philcb) wrote :
Benjamin Drung (bdrung) wrote :

I have the same problem.

Changed in devicekit-disks (Ubuntu):
status: New → Confirmed
Daniel T Chen (crimsun) wrote :

I'm able to reproduce this in current Karmic with both 2.6.31-11.36 and 2.6.31-11.37 (in Tim's NEW_FAIR_SLEEPERS dir). On the other hand, I haven't chased whether there's also a linux component - using the mainline build of 2.6.32-rc1 resolves the issue completely.

Benjamin Drung (bdrung) wrote :

The strange thing is: You can log out, login again, and then it works.

Dave Walker (davewalker) wrote :

Following insertion of cdrom media, it not only fails to mount but also refuses to eject by pressing the hardware eject button.

/usr/bin/eject fails to eject.

Following logout/restart of gdm, it does mount, although hardware eject button fails to work as expected, not sure this aspect is relevant.

Benjamin Drung (bdrung) wrote :

I can confirm that eject fails, too. Your dmesg output looks like mine.

Krzysiek Kwasniewski (krzykwas) wrote :

I also have the same problem: https://bugs.launchpad.net/ubuntu/+bug/436931 and here: https://bugs.launchpad.net/ubuntu/+bug/436187

While trying to read from a dvd disk, I get an io error. Does anyone know the reason of this bug? Is it because of the 2.6.31 kernel line? Is this bug concerned severe? What priority does it have?

Changed in linux (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) wrote :

The hw eject button not working is bug 397734.

I heared several reports about DVDs not mounting properly, so if Daniel says it's fixed in 2.6.32-rc1, I think it's a kernel bug. DK-disks does not do anythign about accessing the contents of DVDs, it just detects their file systems and triggers GNOME to mount them.

Changed in devicekit-disks (Ubuntu):
status: Confirmed → Invalid
summary: - Karmic alpha6: DVDs fail to mount at all.
+ Karmic: DVDs cannot be mounted
Changed in linux (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged

So, if the bug is fixed in 2.6.32, do we need to wait until 2.6.32 kernel will be available in Ubuntu? It will last a bit long, since the final 2.6.32 version of kernel is to be released more less in December, isn't it? Or will 2.6.31 rather get patched?

Daniel T Chen (crimsun) wrote :

Again, I'm unsure whether there is a linux component. I'm running a fully updated Karmic (linux 2.6.31-11.38-generic, upstart 0.6.3-6, etc.), and this symptom is no longer reproducible. Can others confirm whether this is the case?

Benjamin Drung (bdrung) wrote :

The updates (between the beta release and now) fixes the problem.

I still get the "unaligned transfer" messages.

JK (m0d) wrote :

They DON'T fix the problem for me! Everything I wrote in my bug report (marked as duplicate of this one) is still valid:

https://bugs.launchpad.net/ubuntu/+source/devicekit-disks/+bug/436767

Exactly which change should have fixed this problem?

I have the same troubles with reading DVD resulted in I/O error or seek failed and not working hw eject button.

I confirm that (as noted in bug #436767) if you reboot with the CD/DVD in the tray then it is able to read the whole disc, even after changing the disc... the hw eject button does not work, but you can use eject command.

Closing the empty tray has another consequence... there is no way how to open it again, neither the eject command works since that.

Nothing fixed as for now with all available updates! What actually happens:

1) I open the drive by pressing the button, insert the disk and close the drive.
2) The disk is NOT mounted automatically, I do it by hand: `mount /dev/cdrom` - the disk gets mounted according to the information given by `mount` and the icon shown on the desktop. However the name of the disk is not shown on the desktop, I see only the string "cdrom" or "cdrom0" - now I'm not sure.
3) Then I execute `ls /media/cdrom` and get the listing of my root folder of the disk.
4) I can see the contents of files in the root folder of the disk with `cat /media/cdrom/example_file` (It's not important how I have actually called my files).
5) I try to execute `cat /media/cdrom/dir1/dir2/dir3/.../example_file` and I get output: "File /media/cdrom/dir1/dir2/dir3/.../example_file Input/output error"
6) Then I execute `umount /dev/cdrom` and the piece of information about disk disappears from the output of `mount`, I also don't see the icon of disk on the desktop.
7) I try to open the drive, using the button - it does not work.
8) I execute `eject` - it works and opens the drive - I take the disk out and close the drive.
9) I execute `eject` and it does not work.

Some more help to track down the problem:
1) Output of dmesg: http://wklej.org/id/164047/
2) Output of lshw: http://wklej.org/id/164048/
3) `uname -a`: Linux feniks 2.6.31-11-generic #38-Ubuntu SMP Fri Oct 2 11:06:40 UTC 2009 x86_64 GNU/Linux
4) `dpkg-query -l 'upstart'`
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Nazwa Wersja Opis
+++-==============-==============-============================================
ii upstart 0.6.3-7 event-based init daemon
5) In /var/log/syslog: "Oct 3 15:58:26 feniks kernel: [ 9609.016956] sr 1:0:0:0: [sr0] unaligned transfer
Oct 3 15:58:26 feniks kernel: [ 9609.017122] sr 1:0:0:0: [sr0] unaligned transfer"

Everything worked flawlessly in Ubuntu 9.04. I recorded the disk in JJ exactly the same as I had done before, using Brasero. I dream of this bug being fixed, so that I could fully use this system (i.e. 9.10) and get to my personal data on this disk. I actually have a 1:1 copy of this disk and this problem appears on both of them. What help do you need, to find out the reason of this errors? Should I give you output of some commands, the contents of some files? I really want to help.

Download full text (56.0 KiB)

I tried rebooting with a disk in the drive and I report, that it works. While the system was starting, I heard the noise of the drive mounting the disk. On the desktop I see now an icon of a disk with an appropriate label including the name of my disk. I can also copy all the data from my disk. I haven't tried to take the disk out, so I cannot tell anything about whether the "eject" button does or doesn't work. I can do it in a while - when the data will be safe on my hard disk. So I'm happy, being able to get to my data, however I expect KK 9.10 cannot work this way. How to help you?

Here you have an output of `dmesg` with a disk inside the drive while copying data from it:
"[ 0.000000] Initializing cgroup subsys cpuset
[ 0.000000] Initializing cgroup subsys cpu
[ 0.000000] Linux version 2.6.31-11-generic (buildd@yellow) (gcc version 4.4.1 (Ubuntu 4.4.1-4ubuntu4) ) #38-Ubuntu SMP Fri Oct 2 11:06:40 UTC 2009 (Ubuntu 2.6.31-11.38-generic)
[ 0.000000] Command line: BOOT_IMAGE=/vmlinuz-2.6.31-11-generic root=UUID=e38ecbf1-0b94-4ce5-ba79-20f3baf041e9 ro quiet splash
[ 0.000000] KERNEL supported cpus:
[ 0.000000] Intel GenuineIntel
[ 0.000000] AMD AuthenticAMD
[ 0.000000] Centaur CentaurHauls
[ 0.000000] BIOS-provided physical RAM map:
[ 0.000000] BIOS-e820: 0000000000000000 - 000000000009ec00 (usable)
[ 0.000000] BIOS-e820: 000000000009ec00 - 00000000000a0000 (reserved)
[ 0.000000] BIOS-e820: 00000000000e1000 - 0000000000100000 (reserved)
[ 0.000000] BIOS-e820: 0000000000100000 - 00000000bff80000 (usable)
[ 0.000000] BIOS-e820: 00000000bff80000 - 00000000bff8e800 (ACPI data)
[ 0.000000] BIOS-e820: 00000000bff8e800 - 00000000bffe0000 (ACPI NVS)
[ 0.000000] BIOS-e820: 00000000bffe0000 - 00000000c0000000 (reserved)
[ 0.000000] BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
[ 0.000000] BIOS-e820: 00000000ffb00000 - 0000000100000000 (reserved)
[ 0.000000] BIOS-e820: 0000000100000000 - 0000000140000000 (usable)
[ 0.000000] DMI 2.5 present.
[ 0.000000] AMI BIOS detected: BIOS may corrupt low RAM, working around it.
[ 0.000000] e820 update range: 0000000000000000 - 0000000000010000 (usable) ==> (reserved)
[ 0.000000] last_pfn = 0x140000 max_arch_pfn = 0x400000000
[ 0.000000] MTRR default type: uncachable
[ 0.000000] MTRR fixed ranges enabled:
[ 0.000000] 00000-9FFFF write-back
[ 0.000000] A0000-BFFFF uncachable
[ 0.000000] C0000-CFFFF write-protect
[ 0.000000] D0000-DFFFF uncachable
[ 0.000000] E0000-EFFFF write-through
[ 0.000000] F0000-FFFFF write-protect
[ 0.000000] MTRR variable ranges enabled:
[ 0.000000] 0 base 000000000 mask F00000000 write-back
[ 0.000000] 1 base 100000000 mask FC0000000 write-back
[ 0.000000] 2 base 0C0000000 mask FC0000000 uncachable
[ 0.000000] 3 disabled
[ 0.000000] 4 disabled
[ 0.000000] 5 disabled
[ 0.000000] 6 disabled
[ 0.000000] 7 disabled
[ 0.000000] e820 update range: 00000000c0000000 - 0000000100000000 (usable) ==> (reserved)
[ 0.000000] last_pfn = 0xbff80 max_arch_pfn = 0x400000000
[ 0.000000] Scanning 0 areas for low memory corruption...

"Eject" button does not work while I have a disk in the drive. However I can open the drive using the command `eject`. Then, when the drive is empty, I can open it with a button. The strange thing is that `eject -v` prints, that it could not open the drive, however it opens that properly.

Sorry, I checked it once more and now neither "eject" button, nor "eject" command works. Everything without rebooting - I mean last 2 comments and this one.

Doug McMahon (mc3man) wrote :

this 'fix' is what broke the normal, expected use of cd/dvd drives for many people
https://bugs.launchpad.net/ubuntu/+source/brasero/+bug/420841

What has also been confirmed is that reverting brasero, libbrasero-media0 back to 2.27.92 restores proper use of the cd/dvd drives and at the same time gksu nautilus remains operational
as noted here
https://bugs.launchpad.net/ubuntu/+source/brasero/+bug/439846

In lieu of reverting brasero, libbrasero-media0 the removal of them also should restore use. (after a reboot

Daniel T Chen (crimsun) wrote :
Download full text (7.5 KiB)

Okay, there's definitely a linux task on hand. The current Karmic kernel (2.6.31-11.38) will effect DVD mount upon insertion on my hardware, but the hardware fails to play said DVDs. The easiest way to reproduce this for me is with Totem, upon which I receive:

(warning, very lengthy debugging somewhat condensed)
Oct 3 23:37:40 errno kernel: [ 7868.482655] sr 4:0:0:0: [sr0] Unhandled sense code
Oct 3 23:37:40 errno kernel: [ 7868.482668] sr 4:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Oct 3 23:37:40 errno kernel: [ 7868.482679] sr 4:0:0:0: [sr0] Sense Key : Medium Error [current]
Oct 3 23:37:40 errno kernel: [ 7868.482691] sr 4:0:0:0: [sr0] Add. Sense: L-EC uncorrectable error
Oct 3 23:37:40 errno kernel: [ 7868.482704] end_request: I/O error, dev sr0, sector 14720
Oct 3 23:37:40 errno kernel: [ 7868.482716] __ratelimit: 60 callbacks suppressed
[...]
Oct 3 23:39:05 errno kernel: [ 7953.010130] ata5.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
Oct 3 23:39:05 errno kernel: [ 7953.010165] ata5.00: cmd a0/01:00:00:10:00/00:00:00:00:00/a0 tag 0 dma 16 out
Oct 3 23:39:05 errno kernel: [ 7953.010169] cdb a3 00 00 00 00 00 00 00 00 10 c1 00 00 00 00 00
Oct 3 23:39:05 errno kernel: [ 7953.010172] res 40/00:02:00:08:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
Oct 3 23:39:05 errno kernel: [ 7953.010181] ata5.00: status: { DRDY }
Oct 3 23:39:10 errno kernel: [ 7958.050074] ata5: link is slow to respond, please be patient (ready=0)
Oct 3 23:39:15 errno kernel: [ 7963.030048] ata5: device not ready (errno=-16), forcing hardreset
Oct 3 23:39:15 errno kernel: [ 7963.030066] ata5: soft resetting link
Oct 3 23:39:15 errno kernel: [ 7963.230465] ata5: nv_mode_filter: 0x39f&0x39f->0x39f, BIOS=0x0 (0xc600) ACPI=0x39f (120:600:0x12)
Oct 3 23:39:15 errno kernel: [ 7963.290351] ata5.00: configured for MWDMA2
Oct 3 23:39:15 errno kernel: [ 7963.292254] ata5: EH complete
[...]
Oct 3 23:40:04 errno kernel: [ 8012.052545] ata5: link is slow to respond, please be patient (ready=0)
Oct 3 23:40:09 errno kernel: [ 8017.032549] ata5: device not ready (errno=-16), forcing hardreset
Oct 3 23:40:09 errno kernel: [ 8017.032567] ata5: soft resetting link
Oct 3 23:40:09 errno kernel: [ 8017.232943] ata5: nv_mode_filter: 0x19f&0x39f->0x19f, BIOS=0x0 (0xc600) ACPI=0x39f (120:600:0x12)
Oct 3 23:40:09 errno kernel: [ 8017.292859] ata5.00: configured for MWDMA1
Oct 3 23:40:09 errno kernel: [ 8017.294481] ata5: EH complete
Oct 3 23:40:09 errno kernel: [ 8017.294587] sr0: CDROM (ioctl) error, command: cdb[0]=0xa3, sa=0x0 a3 00 00 00 00 00 00 00 00 10 c1 00
Oct 3 23:40:09 errno kernel: [ 8017.294618] sr: Sense Key : Aborted Command [current] [descriptor]
Oct 3 23:40:09 errno kernel: [ 8017.294629] sr: Add. Sense: No additional sense information
Oct 3 23:40:17 errno kernel: [ 8025.012607] ata5.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
Oct 3 23:40:17 errno kernel: [ 8025.012640] ata5.00: cmd a0/01:00:00:10:00/00:00:00:00:00/a0 tag 0 dma 16 out
Oct 3 23:40:17 errno kernel: [ 8025.012644] cdb a3 00 00 00 00 00 00 00 00 10 c1 00 00 00 00 00
Oct 3 23:40:17 errno kernel: [ 8025.012647] ...

Read more...

JK (m0d) wrote :

Weird... it seems that the most important task right now is to find out whether it's a linux or a libbrasero bug that causes the problem. Maybe there are bugs in both of them, that would at least explain the slightly different experiences of some users here. I'd really like the brasero devs to have a look and comment on this...

Which of you have brasero installed at all?

Klaus Doblmann (moviemaniac) wrote :

*raises his hand*
I too had all sorts of troubles mounting and/or using CDs/DVDs - until I reverted to the last version of Brasero (2.27.92-something). Now everything runs smoothly.

"Which of you have brasero installed at all?"

`dpkg-query -l '*brasero*'`
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Nazwa Wersja Opis
+++-==============-==============-============================================
ii brasero 2.28.0-0ubuntu CD/DVD burning application for GNOME
ii libbrasero-med 2.28.0-0ubuntu CD/DVD burning application for GNOME - runti

Is it possible, that brasero causes kernel errors? Isn't that strange?

Daniel T Chen (crimsun) wrote :

2.6.31.1 mainline also exhibits this symptom. 2.6.32 does not exhibit this symptom.

On my hardware, reverting brasero and libbrasero-media0 to 2.27.92-0ubuntu2 indeed "fixes" the symptom regardless whether 2.6.31.1 or 2.6.32 is used.

At this point it's pretty safe to say that there _may_ be some additional error handling needed in drivers/scsi/*, but it's more probable that brasero should be fixed. Normally unaligned transfers are caused by higher layers, which seems to be the case here. Also, no ("pure") Kubuntu users are experiencing this issue, since brasero isn't used.

Changed in brasero (Ubuntu):
status: New → Confirmed
Daniel T Chen (crimsun) on 2009-10-04
summary: - Karmic: DVDs cannot be mounted
+ Karmic: DVDs cannot be mounted in GNOME
JK (m0d) wrote :

> 2.6.31.1 mainline also exhibits this symptom. 2.6.32 does not exhibit this symptom.

Do you know which commit fixed the problem? I searched the changelog but found nothing that sounded reasonable:
http://www.kernel.org/pub/linux/kernel/v2.6/testing/ChangeLog-2.6.32-rc1

That knowledge may help fixing the bug within brasero...

Doug McMahon (mc3man) wrote :

Just to note
This does not just relate to dvd's. ( as noted in some dups and other reports
In most (and here for sure) any media will cause the issue, whether data cd's, data dvd's, dvd_video or audio cd's.

Also this extends to external usb dvd/cd drives, though the symptoms can vary. The current symptom is after 1 successful mount and eject any further attempts will cause the external to go into an endless open and close loop, in my case continuing AFTER the drive has been disconnected, but still powered

In fact I had to use this particular usb drive in vista to get it to stop looping, now works perfectly in 8.04 and a 9.10 with reverted brasero

*-cdrom
       description: DVD reader
       product: DVD/HD X807616
       vendor: TOSHIBA
       physical id: 0.0.0
       bus info: scsi@9:0.0.0
       logical name: /dev/scd2
       logical name: /dev/sr2
       logical name: /media/WHEN_WE_WERE_KINGS_PAN_SCAN
       version: MC08
       capabilities: removable audio dvd
       configuration: mount.fstype=udf mount.options=ro,nosuid,nodev,relatime,uid=1000,gid=1000,umask=77,iocharset=utf8 state=mounted status=ready

Maxim Levitsky (maximlevitsky) wrote :

Folks, this issue is almost fixed.

Look at,

https://bugs.launchpad.net/ubuntu/+source/devicekit-disks/+bug/397734

There are two problems.

First is that brasero nautilus plugin was locking the DVD drive. This one and many many more bugs were fixed in the git branch 'gnome-2.28' in the brasero git repository.

Another problem is that devkit doesn't poll the drive to see if user have pressed that eject button, however the kernel by default tells the drive to lock the button, so it doesn't eject the disk.
It was agreed that we need to change the kernel not to lock the drive.
This can be meanwhile done by issuing the:

echo 0 > /proc/sys/dev/cdrom/lock

(This will take effect when new disk is inserted)

Doug McMahon (mc3man) wrote :

Can confirm that running above resolves the locking and failure to mount all types of media ( data cd's and dvd's, audio cd's, dvd_video in both internal and external cd/dvd drives

JK (m0d) wrote :

> Just to note
>This does not just relate to dvd's. ( as noted in some dups and other reports
> In most (and here for sure) any media will cause the issue, whether data cd's, data dvd's, dvd_video or audio cd's.

Not true for me. Audio CDs and blank CDs are working correctly (i.e. auto-mounting and ejecting) while everything containing 'normal' data doesn't...

> First is that brasero nautilus plugin was locking the DVD drive.

If the failed auto-mounting is indeed caused by brasero locking the drive, how can a change within the kernel 'fix' that behaviour? And where do all those 'unaligned read' (and other) errors within syslog come from?

Onkar Shinde (onkarshinde) wrote :

I have similar problem. I am assuming it is same as this bug because the messages in dmesg led me here (via Google Search). I initially thought the drive was faulty but it is not the case.

What works:
Audio CD, Video CD, non-CSS-encrypted DVD, all mount fine.

What doesn't work:
CSS-encrypted DVD, irrespective of region code.

Workaround tried:
I tried removing (lib)brasero*. That doesn't help.
I tried installing mainline kernel from the PPA for date 2 October. Even that doesn't help.

Please let me know if there is any more information needed.

i can confirm that if you uninstall libbrasero-media0 2.28 or downgrade this package to 2.27.92 then dvd playback works again.
also fixes another problem that i had whereby if you unmount and eject a disk and close the draw you where unable to reopen the dvd drawer to insert another disc as it was locked and you needed to logoff and back on for it to work.

there is only one problem when you insert dvd video in the drive you have to use the eject/unmount button in nautilus which i think is the above bug #397734 as the button on drive doesn't work.

Andy Whitcroft (apw) wrote :

Mounting of the disks was found to work when changing the version of the userspace libarary. The eject issue is known and being worked on a separate bug. Therefore closing the kernel task.

Changed in linux (Ubuntu):
status: Triaged → Invalid
Martin Pitt (pitti) wrote :

Sebastien, it was confirmed that downgrading libbrasero-media to the previous version helps. Could you please have a look at the changes, check which ones change DVD access, and see whether a commit can be reverted or fixed? Thanks!

Changed in brasero (Ubuntu):
importance: Undecided → High
tags: added: regression-potential
Changed in brasero (Ubuntu Karmic):
assignee: nobody → Sebastien Bacher (seb128)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 2.28.1-0ubuntu1

---------------
brasero (2.28.1-0ubuntu1) karmic; urgency=low

  * New upstream version:
    Highlights:
    - fix problems with drive/medium management
      (file descriptor leak preventing ejection, improved threading safety)
      (lp: #438065)
    - fix problems with libburn/libisofs
      (rare case data corruption, workaround TAO+dummy problem)
    - some crashes fixed (596625 among others) (lp: #425296, #437708)
    - memory leaks
    Updated translations:

 -- Sebastien Bacher <email address hidden> Mon, 05 Oct 2009 23:59:43 +0200

Changed in brasero (Ubuntu Karmic):
status: Confirmed → Fix Released
Matthew Murphy (chthonical) wrote :

I managed to get the bug to pop back up after the patch when I tried to open a file on an audio CD with Sound Juicer. Locked the CD in the tray until I went back to login to get it out.

matthew

this sounds more like bug #397734 (the eject button on drive doesn't work when mounted)

when i play a dvd-video it mounts and plays ok now with this new libbrasero-media0 2.28.1. i cant eject using the drive button but can unmount/eject using nautilus, then drive button works again until i insert another dvd-video.

basically until bug #397734 is fixed (which fix has been commited for review but not released) you are going to get this problem where the drive button doesn't work until you unmount/eject the drive or logoff and back in.

hope this helps

Onkar Shinde (onkarshinde) wrote :

The DVD mounting problem is certainly not solved for me with all updates. If I am the only one experiencing it then I will log a separate bug.

I don't experience this bug now. The disks are mounted and I can read their contents. The only problem is that it is not possible to open the drive using a button, but it's not really annoying. Actually it's not this bug, but another one. Sometime in the future it will probably get fixed. I checked dmesg and there are no "unaligned transfer" messages, there are also no errors connected with this issue (according to syslog).

Thanks to the one, who is responsible for fixing that. :)

Neil Wilson (neil-aldur) wrote :

[ 3472.645731] sr 1:0:0:0: [sr0] unaligned transfer
[ 3472.645940] sr 1:0:0:0: [sr0] unaligned transfer

One latest updates still getting unaligned transfer in dmesg.

brasero:
  Installed: 2.28.1-0ubuntu1
  Candidate: 2.28.1-0ubuntu1

Are we sure this is brasero and not kernel?

Changed in brasero (Ubuntu Karmic):
status: Fix Released → Confirmed
Neil Wilson (neil-aldur) wrote :

Sorry duff info.

Forgot to reboot the machine before testing.

Fixed here.

Changed in brasero (Ubuntu Karmic):
status: Confirmed → Fix Released
imclean (ipxdesign) wrote :

Not sure if it is the same problem, but I cannot playback DVD movies unless they are mounted BEFORE login.
If I insert a disk after login, xine reports unable to access disk / do not have rights error.
If the disk is already in before login, playback works fine.

Agung Yoga (agung-yoga) wrote :

Same case applied for me. cd (data and music) were running just fine. But it's just unable to mount dvd's anykind (movie/data).
I've dual booting with windows and there my cdrom running fine, so I'm pretty sure that was not a hardware problem.
Any positive progress would be much appreciated.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers