constantly polls floppy drive

Bug #384469 reported by Martin Emrich on 2009-06-07
98
This bug affects 12 people
Affects Status Importance Assigned to Milestone
obsolete
Fix Released
Medium
devicekit-disks (Ubuntu)
Medium
Martin Pitt

Bug Description

Binary package hint: devicekit-disks

Since I upgraded my karmic amd64 installation today, I noticed that my floppy drive is constantly running. I found a process "devkit-disks-daemon: polling /dev/sr0 /dev/fd0", after terminating it the floppy activity stops.

Constantly polling of floppy drives should be disabled, as it is noisy and wears out the drive mechanics unnecessarily. Is there something like "hal-disable-polling" for DeviceKit?

Changed in devicekit-disks (Ubuntu):
status: New → Confirmed
Johan Kiviniemi (ion) wrote :

I don’t have a floppy drive on either of the machines I have running karmic, but the ATA activity LED is constantly lit on one of them.

Killing the “devkit-disks-daemon: polling /dev/sr0 /dev/fd0” process makes the LED behave normally. Is this related or should I report another bug?

dmesg and lshw for the computer in question:
http://heh.fi/hw/virhe.20090607.dmesg.karmic
http://heh.fi/hw/virhe.20090607.lshw

dk-disks polls floppy drives for media every couple of seconds. Constantly doing so is noisy and wears out the drive mechanics unnecessarily.

In the hal era we didn't do that either, so I think floppy disks should be blacklisted from polling.

We should disable polling for floppy drives.

Changed in devicekit-disks (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: Confirmed → Triaged
summary: - contantly polls floppy drive
+ constantly polls floppy drive
Changed in devicekit:
status: Unknown → Confirmed
Johan Kiviniemi (ion) wrote :

Please ignore my previous message. It must be a symptom of LP #384579, since the HDD LED is constantly lit while running /lib/udev/devkit-disks-part-id /dev/fd0 as well.

The polling method is also noisy, causing kernel messages to be written to text consoles:
....
[355682.176027] end_request: I/O error, dev fd0, sector 0
[355684.176029] end_request: I/O error, dev fd0, sector 0
[355686.176036] end_request: I/O error, dev fd0, sector 0
[355688.176026] end_request: I/O error, dev fd0, sector 0
....

ACK, this badly needs fixing. I haven't gotten to this because Fedora doesn't automatically load floppy.ko (yeah, bad excuse). I'm going to be in the office on Wednesday so I'll fix it then (I don't have a box with a floppy drive at home).

Max Bowsher (maxb) wrote :

Presumably as a result of this, my console is spammed with a continual spew of error messages....
[355682.176027] end_request: I/O error, dev fd0, sector 0
[355684.176029] end_request: I/O error, dev fd0, sector 0
[355686.176036] end_request: I/O error, dev fd0, sector 0
[355688.176026] end_request: I/O error, dev fd0, sector 0
[355690.176027] end_request: I/O error, dev fd0, sector 0
[355692.176045] end_request: I/O error, dev fd0, sector 0
[355694.176029] end_request: I/O error, dev fd0, sector 0
[355696.176032] end_request: I/O error, dev fd0, sector 0
[355698.176033] end_request: I/O error, dev fd0, sector 0

In Ubuntu we don't force floppy.ko either, it just seems to get autoloaded with the normal udev/modalias mechanism. Unfortunately I can't personally help with debugging here, it's been ages since I had my last floppy drive, but I'm happy to relay testing questions to the reporter, or create some test packages for him.

https://bugs.launchpad.net/bugs/384579 has some udev log and devkit-disks --dump on a computer where a floppy is detected, so that might help.

A work around is to blacklist the floppy module:

sudo vi /etc/modprobe.d/blacklist.conf

add

blacklist floppy

and then run update-initramfs:

sudo update-initramfs -u

Hth

Changed in devicekit:
status: Confirmed → In Progress

By the way, you’d expect it would be possible to do a noiseless poll with the floppy drive.

AmigaOS did the clicky poll periodically, and someone created a utility that made it silent. It worked perfectly.

http://aminet.net/disk/misc/anticlick.readme

Johan Kiviniemi (ion) wrote :

By the way, you’d expect it would be possible to do a noiseless poll with the floppy drive.

AmigaOS did the clicky poll periodically, and someone created a utility that made it silent. It worked perfectly.

http://aminet.net/disk/misc/anticlick.readme

zingerest (z-wickham) wrote :

Constant floppy seek activity which needs to be corrected in os.

(In reply to comment #4)
> By the way, you’d expect it would be possible to do a noiseless poll with the
> floppy drive.
>
> AmigaOS did the clicky poll periodically, and someone created a utility that
> made it silent. It worked perfectly.
>
> http://aminet.net/disk/misc/anticlick.readme
>

Maybe it worked perfectly on Amiga hardware but PC hardware is a lot more cheap/varied. Actually, it almost worked in Windows 95 but not quite so - see

http://blogs.msdn.com/oldnewthing/archive/2009/04/02/9528175.aspx

for a good write up.

Matt Zimmerman (mdz) on 2009-06-16
Changed in devicekit-disks (Ubuntu):
importance: Undecided → Medium
zingerest (z-wickham) wrote :

 marcobra (Marco Braida) wrote on 2009-06-09: (permalink)

A work around is to blacklist the floppy module:

sudo vi /etc/modprobe.d/blacklist.conf

add

blacklist floppy

and then run update-initramfs:

sudo update-initramfs -u

This workaround corrected my constant floppy drive polling. Great solution and appreciate the information. :^>

Changed in devicekit:
status: In Progress → Fix Released
Martin Pitt (pitti) on 2009-06-17
Changed in devicekit-disks (Ubuntu):
status: Triaged → Fix Committed
Daniel Drummond (dmdrummondx) wrote :

A temporary fix is

$ devkit-disks --inhibit-polling /devices/fd0 &

I'm looking for the configuration file to disable floppy polling completely.

Perhaps a lower frequency of polling the floppy drives would be better, ie a longer gap than 2 seconds. It took me a while to find where the constant ticking noise was when I first noticed this on my computer.

Peter Júnoš (petoju) wrote :

This bug still affects me. Can I ask, when will fix come to Ubuntu repos? A have the very latest updates now, but floppy is still "clicking". Temporary fixes mentioned here doesn't help me; only thing that works is
#pkill devkit-disks-da

But then no disks are mounted automatically.

marcobra (Marco Braida) wrote on 2009-06-09: (permalink)

A work around is to blacklist the floppy module:

sudo vi /etc/modprobe.d/blacklist.conf

add

blacklist floppy

and then run update-initramfs:

sudo update-initramfs -u

----- Original Message ----
From: Peter Júnoš <email address hidden>
To: <email address hidden>
Sent: Friday, June 19, 2009 11:54:48 AM
Subject: [Bug 384469] Re: constantly polls floppy drive

This bug still affects me. Can I ask, when will fix come to Ubuntu repos? A have the very latest updates now, but floppy is still "clicking". Temporary fixes mentioned here doesn't help me; only thing that works is
#pkill devkit-disks-da

But then no disks are mounted automatically.

--
constantly polls floppy drive
https://bugs.launchpad.net/bugs/384469
You received this bug notification because you are a direct subscriber
of the bug.

Peter Júnoš (petoju) wrote :

Have you read my description? "Temporary fixes mentioned here doesn't help me" and I add, no fixes mentioned here work for me.

$ cat /etc/modprobe.d/blacklist.conf | grep floppy
#workaround for floppy
blacklist floppy

$ sudo update-initramfs -u
update-initramfs: Generating /boot/initrd.img-2.6.30-9-generic

-> done -> reboot -> floppy is still clicking.

Daniel Drummond (dmdrummondx) wrote :

My temporary run-once-per-login solution above is incorrect. It should be:

devkit-disks --inhibit-polling /dev/fd0 &

unimatrix9 (jochemscheelings) wrote :

I have the same bug :

hccmb@hccmb-desktop:~$ dmesg | tail
[ 1275.620041] end_request: I/O error, dev fd0, sector 0
[ 1277.620032] end_request: I/O error, dev fd0, sector 0
[ 1279.620036] end_request: I/O error, dev fd0, sector 0
[ 1281.620036] end_request: I/O error, dev fd0, sector 0
[ 1283.620052] end_request: I/O error, dev fd0, sector 0
[ 1285.620067] end_request: I/O error, dev fd0, sector 0
[ 1287.620078] end_request: I/O error, dev fd0, sector 0
[ 1289.620051] end_request: I/O error, dev fd0, sector 0
[ 1291.620042] end_request: I/O error, dev fd0, sector 0
[ 1293.620054] end_request: I/O error, dev fd0, sector 0

With dmesg you can see some of the action ...

put in a floppy disk does ease it, but could not find an other solution yet..
this is on a fresh install of Karmic release 2

ps aux | grep devkit-disks

root 3695 0.0 0.3 16248 3200 ? S 10:44 0:00 /usr/lib/devicekit-disks/devkit-disks-daemon
root 3696 0.0 0.0 5724 768 ? S 10:44 0:00 devkit-disks-daemon: polling /dev/fd0 /dev/sr0
hccmb 5020 0.0 0.0 3172 832 pts/1 S+ 11:11 0:00 grep devkit-disks

sudo kill ( the pid of the polling )

is an not so nice work around....

unimatrix9 (jochemscheelings) wrote :

This bug will be fixed in the next release, but you can do this if you are in need for an quick solution:

add to your repositories :

deb http://ppa.launchpad.net/ubuntu-desktop/ppa/ubuntu karmic main

then install the package :

 devicekit ( search with synaptic ) and install any dependecies as well, reboot , fixed....

Danne MCA (danne-mca) wrote :

I try use all fix here, but no ones works. Only when I kill the process.

unimatrix9 (jochemscheelings) wrote :

Danne, you also tested the above solution? adding repository and installing the new devicekit?

I cannot remember the last time I used a floppy; indeed I had to get one from the attic to test what happened when you inserted one with the constant polling going on.

Rather than meddling with the OS while we are waiting for the next release, can I suggest (as I have) temporarily disabling the floppy in the BIOS setup... that is unless you still use floppies ;-)

Danne MCA (danne-mca) wrote :

I try use the repository, but I can't make a connection because the key. Can you help me?

unimatrix9 (jochemscheelings) wrote :

Danne , i hope this can help you, but you can install anyway if you choose
to ignore the safety message..and click okey, install..

here is the long version of how to add key :

How do I use software from a PPA?

To start installing and using software from a Personal Package Archive,
you first need to tell Ubuntu where to find the PPA and how to verify the
authenticity of its software.
Adding the PPA to Ubuntu

Step 1: Copy the first line from the apt sources.list entries section of
the PPA overview page. For example:

deb http://ppa.launchpad.net/awn-testing/ubuntu jaunty main

Step 2: On your Ubuntu computer, open System > Administration > Software
Sources.

Step 3: Click the Third Party Software tab.
Screen shot of the top tabs in the Software Sources app

Step 4: Click the Add button.

Step 5: Paste the line you copied in step 1 and click the Add Source button.

Step 6: Now copy the second line from the second line from the apt
sources.list entries section of the PPA overview page and paste it in just
as you did in steps 4 and 5.

When prompted, reload the software sources information. Don't worry if you
see a warning about unverified software sources; we're going to fix that
next.
Telling Ubuntu how to authenticate the PPA

Now Ubuntu knows about the PPA. It also needs to know how to check the
software hasn't been tampered with since Launchpad built it.

Note: This is not an endorsement of any of the software in PPAs. You must
make sure you trust the PPA owner before installing their software.

Step 1: On the PPA's overview page you'll see the PPA's OpenPGP key id.
It'll look something like this: 1024/12345678. Copy it, or make a note of,
the portion after the slash, e.g: 12345678.

Step 2: Open your terminal and enter:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 12345678

Replace 12345678 with the key id you copied in step 1.

Step 3: Finally, tell Ubuntu to re-load the details of each software
archive it knows about:

sudo apt-get update

You're now ready to install software from the PPA!

Read more about Personal Package Archives in our help wiki.

> I try use the repository, but I can't make a connection because the key.
> Can you help me?
>
>
> --
> constantly polls floppy drive https://bugs.launchpad.net/bugs/384469
> You received this bug notification because you are a direct subscriber
> of the bug.
>

unimatrix9 (jochemscheelings) wrote :

How do you add this with key ? read here : https://edge.launchpad.net/~ubuntu-desktop/+archive/ppa

Max Bowsher (maxb) wrote :

I've installed the packages from the ubuntu-desktop PPA, but the bug is still present.

Danne MCA (danne-mca) wrote :

unimatrix9, I try, add the repository and get no problem with key, in this time. I did the update, after, upgrade. Instaled the package devicekit-disks, and reboot. Don't work. I try reinstall the package devicekit and reboot. Don't work too. And try install the devicekits-globject-dev, and even, don't work. =[

Danne MCA (danne-mca) wrote :

Oops. I did the update again and its working now. Thanks, 'unimatrix9'.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package devicekit-disks - 005-0ubuntu1

---------------
devicekit-disks (005-0ubuntu1) karmic; urgency=low

  * New upstream release:
    - Fixes constant polling of floppy drives. (LP: #384469)
    - Drop usage of DeviceKit, talk directly to udev now.
  * debian/control:
    - Replace libdevkit-gobject-dev with libgudev-1.0-dev (upstream now talks
      to udev directly instead of through devicekit).
    - Drop devicekit dependency.
    - Update libpolkit b-deps to new policykit-1 ones.
    - Add new build dependency libsgutils2-dev.
    - Bump libudev-dev b-dep version according to configure.ac.
  * debian/rules: Explicitly enable gtk-doc, not done by default any more.
  * debian/devicekit-disks.install:
    - Update path for new policykit-1 files.
    - Add new pkgconfig file.
    - Install usr/share/locale and usr/share/man.
  * debian/rules: Ignore usr/lib/polkit-1/ for dh_makeshlibs, they are
    backends for PolicyKit.

 -- Martin Pitt <email address hidden> Mon, 22 Jun 2009 11:37:52 +0200

Changed in devicekit-disks (Ubuntu):
status: Fix Committed → Fix Released
wmccroskey (wmccroskey) wrote :

I also had this problem on Fedora 11 x86_64.

I use the floppy drive, so disabling it is NOT an option. I know most of you don't have this type of hardware on your PC these days, but as a bit of an old-timer, here are a few facts to consider:
1. Floppy drive motors are not rated for continuous duty. This polling appears to be running the head positioning motor to try to read track zero as well as possibly the drive motor. Either action every two seconds will fail the drive over time as the the motors have some run time and spin down time.

2. Please review the interface chip. The Intel 82077 (or clone) FDC used pin 31 for DSKCHG and it show up as bit 7 of the Digital Input Register (DIR, PC-AT Mode) "DSKCHG monitors the pin of the same name and reflects the opposite value seen on the disk cable, regardless of the value of /Invert"

The DSKCHG signal would be the preferred way of polling the disk. Poll for a disk change and only try to read after that.

The main this is to not keep running the motor.

Not sure what problems I'll cause, but under /usr/libexec, I mv'ed the devkit-disks-daemon to devkit-disks-daemon.do_not_run and then rebooted.

It seems the HALD is still polling the other removable drives, so they pop-up as media is inserted.

I tried to put the devkit-disks --inhibit-polling /dev/fd0 & into a startup script and that did not seem to work.

Mark (markhfm) wrote :

Installed updated package. Bug fixed.

On 6/26/2009 9:00 AM, Launchpad Bug Tracker wrote:
> This bug was fixed in the package devicekit-disks - 005-0ubuntu1
>
> ---------------
> devicekit-disks (005-0ubuntu1) karmic; urgency=low
>
> * New upstream release:
> - Fixes constant polling of floppy drives. (LP: #384469)
> - Drop usage of DeviceKit, talk directly to udev now.
> * debian/control:
> - Replace libdevkit-gobject-dev with libgudev-1.0-dev (upstream now talks
> to udev directly instead of through devicekit).
> - Drop devicekit dependency.
> - Update libpolkit b-deps to new policykit-1 ones.
> - Add new build dependency libsgutils2-dev.
> - Bump libudev-dev b-dep version according to configure.ac.
> * debian/rules: Explicitly enable gtk-doc, not done by default any more.
> * debian/devicekit-disks.install:
> - Update path for new policykit-1 files.
> - Add new pkgconfig file.
> - Install usr/share/locale and usr/share/man.
> * debian/rules: Ignore usr/lib/polkit-1/ for dh_makeshlibs, they are
> backends for PolicyKit.
>
> -- Martin Pitt<email address hidden> Mon, 22 Jun 2009 11:37:52
> +0200
>
> ** Changed in: devicekit-disks (Ubuntu)
> Status: Fix Committed => Fix Released
>
>
> ------------------------------------------------------------------------
>
>
> No virus found in this incoming message.
> Checked by AVG - www.avg.com
> Version: 8.5.374 / Virus Database: 270.12.93/2206 - Release Date: 06/27/09 17:55:00
>
>

tags: added: iso-testing
Malte Wetz (mjw-de) wrote :

I think I have a similar problem. However, in my case, devkit-disks-daemon continues to poll for /dev/sdb which in my case is a card reader device. It uses approximately 20% of my CPU. If I kill the process, the cpu load drops significantly.

Sergio Zanchetta (primes2h) wrote :

2009/11/20 Malte Wetz <email address hidden>:
> I think I have a similar problem. However, in my case, devkit-disks-
> daemon continues to poll for /dev/sdb which in my case is a card reader
> device. It uses approximately 20% of my CPU. If I kill the process, the
> cpu load drops significantly.
>

This bug is fixed so try to update your system
If this is still an issue, please open another bug report.
Thank you.

> --
> constantly polls floppy drive
> https://bugs.launchpad.net/bugs/384469
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Malte Wetz (mjw-de) wrote :

> This bug is fixed so try to update your system

I already tried that but it did not solve the problem. However, my system was an upgrade from 9.04. Maybe some leftover config file screwed things up because after I reinstalled 9.10 from scratch, the problem did not occur again. Just posting to have it on the record in case someone else has the same problem.

Thanks anyway. :)

Changed in devicekit:
importance: Unknown → Medium
Changed in devicekit:
importance: Medium → Unknown
Changed in devicekit:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.