Please sync devhelp 2.28 from debian unstable main

Bug #451864 reported by Javier Jardón on 2009-10-15
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
devhelp (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: devhelp

The current version of devhelp in Lucid is 0.23-4. The latest version upstream is 2.28.1. We do have an outdated version in Lucid, and since testing also has 0.23-4 Lucid won't get the new version unless testing gets a Devhelp upgrade.

The maintainer of Devhelp, Bradley Smith, disabled his account, which means there is no active maintainer for Devhelp at the moment.

This is a request to sync Devhelp with Debian unstable main to version 2.28.1-1
However, we may have to sync again once GNOME 2.29 and GNOME 2.30 are released.

Current version: devhelp 0.23-4
Requested version: devhelp 2.28.1-1
Sync source: Debian unstable main
Changelog: http://packages.debian.org/changelogs/pool/main/d/devhelp/devhelp_2.28.1-1/changelog
Ubuntu changes: none

Javier Jardón (jjardon) wrote :
Changed in devhelp (Ubuntu):
importance: Undecided → Wishlist
Sense Egbert Hofstede (sense) wrote :

Thank you for helping with making Ubuntu better by reporting this bug. It is already to late to include this version of devhelp in Karmic, or any previous release.
However, development for the next release -- Lucid -- just started. I would also love to see an up to date version of devhelp in that release.

If you want to request a sync with Debian unstable, please follow the guidelines at https://wiki.ubuntu.com/SyncRequestProcess and add the requested information to this bug report.

Changed in devhelp (Ubuntu):
status: New → Incomplete
Javier Jardón (jjardon) wrote :

Hello Sense, all the info added. There is not specific Ubuntu changes in the changelog

Changed in devhelp (Ubuntu):
status: Incomplete → Confirmed
description: updated
summary: - Please sync devhelp 2.28 from debian sid
+ Please sync devhelp 2.28 from debian unstable
summary: - Please sync devhelp 2.28 from debian unstable
+ Please sync devhelp 2.28 from debian unstable main
description: updated
Sense Egbert Hofstede (sense) wrote :

I've uploaded Devhelp from Debian unstable to ppa:qense/devhelp and the latest version upstream (2.29.2) to ppa:qense/devhelp-testing.
The only change to the first is a 'dch -n', and it is built for Karmic. The second is a clean upstream release with the debian directory taken from Debian testing's 2.28.1, the only changes here are a 'dch -i', removal of the patches and the removal patch macro inclusion in rules, next to increasing the libgtk2.0 dependency version to 2.10.0.

Sense Egbert Hofstede (sense) wrote :

I personally did not, but I could have known it. Anjuta and gnome-devel also fail to install on amd64 with the latest Devhelp.
I reckon the changes needed to solve this aren't that big, but it does need to be investigated before the sync request can be honoured.

This most likely has to do with the renaming of libdevhelp-1-0 to libdevhelp-1-1.

Sense Egbert Hofstede (sense) wrote :

It seems that upstream now has no problems anymore with this version of Devhelp, which means that syncing Anjuta and gnome-devel from Debian would mean that Devhelp has to be synced/merged as well.

Sense Egbert Hofstede (sense) wrote :

Probably because there was nothing blocking a sync of Devhelp anymore it is now 2.28.1 in Lucid and I'm sure it will be kept up-to-date.
I'm setting this bug to Fix Released.
Thanks everyone!

Changed in devhelp (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers