lernid crashed with ImportError in /usr/lib/pymodules/python2.7/desktopcouch/records/server.py: No module named application.server

Bug #727232 reported by Dooitze de Jong on 2011-03-01
40
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Lernid
Critical
John S. Gruber
desktopcouch (Ubuntu)
Medium
Unassigned
lernid (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: lernid

Lernid doesn't start

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: lernid 0.7
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Tue Mar 1 16:55:46 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/lernid
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/lernid
ProcEnviron:
 SHELL=/bin/bash
 LANG=nl_NL.UTF-8
 LANGUAGE=nl_NL:nl:en_GB:en
PythonArgs: ['/usr/bin/lernid']
SourcePackage: lernid
Title: lernid crashed with ImportError in /usr/lib/pymodules/python2.7/desktopcouch/records/server.py: No module named application.server
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Dooitze de Jong (dooitze) wrote :
tags: removed: need-duplicate-check
visibility: private → public
John S. Gruber (jsjgruber) wrote :

Happened to me as well. Seems to me that the problem is that lernid doesn't depend upon desktopcouch, either directly or indirectly (python-desktopcouch-records doesn't have that dependancy either).

Installing desktopcouch got me by this error. Its presence, and its dependencies on couchdb-bin and python-desktopcouch-application seem to solve this set of errors.

Dooitze de Jong: Can you confirm that desktopcouch is not installed when you experience this problem (its not in the dependency.txt above) and that installing it resolves this particular error? (I'm aware of at least one more error that stops lernid from starting).

John S. Gruber (jsjgruber) wrote :

There's a good chance that I'm not understanding how python dependencies should be working, but just in case...

In revision 40 of lp:ubuntu/desktopcouch on 1/12/11 dependencies were reorganized. In particular, python-desktopcouch-records no longer depends on the desktopcouch binary package. However, python-desktopcouch-records does import from python-desktop-application in line 9 of its deprecated desktopcouch.records.server.py and python-desk-application requires desktopcouch in /usr/share/pyshared/desktopcouch/application/local_files.py in lines 43-48. (python-desktop-application doesn't depend on the desktopcouch binary, so even if the application instead depended upon python-desktopcouch-application and imported d...application.server rather than d...record.server, a problem would remain in its local_files.py).

See also lp: #708114

Changed in desktopcouch (Ubuntu):
status: New → Confirmed
John S. Gruber (jsjgruber) wrote :

WRT desktopcouch also see LP #738762.

John S. Gruber (jsjgruber) wrote :

  A corrected lernid package is available in my ppa (ppa:jsjgruber/ppa) for this and for LP #716937.

Changed in lernid (Ubuntu):
status: New → Confirmed

Some users would use your ppa but many users would use the regular
repo and don't know what to do if they get an error.

On 24/03/2011, John S. Gruber <email address hidden> wrote:
> A corrected lernid package is available in my ppa (ppa:jsjgruber/ppa)
> for this and for LP #716937.
>
> ** Changed in: lernid (Ubuntu)
> Status: New => Confirmed
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/727232
>
> Title:
> lernid crashed with ImportError in
> /usr/lib/pymodules/python2.7/desktopcouch/records/server.py: No module
> named application.server
>
> Status in “desktopcouch” package in Ubuntu:
> Confirmed
> Status in “lernid” package in Ubuntu:
> Confirmed
>
> Bug description:
> Binary package hint: lernid
>
> Lernid doesn't start
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.04
> Package: lernid 0.7
> ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
> Uname: Linux 2.6.38-5-generic i686
> NonfreeKernelModules: nvidia
> Architecture: i386
> Date: Tue Mar 1 16:55:46 2011
> EcryptfsInUse: Yes
> ExecutablePath: /usr/bin/lernid
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
> InterpreterPath: /usr/bin/python2.7
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/bin/lernid
> ProcEnviron:
> SHELL=/bin/bash
> LANG=nl_NL.UTF-8
> LANGUAGE=nl_NL:nl:en_GB:en
> PythonArgs: ['/usr/bin/lernid']
> SourcePackage: lernid
> Title: lernid crashed with ImportError in
> /usr/lib/pymodules/python2.7/desktopcouch/records/server.py: No module named
> application.server
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/desktopcouch/+bug/727232/+subscribe
>

--
Kind Regards,
Dooitze de Jong

Webmaster: http://ubuntu-fy.org
ICT Kollumerzwaag
Ervaring Ubuntu, Debian, MySQL, Apache2 en openVPN
Mail voor meer informatie

dooitzedejong

John S. Gruber (jsjgruber) wrote :

Dooitze de Jong:
I'm sure you are right. I intend to work toward that goal for the circumvention for lernid

However, I believe the problem is best fixed in desktopcouch. I believe other packages will experience the same problem.

Thanks for the report, by the way.

Changed in lernid (Ubuntu):
assignee: nobody → John S. Gruber (jsjgruber)
Changed in lernid (Ubuntu):
assignee: John S. Gruber (jsjgruber) → nobody
Changed in lernid:
status: New → Confirmed
assignee: nobody → John S. Gruber (jsjgruber)
John S. Gruber (jsjgruber) wrote :
John S. Gruber (jsjgruber) wrote :

A build for natty lernid_0.7ubuntu1 is in ppa:~jsjgruber/ppatwo and was tested from there.

John S. Gruber (jsjgruber) wrote :

lernid is not a debian package

John S. Gruber (jsjgruber) wrote :

Please note that the proposed update to natty 0.7ubuntu1 is currently in ppa:~jsjgruber/ppatwo while ppa:~jsjgruber/ppa currently contains the merge proposal package for upstream against 0.7.1.

tags: added: patch
John S. Gruber (jsjgruber) wrote :

To test remove the exisiting lernid, desktopcouch, python-desktopcouch-application, python-desktopcouch-records, couchdb-bin packages and install the new lernid. Installing should install the packages above and lernid should start up when run, displaying a connection dialog box rather than giving a traceback like that in one of theses two bug descriptions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lernid - 0.8

---------------
lernid (0.8) natty; urgency=low

  * Fix Significant bugs
    (LP: #716937) - Correct specification of text tags colors
    (LP: #727232) - Add desktopcouch as dependency
 -- John S Gruber <email address hidden> Tue, 29 Mar 2011 16:22:10 -0400

Changed in lernid (Ubuntu):
status: Confirmed → Fix Released
Changed in lernid:
importance: Undecided → Critical
Changed in lernid:
status: Confirmed → In Progress
Changed in lernid:
status: In Progress → Fix Committed
Changed in lernid:
status: Fix Committed → Fix Released
Changed in desktopcouch (Ubuntu):
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers