bughugger does not work in kubuntu lucid

Bug #565376 reported by Rohan Garg on 2010-04-17
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
desktopcouch
Undecided
Unassigned
Nominated for 0.5-stable by Rohan Garg
desktopcouch (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: bughugger

I installed the bughugger package in kubuntu lucid (everything updated) but i cant get bughugger to work,hence im reporting this bug along with a traceback of bughugger when started from konsole.

==Traceback==

** Message: secret service operation failed: The name org.freedesktop.secrets was not provided by any .service files
Traceback (most recent call last):
  File "/usr/bin/bughugger", line 28, in <module>
    from desktopcouch.records.server import CouchDatabase
  File "/usr/lib/python2.6/dist-packages/desktopcouch/__init__.py", line 20, in <module>
    from desktopcouch.start_local_couchdb import process_is_couchdb, read_pidfile
  File "/usr/lib/python2.6/dist-packages/desktopcouch/start_local_couchdb.py", line 38, in <module>
    from desktopcouch import local_files
  File "/usr/lib/python2.6/dist-packages/desktopcouch/local_files.py", line 297, in <module>
    xdg_base_dirs.save_config_path("desktop-couch"))
  File "/usr/lib/python2.6/dist-packages/desktopcouch/local_files.py", line 237, in __init__
    self.configuration = _Configuration(self)
  File "/usr/lib/python2.6/dist-packages/desktopcouch/local_files.py", line 91, in __init__
    {'desktopcouch': 'basic'})
gnomekeyring.IOError

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: bughugger 10.04
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic x86_64
Architecture: amd64
Date: Sat Apr 17 19:20:57 2010
InstallationMedia: Kubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100317)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: bughugger

SRU details :

Impact :
Bughugger is rendered useless on Kubuntu Systems since it does not pull in gnome-keyring and python-gtk2 for authorization to launchpad.

Fixed in Maverick Meerkat in version 0.6.6-0ubuntu2

Lucid packages in : https://edge.launchpad.net/~rohangarg/+archive/experimental

TEST CASE :
1) Install Kubuntu
2) Install bug hugger from official repositories
3) Try and run Bughugger, bughugger does not start and instead crashes

Rohan Garg (rohangarg) wrote :
Rohan Garg (rohangarg) on 2010-06-29
affects: bughugger (Ubuntu) → desktopcouch (Ubuntu)
Changed in desktopcouch (Ubuntu):
assignee: nobody → Rohan Garg (rohangarg)
affects: bughugger → desktopcouch
Changed in desktopcouch:
assignee: nobody → Rohan Garg (rohangarg)
Rohan Garg (rohangarg) wrote :

Hi
Please do a SRU for this package with the debdiff attached.gnome-keyring had to be added to depends of python-couchdb to fix this.

tags: added: patch
Rohan Garg (rohangarg) on 2010-07-06
Changed in desktopcouch (Ubuntu):
status: New → In Progress
Changed in desktopcouch:
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package desktopcouch - 0.6.6-0ubuntu2

---------------
desktopcouch (0.6.6-0ubuntu2) maverick; urgency=low

  * Add gnome-keyring to depends of python-desktopcouch (LP: #565376)
    and desktop couch (LP: #561541) for proper authentication in KDE
 -- Rohan Garg <email address hidden> Sat, 17 Jul 2010 21:19:44 +0530

Changed in desktopcouch (Ubuntu):
status: In Progress → Fix Released
Rohan Garg (rohangarg) wrote :

Im attaching a new debdiff for a SRU to lucid,can someone please look into this? It has been fixed in lucid

Rohan Garg (rohangarg) on 2010-09-10
description: updated
Rohan Garg (rohangarg) wrote :

New SRU debdiff with proper version

Rohan Garg (rohangarg) wrote :

Ok final attachement, i screwed up the release name in last debdiff

Martin Pitt (pitti) wrote :

SRU ack, please upload.

Benjamin Drung (bdrung) wrote :

uploaded to lucid-proposed

Changed in desktopcouch (Ubuntu Lucid):
status: New → Fix Committed

Accepted desktopcouch into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed

I'm unable to test in Lucid/Kubuntu because before the update I can't run bughugger because of the bug and after the upgrade to -proposed, the bughugger windows are shown but are completely empty as shown on the screenshot.

The following output is printed on the command line
===
Removing stale, deceptive pid file.
Apache CouchDB has started, time to relax.
Browse your desktop CouchDB at file:///home/ubuntu/.local/share/desktop-couch/couchdb.html
running logon dialog for bughugger
making .local directory for bughugger
/home/ubuntu/.local/share/bughugger/production/credentials
directories now exist for bughugger
no cached credentials, retrieving from Launchpad
attempting to authenticate
contacting https://edge.launchpad.net/ to get auth url for credentials:
<launchpadlib.credentials.Credentials object at 0x95f3aec>
received auth_url: https://edge.launchpad.net/+authorize-token?oauth_token=sfWm3B74D7VtJrjdBTQb
auth link received https://edge.launchpad.net/+authorize-token?oauth_token=sfWm3B74D7VtJrjdBTQb
authentication url received
===

Either the fix is incomplete or provide another test case to verify the desktopcouch issue ?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package desktopcouch - 0.6.4-0ubuntu3.1

---------------
desktopcouch (0.6.4-0ubuntu3.1) lucid-proposed; urgency=low

  * Add gnome-keyring to depends of python-desktopcouch (LP: #565376)
    and desktop couch (LP: #561541) for proper authentication in KDE
 -- Rohan Garg <email address hidden> Sun, 19 Sep 2010 20:18:04 +0200

Changed in desktopcouch (Ubuntu Lucid):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to lucid-updates to push out the other fix, and since this doesn't seem to be a regression. I reopen this lucid task, though, since it still doesn't seem to work.

Changed in desktopcouch (Ubuntu Lucid):
status: Fix Released → Confirmed
dobey (dobey) wrote :

The screenshot from comment #10 seems to suggest that the fix for this bug is working, but the UI is blocking, possibly on network I/O. Given that bughugger stores offline bug information in desktopcouch, and the desktopcouch/couchdb APIs are not asynchronous, it is possible that it could block the UI for a very long time.

Rohan Garg (rohangarg) wrote :

Seems like bughugger has been discontinued, hence, removing self from task

Changed in desktopcouch:
assignee: Rohan Garg (rohangarg) → nobody
status: In Progress → Invalid
Changed in desktopcouch (Ubuntu):
assignee: Rohan Garg (rohangarg) → nobody
Rolf Leggewie (r0lf) wrote :

lucid has seen the end of its life and is no longer receiving any updates. Marking the lucid task for this ticket as "Won't Fix".

Changed in desktopcouch (Ubuntu Lucid):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers