Don't register as default video player

Bug #334954 reported by Ken VanDine on 2009-02-26
2
Affects Status Importance Assigned to Milestone
desktop-file-utils (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: banshee

Currently banshee registers itself as the default video player. This isn't desirable if the distro is defaulting to totem.

Changed in banshee:
assignee: nobody → ken-vandine
status: New → Confirmed
Ken VanDine (ken-vandine) wrote :

debdiff removing the video mimetypes from banshee

Changed in banshee:
assignee: ken-vandine → ubuntu-universe-sponsors
Steve Stalcup (vorian) on 2009-02-26
Changed in banshee:
assignee: ubuntu-universe-sponsors → vorian
status: Confirmed → In Progress
Ken VanDine (ken-vandine) wrote :

Updated patch to use correct version

On Thu, 2009-02-26 at 15:55 +0000, Ken VanDine wrote:
> debdiff removing the video mimetypes from banshee
>
> ** Attachment added: "334954.diff"
> http://launchpadlibrarian.net/23150580/334954.diff
>
> ** Changed in: banshee (Ubuntu)
> Assignee: Ken VanDine (ken-vandine) => Ubuntu Sponsors for universe (ubuntu-universe-sponsors)
>
Are you sure this is a good idea? I doubt upstream will be accepting
this anytime soon, and I don't think Debian would either.

I was just talking to Martin Pitt about this issue, and it seems that
listing the said videos in /usr/share/applications/defaults.list, as
associated with Totem should do the trick. Why do we have to resort to
removing Banshee's video support completely?
--
Chow Loong Jin

Daniel Holbach (dholbach) wrote :

Generally: can you follow https://wiki.ubuntu.com/UbuntuDevelopment/PatchTaggingGuidelines and use "(LP: #334954)" instead of "(LP #334954)"?

Also click on the "[x] This attachment is a patch" thing when submitting a patch. :-)

Ken VanDine (ken-vandine) wrote :

It wouldn't remove support for it completely, just remove it as a default action (or list of defaults) when opening/downloading a video file.

I just don't think banshee provides the expected user experience when used to open a video. It is fine if you are playing videos you are managing in your library. But when you click on a video to play, banshee doesn't actually take you right into video playback. You actually have to navigate to your playing video. That should really be fixed in banshee, right now banshee always does the same thing no matter what media type you opened. Perhaps it should detect it is a video and change your view to the "Now Playing" view. I will file an upstream bug for that, but until the user experience is improved I would rather steer the user towards totem.

Chow Loong Jin (hyperair) wrote :

On Thu, 2009-02-26 at 17:04 +0000, Ken VanDine wrote:
> It wouldn't remove support for it completely, just remove it as a
> default action (or list of defaults) when opening/downloading a video
> file.
Yeah that's what I meant. Sorry for phrasing it wrongly.
>
> I just don't think banshee provides the expected user experience when
> used to open a video. It is fine if you are playing videos you are
> managing in your library. But when you click on a video to play,
> banshee doesn't actually take you right into video playback. You
> actually have to navigate to your playing video. That should really
> be
> fixed in banshee, right now banshee always does the same thing no
> matter what media type you opened. Perhaps it should detect it is a
> video and change your view to the "Now Playing" view. I will file an
> upstream bug for that, but until the user experience is improved I
> would
> rather steer the user towards totem.
>
I agree that Banshee provides a less than ideal user experience for
videos. However, I don't think this is enough to warrant removing
Banshee from the list of applications available to play videos.

The current behaviour (assuming that defaults.list has Totem listed as
default for all videos) is that Banshee just appears in the list of
"Open with" applications, but does not become the default, unless the
user chooses it to be.

I can't think of any way this would inconvenience any users at all. If a
user wants to use Banshee as his/her default, he/she just selects it as
the default in the properties dialog in Nautilus. If he/she does not
want to use Banshee as his/her default, he just leaves it be, and that's
it.

On the other hand, this change you are proposing will inconvenience
users who DO want to use Banshee as their default, because now they will
have to manually add the application to the list.

You mention that you would rather steer the user towards totem. Don't
you think that having Totem as the default application for videos is
enough rather than removing Banshee from the list of "Open with"
applications as well? Moreover, Banshee is an application in universe
which is not even installed by default! If the user has installed
Banshee, then the user WANTS Banshee. And even then, Totem will remain
the default video application.

That said, I am completely and utterly against this change. If you feel
you must go on with this change, at least discuss it with upstream and
the Debian maintainer first.
--
Chow Loong Jin

Chow Loong Jin (hyperair) wrote :

By the way, it wasn't Martin Pitt I talked to earlier, it was Sebastian
Bacher. I typed out the wrong name.
--
Chow Loong Jin

Chow Loong Jin (hyperair) wrote :

I'd also like to bring to your attention that Banshee's behaviour in
trunk regarding videos is perfect. When you right click on a video and
choose open with Banshee, it queues the file in the File System Queue,
and goes straight to the Now Playing window where it plays the video.
--
Chow Loong Jin

Ken VanDine (ken-vandine) wrote :

Oh excellent!

Changed in banshee:
assignee: vorian → nobody
importance: Undecided → Low
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package desktop-file-utils - 0.15-1ubuntu6

---------------
desktop-file-utils (0.15-1ubuntu6) jaunty; urgency=low

  * debian/defaults.list:
    - updated the openoffice desktop files names to match current versions
    - updated the audio and video mimetype list and set default to totem so
      banshee is not used to play videos when installed for example
      (lp: #334954)

 -- Sebastien Bacher <email address hidden> Thu, 12 Mar 2009 22:48:38 +0100

Changed in desktop-file-utils:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments