wrong association of files .sxd and .sxc

Bug #215010 reported by Guillaume on 2008-04-10
2
Affects Status Importance Assigned to Milestone
desktop-file-utils (Ubuntu)
High
Sebastien Bacher

Bug Description

Binary package hint: openoffice.org

When trying to open old files saved in .sxc or .sxd format, those files are opened with Impress module, not Calc or Draw.

ProblemType: Bug
Architecture: i386
Date: Thu Apr 10 11:11:13 2008
DistroRelease: Ubuntu 8.04
Package: openoffice.org-core 1:2.4.0-3ubuntu2
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/lib/openoffice/program:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: openoffice.org
Uname: Linux 2.6.24-15-generic i686

Guillaume (bou-gui) wrote :
Chris Cheney (ccheney) wrote :

Can you attach example documents that opens incorrectly in openoffice.org impress instead of calc or draw? I looked at the mimetype associations and don't see how they could possibly be opening in the wrong program, so example files to look at could help me determine what the problem is.

Thanks,

Chris Cheney

Changed in openoffice.org:
status: New → Incomplete
Guillaume (bou-gui) wrote :

Thank's for your answer.
Here is an exemple of .sxd opened with Impres.

Chris Cheney (ccheney) wrote :

As best as I can tell this is caused by the file /usr/share/applications/defaults.list which is shipped in desktop-file-utils.

Chris

Changed in openoffice.org:
importance: Undecided → High
status: Incomplete → Confirmed
Sebastien Bacher (seb128) wrote :

Could you attach an sxc incorrectly associated? The sxd one is a desktop-files-utils issue indeed and I'll upload a fix now but sxc seems to be correctly working on hardy

Sebastien Bacher (seb128) wrote :

I've uploaded a fix for the sxd association to hardy

Changed in desktop-file-utils:
assignee: nobody → seb128
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package desktop-file-utils - 0.15-1ubuntu3

---------------
desktop-file-utils (0.15-1ubuntu3) hardy; urgency=low

  * debian/defaults.list:
    - correct some openoffice.org associations issues (lp: #215010)

 -- Sebastien Bacher <email address hidden> Fri, 18 Apr 2008 18:28:32 +0200

Changed in desktop-file-utils:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers