package desktop-file-utils 0.23-1ubuntu3 failed to install/upgrade: dependency problems - leaving triggers unprocessed

Bug #1769954 reported by Michael Bushey on 2018-05-08
36
This bug affects 13 people
Affects Status Importance Assigned to Milestone
desktop-file-utils (Ubuntu)
Undecided
Julian Andres Klode
Xenial
Undecided
Julian Andres Klode
Artful
Undecided
Julian Andres Klode
Bionic
Undecided
Julian Andres Klode

Bug Description

[Impact]
dist-upgrade from artful to bionic fails with attached tarball

[Test case]
artful:
1. Install new desktop-file-utils
2. check that dist-upgrade works
bionic:
1. Download new deb
2. Run apt-get dist-upgrade path/to/deb in xenial to trigger upgrade with that deb being upgraded too.

[Regression potential]
Packages installing desktop files to /usr/share/applications won't get put in triggers-awaited state due to d-f-u.

[Other info]
Just fixing bionic makes an apt dist-upgrade work (not sure about do-release-upgrade); but it might not work in other circumstances I guess, so it might make sense to upload the fix to older releases.

We can only verify artful and bionic, though, so xenial would have to go in unchecked.

The trigger causes the desktop database to be updated, as such it is possible to use noawait here, as there's no reason for packages shipping .desktop files to be not configured just because the database has not been updated yet.

The same change has been made in Debian in 0.23-2.

[Original bug report]
run `sudo do-release-upgrade` on a relativity new 16.04 EC2 instance.

ProblemType: Package
DistroRelease: Ubuntu 18.04
Package: desktop-file-utils 0.23-1ubuntu3
ProcVersionSignature: Ubuntu 4.13.0-36.40-generic 4.13.13
Uname: Linux 4.13.0-36-generic x86_64
NonfreeKernelModules: zfs zunicode zavl zcommon znvpair
ApportVersion: 2.20.7-0ubuntu3.8
Architecture: amd64
Date: Tue May 8 16:59:12 2018
Ec2AMI: ami-70873908
Ec2AMIManifest: (unknown)
Ec2AvailabilityZone: us-west-2a
Ec2InstanceType: t2.large
Ec2Kernel: unavailable
Ec2Ramdisk: unavailable
ErrorMessage: dependency problems - leaving triggers unprocessed
Python3Details: /usr/bin/python3.6, Python 3.6.5, python3-minimal, 3.6.5-3
PythonDetails: /usr/bin/python2.7, Python 2.7.15rc1, python-minimal, 2.7.15~rc1-1
RelatedPackageVersions:
 dpkg 1.19.0.5ubuntu2
 apt 1.6.1
SourcePackage: desktop-file-utils
Title: package desktop-file-utils 0.23-1ubuntu3 failed to install/upgrade: dependency problems - leaving triggers unprocessed
UpgradeStatus: Upgraded to bionic on 2018-05-08 (0 days ago)

Michael Bushey (corwin7) wrote :
tags: removed: need-duplicate-check
Brian Murray (brian-murray) wrote :

Do you happen to have and could you provide us with the following file from the system?

/var/log/dist-upgrade/apt-clone_system_state.tar.gz

Thanks in advance.

Changed in desktop-file-utils (Ubuntu):
status: New → Incomplete
Michael Bushey (corwin7) wrote :

Sure, here it is.

Brian Murray (brian-murray) wrote :

The sources.list file in the provided apt-clone information indicates that you were running Ubuntu 17.10 not Ubuntu 16.04 as mentioned in the description. Is this the correct apt-clone file?

Changed in desktop-file-utils (Ubuntu):
status: Incomplete → Confirmed
Brian Murray (brian-murray) wrote :

I've been able to recreate this with both do-release-upgrade and manually editing sources.list from artful to bionic and then running 'apt-get dist-upgrade'.

I was able to work around this by editing sources.list and then first installing libglib2.0-0 before running 'apt-get dist-upgrade'.

tags: added: triggers-unprocessed
Tessa (unit3) wrote :

Just ran into this upgrading from 17.10 to 18.04.

Julian Andres Klode (juliank) wrote :

Fixing desktop-file-utils in artful to be noawait fixes that, I'll try bionic next.

description: updated
description: updated
description: updated
tags: added: id-5b1169fb7c4ba277874d3879
Changed in desktop-file-utils (Ubuntu):
assignee: nobody → Julian Andres Klode (juliank)
Changed in desktop-file-utils (Ubuntu Xenial):
assignee: nobody → Julian Andres Klode (juliank)
Changed in desktop-file-utils (Ubuntu Artful):
assignee: nobody → Julian Andres Klode (juliank)
Changed in desktop-file-utils (Ubuntu Bionic):
assignee: nobody → Julian Andres Klode (juliank)
Changed in desktop-file-utils (Ubuntu):
status: Confirmed → Fix Committed
Changed in desktop-file-utils (Ubuntu Bionic):
status: New → In Progress
Changed in desktop-file-utils (Ubuntu Artful):
status: New → In Progress
description: updated
description: updated
Changed in desktop-file-utils (Ubuntu Xenial):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package desktop-file-utils - 0.23-1ubuntu4

---------------
desktop-file-utils (0.23-1ubuntu4) cosmic; urgency=medium

  * Use noawait trigger (LP: #1769954)

 -- Julian Andres Klode <email address hidden> Tue, 05 Jun 2018 10:30:25 -0700

Changed in desktop-file-utils (Ubuntu):
status: Fix Committed → Fix Released

Hello Michael, or anyone else affected,

Accepted desktop-file-utils into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/desktop-file-utils/0.22-1ubuntu5.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in desktop-file-utils (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial
Changed in desktop-file-utils (Ubuntu Artful):
status: In Progress → Fix Committed
tags: added: verification-needed-artful
Robie Basak (racb) wrote :

Hello Michael, or anyone else affected,

Accepted desktop-file-utils into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/desktop-file-utils/0.23-1ubuntu3.17.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in desktop-file-utils (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed-bionic
Robie Basak (racb) wrote :

Hello Michael, or anyone else affected,

Accepted desktop-file-utils into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/desktop-file-utils/0.23-1ubuntu3.18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: id-5b16b21de0acb39616c818d5
Julian Andres Klode (juliank) wrote :
Julian Andres Klode (juliank) wrote :

artful upload:

Verified by first running a dist-upgrade from artful to bionic, which failed; then first installing new desktop-file-utils before running the dist-upgrade, which succeeded (ignoring the friendly-recovery failure due to being run in container).

Julian Andres Klode (juliank) wrote :

(the log was for a second run, first one failed to start dist-upgrade due to lock race, hence desktop-file-utils_0.23-1ubuntu3.17.10.1_amd64.deb was already installed).

tags: added: verification-done-bionic
removed: verification-needed-bionic
tags: added: verification-done-artful verification-needed-bionic
removed: verification-done-bionic verification-needed-artful
Julian Andres Klode (juliank) wrote :

Upgrading to bionic with desktop-file-utils_0.23-1ubuntu3.18.04.1_amd64.deb as part of the dist-upgrade also worked fine, as expected (again, ignoring friendly-recovery failure due to container).

tags: added: verification-done-bionic
removed: verification-needed-bionic
Julian Andres Klode (juliank) wrote :

Also marking xenial as verified, as the other two have not produced any problems, we know that the fix is correct, and the fix is tiny and declarative, and cannot be verified for xenial itself, as mentioned in the bug report.

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package desktop-file-utils - 0.23-1ubuntu3.18.04.1

---------------
desktop-file-utils (0.23-1ubuntu3.18.04.1) bionic; urgency=medium

  * Use noawait trigger (LP: #1769954)

 -- Julian Andres Klode <email address hidden> Tue, 05 Jun 2018 10:30:25 -0700

Changed in desktop-file-utils (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for desktop-file-utils has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package desktop-file-utils - 0.23-1ubuntu3.17.10.1

---------------
desktop-file-utils (0.23-1ubuntu3.17.10.1) artful; urgency=medium

  * Use noawait trigger (LP: #1769954)

 -- Julian Andres Klode <email address hidden> Tue, 05 Jun 2018 10:30:25 -0700

Changed in desktop-file-utils (Ubuntu Artful):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package desktop-file-utils - 0.22-1ubuntu5.2

---------------
desktop-file-utils (0.22-1ubuntu5.2) xenial; urgency=medium

  * Use noawait trigger (LP: #1769954)

 -- Julian Andres Klode <email address hidden> Tue, 05 Jun 2018 11:43:53 -0700

Changed in desktop-file-utils (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.