Use GNOME Software as default snap: URL handler

Bug #1666100 reported by Robert Ancell on 2017-02-20
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
desktop-file-utils (Ubuntu)
Medium
Unassigned
Xenial
Medium
Unassigned
Yakkety
Medium
Unassigned
Zesty
Medium
Unassigned

Bug Description

[Impact]
In the same way as apturl is set as the default apt: URL handler, we should do the same for GNOME Software with the snap: URL.

The prime impact for users will be support for snap:// URLs in the browser. This will allow web sites to provide a "click here to install this snap...." type links which will take the user directly to Ubuntu Software (instead of having to choose a url handler) where the snap will be preselected. e.g. http://www.omgubuntu.co.uk/2017/02/snap-url-support-coming-ubuntu-software-app-plus-love-news (link towards the bottom as an example of the sorts of things websites will be able to do).

[Test Case]
Run:
$ xdg-open snap:moon-buggy

Expected result:
GNOME Software opens with information on the moon-buggy snap

Observed result:
Get error about "specified location not supported"

[Regression Potential]
Low, we set a default where there was previously none.

Robert Ancell (robert-ancell) wrote :

Bug 1621971 added snap: URL support to GNOME Software.

Changed in desktop-file-utils (Ubuntu Zesty):
status: New → Fix Committed
importance: Undecided → Medium
Changed in desktop-file-utils (Ubuntu Yakkety):
importance: Undecided → Medium
Changed in desktop-file-utils (Ubuntu Xenial):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package desktop-file-utils - 0.23-1ubuntu2

---------------
desktop-file-utils (0.23-1ubuntu2) zesty; urgency=medium

  * debian/defaults.list:
    - Use GNOME Software as default snap: URL handler (LP: #1666100)

 -- Robert Ancell <email address hidden> Mon, 20 Feb 2017 16:54:20 +1300

Changed in desktop-file-utils (Ubuntu Zesty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in desktop-file-utils (Ubuntu Xenial):
status: New → Confirmed
Changed in desktop-file-utils (Ubuntu Yakkety):
status: New → Confirmed
Robie Basak (racb) wrote :

What's the real user impact of this please? What's the user action that causes an attempt to xdg-open a snap: URL that currently fails? Please document this in the "Impact" section.

Will Cooke (willcooke) wrote :

Robert is out on holiday for a couple of weeks, so I've taken the liberty of updating the impact section. I think it's right, but please let me know if you need more info.

description: updated

Hello Robert, or anyone else affected,

Accepted desktop-file-utils into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/desktop-file-utils/0.23-1ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

description: updated
Changed in desktop-file-utils (Ubuntu Yakkety):
status: Confirmed → Fix Committed
tags: added: verification-needed
Changed in desktop-file-utils (Ubuntu Xenial):
status: Confirmed → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Robert, or anyone else affected,

Accepted desktop-file-utils into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/desktop-file-utils/0.22-1ubuntu5.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

I checked the Yakkety package.

tags: added: verification-done
removed: verification-needed
Will Cooke (willcooke) wrote :

I checked the Xenial package. Also good, so verification-done.

Chris Halse Rogers (raof) wrote :

Yakkety flatpak autopkgtest failures on armhf and s390x would appear unrelated; flatpack autopkgtests have passed only once since June last year.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package desktop-file-utils - 0.22-1ubuntu5.1

---------------
desktop-file-utils (0.22-1ubuntu5.1) xenial; urgency=medium

  * debian/defaults.list:
    - Use GNOME Software as default snap: URL handler (LP: #1666100)

 -- Robert Ancell <email address hidden> Mon, 20 Feb 2017 16:54:20 +1300

Changed in desktop-file-utils (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for desktop-file-utils has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package desktop-file-utils - 0.23-1ubuntu1.1

---------------
desktop-file-utils (0.23-1ubuntu1.1) yakkety; urgency=medium

  * debian/defaults.list:
    - Use GNOME Software as default snap: URL handler (LP: #1666100)

 -- Robert Ancell <email address hidden> Mon, 20 Feb 2017 16:54:20 +1300

Changed in desktop-file-utils (Ubuntu Yakkety):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers