Evince will not open .djvu files by default

Bug #1238584 reported by Vasil Yakauleu on 2013-10-11
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
desktop-file-utils (Ubuntu)
High
Unassigned

Bug Description

This issue is reproducible on Ubuntu and Ubuntu-Gnome 13.10

Steps to reproduce:
1. Try to open any djvu file

Actual result:
It opens by default in PrintPreviewer instead of Evince

Expected result:
1. Evince should open djvu files by default

NB: This can be easily changed, but it would be more userfriendly to make this default

affects: evince (Ubuntu) → desktop-file-utils (Ubuntu)
Changed in desktop-file-utils (Ubuntu):
importance: Undecided → High
status: New → In Progress
Vasil Yakauleu (vasilbelarus) wrote :

Sorry, I didn`t know how to find out exactly package for this issue. I thought that every application has it`s own .desktop file where mimetype placed, so chose Evince.

Sebastien Bacher (seb128) wrote :

> Sorry, I didn`t know how to find out exactly package for this issue. I thought that every application has it`s own .desktop file where mimetype placed, so chose Evince.

No worry! The do, the issue is that if several applications claim a mimetype you need to be able to pick a preferred one ... desktop-file-utils is where we ship our list of "what application is recommended for what type"

Changed in desktop-file-utils (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package desktop-file-utils - 0.21-1ubuntu2

---------------
desktop-file-utils (0.21-1ubuntu2) saucy; urgency=low

  * debian/defaults.list: list evince as default, for the types it should
    be handling, otherwise the wrong handler is being used (lp: #1238584)
 -- Sebastien Bacher <email address hidden> Fri, 11 Oct 2013 13:50:37 +0200

Changed in desktop-file-utils (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers