odb file extension should be associated with LibreOffice Base instead Archive Manager

Bug #1016581 reported by Csipak Attila on 2012-06-22
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
desktop-file-utils (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned

Bug Description

Impact:
libreoffice database odb file open in file-roller rather than libreoffice

Test case:
- Create a new database file (foo.odb) using LibreOffice Base (or download the one from comment #3)
- Open foo.odb via dash home / recent files or double click on it in nautilus

With the fixed version it should open with libreoffice-base

Regression potential:
- the odb files could open with the wrong application still

---

Since the odb extension is associated with Archive Manager (alias File Roller) as a default, I got a nice error at this point.

If I open Nautilis and correct the file association to LibreOffice, the above steps work OK, as expected. The question is: why was the odf extension by default associated with the Archive Manager application?

Csipak Attila (corphicks) wrote :
Sebastien Bacher (seb128) wrote :

thank you for your bug report, could you add an example file to the bug?

Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Csipak Attila (corphicks) wrote :

Here's an example database file (no private information in it).

Also It's just as easy to reproduce by doing step 1-3. above (creating an empty *.odb file with LibreOffice Base, and reopening it via dash or even from nautilus). I just reproduced the error this way on my wife's notebook, so I guess I'm not the only one having a default *odf - archive manager file association.

Changed in nautilus (Ubuntu):
status: Incomplete → New
affects: nautilus (Ubuntu) → desktop-file-utils (Ubuntu)
Changed in desktop-file-utils (Ubuntu Precise):
importance: Undecided → Low
status: New → Fix Committed
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package desktop-file-utils - 0.20-0ubuntu4

---------------
desktop-file-utils (0.20-0ubuntu4) quantal; urgency=low

  * debian/defaults.list:
    - set the audacity default handler, thanks Benjamin Drung (lp: #1006610)
    - set the odb files to open with libreoffice-base by default
      (lp: #1016581)
 -- Sebastien Bacher <email address hidden> Mon, 25 Jun 2012 16:59:21 +0200

Changed in desktop-file-utils (Ubuntu):
status: New → Fix Released

Hello Csipak, or anyone else affected,

Accepted desktop-file-utils into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/desktop-file-utils/0.20-0ubuntu3 in a few hours and then in the -proposed repository. Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case details of your testing will help us make a better decision. Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Vasco Alves (vascofalves) wrote :

Works for me!

tags: added: verification-done
removed: verification-needed
Csipak Attila (corphicks) wrote :

The fix released in desktop-file-utils 0.20-0ubuntu3 works OK & fixes the bug.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package desktop-file-utils - 0.20-0ubuntu3

---------------
desktop-file-utils (0.20-0ubuntu3) precise-proposed; urgency=low

  * debian/defaults.list:
    - set the audacity default handler, thanks Benjamin Drung (lp: #1006610)
    - set the odb files to open with libreoffice-base by default
      (lp: #1016581)
 -- Sebastien Bacher <email address hidden> Mon, 25 Jun 2012 16:59:21 +0200

Changed in desktop-file-utils (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers