deskbar popup says bug detected when launching program

Bug #36515 reported by acketon on 2006-03-25
18
Affects Status Importance Assigned to Milestone
deskbar-applet
Fix Released
Critical
deskbar-applet (Ubuntu)
Medium
Unassigned

Bug Description

I am running dapper drake flight 5. Have been installing all updates as they show up and have turned on the deskbar. it was working, but now when I enter a command for a program such as Gaim it gives a pop-up window saying a bug has been detected that probably isn't fatal, the details of the bug that are shown are listed below. I have experiemented with linux in the past, but this is the first distro I feel comfortable switching to, which I have done for 90% of my use on my Laptop (my desktop is still XP) This is the first and only bug I've detected and my first time reporting so I hope this helps.

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/deskbar/ui/entriac/CuemiacEntryUI.py", line 353, in on_entry_activate
    while (not self.model.iter_has_child(iter)) or (not self.cview.row_expanded(self.model.get_path(iter))):
TypeError: iter should be a GtkTreeIter

Corey Burger (corey.burger) wrote :

Thanks for your bug report. Can you please take a look at the linked bug in the gnome bugzilla and see if that is what is also happening to you?
And welcome to Ubuntu!

Changed in deskbar-applet:
status: Unconfirmed → Needs Info
krusbjorn (joohannes) wrote :

I'm having this bug since last nights upgrade (Dapper). Always worked before that. Running xgl/compiz if that makes a difference.

Sebastian Dröge (slomo) wrote :

Could you try running it without xgl/compiz and write here whether this makes a difference?

Sebastian Dröge (slomo) wrote :

ok, it has nothing to do with xgl... I can reproduce it easily here and it's what is described in the upstream bug

Changed in deskbar-applet:
status: Needs Info → Confirmed
Stu Hood (stuhood) wrote :

I can confirm this with a current Dapper. Trying to launch any program crashes Deskbar, and doesn't load the program.

Additionally, but probably unrelated, Bug-Buddy crashes before it performs the trace with GDB.

I tried to attach to the running process and then crash it, but the text input gets disabled when I connect to it with GDB.

Stu Hood (stuhood) wrote :

A fix was released for this bug today in Dapper, so I'm markin' it.

Changed in deskbar-applet:
status: Confirmed → Fix Released
Changed in deskbar-applet:
status: Unconfirmed → Fix Released
Changed in deskbar-applet:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.