Deskbar applet does not search bookmarks (handler never loaded)

Bug #34989 reported by John Stowers on 2006-03-15
12
Affects Status Importance Assigned to Milestone
deskbar-applet
Fix Released
Medium
deskbar-applet (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Hey,

Deskbar applet ships with a handler to search in a users bookmarks. It autodetects if a users default browser is firefox or epiphany

This autodetection is broken and causes the bookmark search handler not to load.

Reason:
BrowserMatch.py checks the gconf key /desktop/gnome/url-handlers/http/ for the presence of either the firefox of epiphany string and loads the appropriate handler

Unfortunately the said key contains gnome-www-browser %s so neither extension is loaded

I presume that gnome-www-browser is an intermediary which checks the /gnome/applications/browser/exec gconf key for which web browser to launch

To Repeat:
1) Remove deskbar from the panel
2) execute /usr/lib/deskbar-applet/deskbar-applet -w
3) Notice how none of the epiphany, galeon or firefox/mozilla handlers are loaded

Raphael Slinckx (kikidonk) wrote :

This bug has already been reported in gnome's deskbar bugzilla feel free to close it here.

Matt Zimmerman (mdz) wrote :

Rejecting Ubuntu task, bug remains open upstream and we will get the fix that way

Changed in deskbar-applet:
status: Unconfirmed → Rejected
Raphael Slinckx (kikidonk) wrote :

A fix has been comitted to head and soon backported to 2.14 branch.. feel free to close here

Daniel Holbach (dholbach) wrote :

Marking Fix Committed, so I remember to close once a tarball is released.

Changed in deskbar-applet:
assignee: nobody → dholbach
status: Rejected → Fix Committed
Daniel Holbach (dholbach) wrote :

 deskbar-applet (2.14.1-0ubuntu1) dapper; urgency=low
 .
   * New upstream release:
     - History order was reversed each time the applet was removed/added to a
       top panel.
     - Fixes typo in the if statement preventing duplicate detection to work
       properly
     - Repair the no-history not appearing when history.pickle was not present
     - Add transparency to Cuemiac mode
     - Fix the history order, and update order when switching form bottom to
       top panel
     - Implement a is_valid method to ask a match if it's still valid, to
       evaluate if it should be stored in history
     - Follow symlinks to detect the browser
     - Fix error if last_visible_path iter is None
     - Fix duplication of items in deskbar history list
     - Use the history icon when displaying history items and bookmark when
       displaying bookmarks
     - Don't throw errors if an unknown beagle type is encountered
     - Pass the preferences dialog to the "more" callback to allow info
       dialogs to be transient
     - Correctly use imlogviewer passing client name to it
     - Activate the bottom hit of the view when the cuem/entr-iac is at a
       bottom panel.
     - Fix bug where deskbar crashes when the user hits up/down immediately
       after entering some text.
     - Implement mozilla/firefox history search, only the url, since history
       format is braindead.
     - Fixes the proxy detection code for google-live.
     - Fix entry in button mode placement for vertical panels
     - Added Translations: Dzongkha, Hebrew, Welsh.
     - Updated Translations: Czech, Finnish, Georgian, Greek.
   * debian/patches/fix-google-proxy.diff:
     - dropped, accepted Upstream.
   * Fixed bugs: Malone #34989.

Changed in deskbar-applet:
assignee: dholbach → desktop-bugs
status: Fix Committed → Fix Released
Changed in deskbar-applet:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.