deskbar-applet crashed with SIGSEGV in PyType_IsSubtype()

Bug #333608 reported by Spider on 2009-02-24
190
This bug affects 4 people
Affects Status Importance Assigned to Milestone
deskbar-applet
Fix Released
Critical
deskbar-applet (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: deskbar-applet

I tried to add it to the panel. In hindsight it might not be supposed to be in the panel?

ProblemType: Crash
Architecture: amd64
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/lib/deskbar-applet/deskbar-applet
InterpreterPath: /usr/bin/python2.5
NonfreeKernelModules: nvidia
Package: deskbar-applet 2.25.90-0ubuntu1
ProcCmdline: /usr/bin/python /usr/lib/deskbar-applet/deskbar-applet --oaf-activate-iid=OAFIID:Deskbar_Applet_Factory --oaf-ior-fd=22
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/zsh
Signal: 11
SourcePackage: deskbar-applet
StacktraceTop:
 PyType_IsSubtype ()
 ?? ()
 ?? ()
 ?? ()
 PyEval_EvalFrameEx ()
Title: deskbar-applet crashed with SIGSEGV in PyType_IsSubtype()
Uname: Linux 2.6.28-8-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Spider (spider-alternating) wrote :

StacktraceTop:?? ()
?? ()
?? ()
?? ()
?? ()

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in deskbar-applet:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Incomplete

Is this due to python updating to 2.6?

Nikolay Botev (nikolaybotevb) wrote :

Here is a coredump for this exact same problem. See bug 336507 for details - the Disassembly and Stacktrace there match the ones here exactly.

Sebastien Bacher (seb128) wrote :

do you get the issue every time?

wios (wios) wrote :

every time i want to add it to the panel the error message occurs and deskbar quits "deskbar has quit unexpectedly"

the same situation here

wios wrote:
> every time i want to add it to the panel the error message occurs and
> deskbar quits "deskbar has quit unexpectedly"
>
>

wiflye81 (wiflye81-gmail) wrote :

Same here

the same situation and here

On Mon, Mar 9, 2009 at 2:08 PM, wiflye81 <email address hidden> wrote:
> Same here
>
> --
> deskbar-applet crashed with SIGSEGV in PyType_IsSubtype()
> https://bugs.launchpad.net/bugs/333608
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Nikolay Botev (nikolaybotevb) wrote :

I get the issue every single time

Tarin Mahmood (mrlinux045) wrote :

I have this problem to and I am unable to add the deskbar to panel.

Marc Hebrard (marc-hebrard) wrote :

Same here.

wios (wios) wrote :

fixed with today's update (for me)

Łukasz Jernaś (deejay1) wrote :

Still crashes for me.

wiflye81 (wiflye81-gmail) wrote :

Also fixed for me with yesterday update (even with tracker lib)

Nikolay Botev (nikolaybotevb) wrote :

also fixed for me after updating python and deskbar packages

Michael Kogan (michael-kogan) wrote :

Which version do you guys use? I'm still experiecing this problem with 2.26.0-0ubuntu1 (jaunty).

MBecker (marc-becker-mainz) wrote :

Still crashes for me. Everytime I try to add the deskbar applet to the gnome panel.

Python 2.6.1, Ubuntu 9.04, amd64

Nikolay Botev (nikolaybotevb) wrote :

I filed bug 349391 which looks exactly like this bug but I believe is different.

The bug here, I joined while testing jaunty on my laptop (nvidia graphics with propr. driver)

The new bug presents the same problem, but on my desktop, after i upgraded it from 810 to 904 beta and installed fglrx (it works on 904 beta with radeon)

the key difference from the log files: here is the crash record on my desktop:

Mar 27 00:08:34 nikolay-quad kernel: [ 7822.490412] deskbar-applet[12675]: segfault at fd ip 0000000000467c45 sp 00007fff9ee7ded8 error 4 in python2.6[400000+216000]

... i will post the corresponding line for my laptop from before the problem got solved there.

Nikolay Botev (nikolaybotevb) wrote :

here is THIS bug's error log line (note the different ip from the above message which relates to my new bug 349391)

Mar 13 23:51:04 nikolay-laptop kernel: [ 83.726969] deskbar-applet[4699]: segfault at 101 ip 0000000000467c05 sp 00007fff651e1318 error 4 in python2.6[400000+215000]

Fixed for me with package deskbar-applet 2.26.0-0ubuntu1.

Kjetil Thuen (kjetil-thuen) wrote :

I was seeing this with 2.26.0-0ubuntu1, but if I move away my ~/.local/share/desktop-applet, it will start. If I put my old copy back in, it crashes on startup again. This box was just upgraded from intrepid to jaunty. The only thing in ~/.local/share/desktop-applet/ is the history file and an empty modules dir.

Michael Kogan (michael-kogan) wrote :

I can confirm this. I've Jaunty since Alpha3 and removing ~/.local/share/desktop-applet/ solves the problem, too.

Sidimar Carniel (sidicdia) wrote :

only making the removal as mentioned above don't solve the problem.It removed the directory, but rather the application quits unexpectedly.

Sebastien Bacher (seb128) wrote :

could you try to figure what in the config trigger the issue?

Michael Kogan (michael-kogan) wrote :

In my case it didn't help to remove any of the files or folders inside of ~/.local/share/desktop-applet or all of them. The only thing that helped was to remove the whole folder. Really strange...

Vassily Gavrilyak (gavrilyak) wrote :

Same with me, only removing the folder helped. But is doesn't help on another laptop with the same Jaunty 64 version.

Mehul J. Rajput (mehulrajput) wrote :

same with me... deleting folder allows deskbar to be added but when you click on it, deskbar crashes.

Sebastian Pölsterl (sebp) wrote :

This bug is also upstream at http://bugzilla.gnome.org/show_bug.cgi?id=577649

Telling from the stacktrace it seems to be a problem in pygobject.

Vassily Gavrilyak (gavrilyak) wrote :

With latest updates of python etc. deskbar-applet crashed again on my laptop, but works on another, where it didn't work before.
So it works either on this laptop or on another, not on both. But running deskbar from command line as /usr/lib/deskbar-applet/deskbar-applet and then adding it to panel works.

Vassily Gavrilyak (gavrilyak) wrote :

More information. deskbar-applet works when launching from terminal and adding to panel, but it crashes when launching from "Run" - (alt-F2). I tried to run in with Alt-F2 in gdb and got the same stackrace. Does anybody know what is the difference between console launch and "Run"?
Maybe some environment variable?

Vassily Gavrilyak (gavrilyak) wrote :

I installed python-dbg package, run deskbar-applet -w from dash and have more detailed stacktrace.

Vassily Gavrilyak (gavrilyak) wrote :

In my previous stacktrace there was /usr/lib/deskbar-applet/modules-2.20-compatible/twitter.pyc. After removing /usr/lib/deskbar-applet/modules-2.20-compatible/twitter.py and /usr/lib/deskbar-applet/modules-2.20-compatible/twitter.pyc everything works

Changed in deskbar-applet (Ubuntu):
status: Incomplete → Triaged
Changed in deskbar-applet:
status: Unknown → New
Nikolay Botev (nikolaybotevb) wrote :

removing twitter.py* from /usr/lib/deskbar-applet/modules-2.20-compatible fixed the problem for me as well

Sebastian Pölsterl (sebp) wrote :

Could anybody who wants to help finding the exact cause of this bug please follow the instructions in the upstream bug tracker at http://bugzilla.gnome.org/show_bug.cgi?id=577649#c23

Download full text (11.8 KiB)

Here's a hopefully useful stack trace:

GNU gdb 6.8-debian
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu"...
(gdb) run
Starting program: /usr/bin/python /usr/lib/deskbar-applet/deskbar-applet -d
[Thread debugging using libthread_db enabled]
[New Thread 0x7f4eac4076f0 (LWP 5237)]
04-09 11:10:36 root INFO Starting Deskbar instance: <gnome.applet.Applet object at 0x25411e0 (PanelApplet at 0x25b0000)> OAFIID:Deskbar_Applet
04-09 11:10:36 deskbar.core.Keybinder INFO Binding Global shortcut <Alt>F3 to focus the deskbar
04-09 11:10:36 deskbar.core.CoreImpl INFO Successfully binded Deskbar to <Alt>F3
04-09 11:10:36 deskbar.core.ModuleLoader WARNING Class EpiphanyBookmarksHandler in file /usr/lib/deskbar-applet/modules-2.20-compatible/epiphany.py has missing requirements. Skipping.
04-09 11:10:36 deskbar.core.ModuleLoader WARNING Class EpiphanyHistoryHandler in file /usr/lib/deskbar-applet/modules-2.20-compatible/epiphany.py has missing requirements. Skipping.
04-09 11:10:36 deskbar.core.ModuleLoader WARNING Class EpiphanySearchHandler in file /usr/lib/deskbar-applet/modules-2.20-compatible/epiphany.py has missing requirements. Skipping.
04-09 11:10:36 deskbar.core.ModuleLoader INFO Loading module 'Programs' from file /usr/lib/deskbar-applet/modules-2.20-compatible/programs.py.
04-09 11:10:36 deskbar.core.ModuleLoader INFO Loading module 'Dictionary' from file /usr/lib/deskbar-applet/modules-2.20-compatible/programs.py.
04-09 11:10:36 deskbar.core.ModuleLoader INFO Loading module 'Files and Folders Search' from file /usr/lib/deskbar-applet/modules-2.20-compatible/programs.py.
04-09 11:10:36 deskbar.core.ModuleLoader INFO Loading module 'Developer Documentation' from file /usr/lib/deskbar-applet/modules-2.20-compatible/programs.py.
04-09 11:10:36 deskbar.core.ModuleLoader INFO Loading module 'Tomboy Notes' from file /usr/lib/deskbar-applet/modules-2.20-compatible/tomboy.py.
04-09 11:10:36 deskbar.core.ModuleLoader INFO Loading module 'Web' from file /usr/lib/deskbar-applet/modules-2.20-compatible/web_address.py.
04-09 11:10:36 deskbar.core.ModuleLoader INFO Loading module 'OpenSearch' from file /usr/lib/deskbar-applet/modules-2.20-compatible/opensearch.py.
04-09 11:10:36 deskbar.core.ModuleLoader INFO Loading module 'Calculator' from file /usr/lib/deskbar-applet/modules-2.20-compatible/calculator.py.
04-09 11:10:36 deskbar.core.ModuleLoader INFO Loading module 'del.icio.us Bookmarks' from file /usr/lib/deskbar-applet/modules-2.20-compatible/desklicious.py.
04-09 11:10:36 deskbar.core.ModuleLoader INFO Loading module 'Computer Actions' from file /usr/lib/deskbar-applet/modules-2.20-compatible/gdmactions.py.

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7f4eac4076f0 (LWP 5237)]
PyType_IsSubtype (a=0xfffffffffffffffd, b=0x7f4eaa26e6a0) at ../Objects/typeobject.c:1157...

Vassily Gavrilyak (gavrilyak) wrote :

It's already fixed upstream. see http://bugzilla.gnome.org/show_bug.cgi?id=577649

Looks like comment #32 here: http://bugzilla.gnome.org/show_bug.cgi?id=577649#c32 and its followups seem to fix the problem. When I remove the inheritance of gobject in GnomeURLopener, the crash goes away.

There is a more complete patch at http://bugzilla.gnome.org/attachment.cgi?id=132271&action=view , which is apparently already commited in the upstream version. It applies fine, though the file locations are a bit different in Ubuntu, and also solves the crash, at least for me.

Vassily Gavrilyak (gavrilyak) wrote :

Locations are not different, patch must be applied to source package, not installed files. It works for me too, as I noted at upstream comments.

Changed in deskbar-applet:
status: New → Fix Released
Nikolay Botev (nikolaybotevb) wrote :

I no longer see this problem on karmic beta

Changed in deskbar-applet:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.