<defunct> processes

Bug #209662 reported by Timo Aaltonen on 2008-03-31
8
Affects Status Importance Assigned to Milestone
deskbar-applet (Ubuntu)
Low
Unassigned
Hardy
Low
Unassigned

Bug Description

Binary package hint: deskbar-applet

My desktop-session has a couple of defunct processes parented by deskbar-applet:

tjaalton 19964 1 0 12:06 ? 00:00:01 /usr/bin/python /usr/lib/deskbar-applet/deskbar-applet ...
tjaalton 19970 19964 0 12:06 ? 00:00:00 [sh] <defunct>
tjaalton 19972 19964 0 12:06 ? 00:00:00 [sh] <defunct>

can't figure out why though. My laptop has three of them.

Andrey Zaitsev (a-zaitsev) wrote :

I confirm this. I have the same issue in Hardy. These two are zombie processes

Changed in deskbar-applet:
assignee: nobody → ubuntu-core-dev
status: New → Confirmed
Changed in deskbar-applet:
assignee: ubuntu-core-dev → desktop-bugs
Sebastian Pölsterl (sebp) wrote :

This is fixed in SVN and will part of 2.22.2

Changed in deskbar-applet:
status: Confirmed → Fix Committed
Sebastien Bacher (seb128) wrote :
Changed in deskbar-applet:
importance: Undecided → Low
importance: Undecided → Low
status: New → Confirmed
Sebastien Bacher (seb128) wrote :
Sebastien Bacher (seb128) wrote :
Changed in deskbar-applet:
assignee: nobody → desktop-bugs
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Changed in deskbar-applet:
status: Confirmed → Fix Committed
soro2005 (soro) wrote :

I get one zombie process. I can kill deskbar-applet to reap the zombie. As soon as I restart deskbar-applet, it produces a new zombie process.

deskbar-applet 2.22.2.1-0ubuntu1 from proposed

Launchpad Janitor (janitor) wrote :
Download full text (3.8 KiB)

This bug was fixed in the package deskbar-applet - 2.23.3-0ubuntu1

---------------
deskbar-applet (2.23.3-0ubuntu1) intrepid; urgency=low

  * New upstream version:
    - Use subprocess module instead of os.popen.
      Catch OSError when retrieving version
    - Escape url for tooltip in ShowUrlAction.py
    - Added Wikipedia Suggest module (lp: #234146)
    - Set snippet correctly for feeds, web history and E-Mails in beagle-live.
      Changed displayed text slightly for those actions.
    - Show tooltip when hovering over the arrow if more than one
      action is available.
    - Added get_tooltip method to Action interface. Override this method to
      display a tooltip when the user hovers over the match (the default
      action's tooltip is displayed) or over an action
      in the list of additional actions.
    - Fixed bug #522585: Crash when changing default browser
    - Added support for iceweasel browser. When the default browser is changed
      mozilla and iceweasel are supported, too. When Firefox is used and the
      command must contain firefox instead of being exactly firefox
    - Added OpenThunderbirdMailMessageAction. Mail messages are now opened in
      either evolution or thunderbird (fixes #420475).
      Display e-mail address as author when no name is available
    - Fixed bug #474496: Files that are in archives will appear as
      "Open <archive> containing <file>"
    - Mark history ComboBox and Clear History button insensitive when no items
      are in history
    - Only store window position when window UI is used
    - Find programs in $PATH that start with the search term
    - Added Capuchin support
    - Fixed: Error dialog appears when installing a valid module after an
      invalid one has been installed.
    - Added (set|get)_snippet methods to Match interface. If a snippet is set
      it will displayed in a new line under the matche's get_verb value
    - Added the possibility to run Deskbar as a tray icon instead of an applet
      with the -t option from the commandline. It only works with Window UI.
    - Fixed exception when changing default browser
      while preferences window is open
    - load_icon returns None if fall back icon 'stock_unknown' is not present
      in the theme
    - The size of the icon in the panel is no longer based on applet's size
      hint, but the allocation width and height.
    - When checking firefox version. Wait until the process terminated to
      avoid zombie processes. (lp: #209662)
    - Use gtk-clear icon instead of gtk-empty for "Clear history" item
      in popup menu
    - Show match that opens beagle-search when more than the maximum results
      have been found. It will only be searched for this particular category.
    - Fixed bug #520278: Window in sticky mode too small (lp: #149366)
    - Added support to change the language the search results should be in
      to Yahoo module
    - Added possibility to search for specific formats only.
      If the query contains format:<format> only those files are searched
    - Added new YahooSuggestHandler module.
      It suggests alternative queries based on the given query.
    - Added new Google Co...

Read more...

Changed in deskbar-applet:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Since the new deskbar-applet otherwise works fine, I copied it to hardy-updates. However, I reopen this bug because it doesn't seem to get fixed by the SRU.

Changed in deskbar-applet:
status: Fix Committed → Confirmed
status: Fix Released → Confirmed
Martin Pitt (pitti) wrote :

Unsub'ed ubuntu-sru. Please resubscribe when SRU is ready.

Timo Aaltonen (tjaalton) wrote :

deskbar-applet is gone, closing the bug

Changed in deskbar-applet (Ubuntu Hardy):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Confirmed → Won't Fix
Changed in deskbar-applet (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers