deluge-gtk crashed with KeyError in cell_priority_icon(): 3

Bug #970689 reported by Mtt.Castelli on 2012-04-01
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Deluge
Fix Released
Unknown
deluge (Ubuntu)
Low
Unassigned

Bug Description

~$ lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04

~$ uname -a
Linux BilboBaggins 3.2.13-030213-generic #201203231755 SMP Fri Mar 23 22:03:22 UTC 2012 i686 i686 i386 GNU/Linux

apt-cache policy deluge
deluge:
  Installato: 1.3.4-1
  Candidato: 1.3.4-1
  Tabella versione:
 *** 1.3.4-1 0
        500 http://it.archive.ubuntu.com/ubuntu/ precise/universe i386 Packages
        100 /var/lib/dpkg/status
matteo@BilboBaggins:~$ apt-cache policy deluge-web
deluge-web:
  Installato: 1.3.4-1
  Candidato: 1.3.4-1
  Tabella versione:
 *** 1.3.4-1 0
        500 http://it.archive.ubuntu.com/ubuntu/ precise/universe i386 Packages
        100 /var/lib/dpkg/status

I've changed files downland priority trough Transdroid (an Android remote torrent control app), then
when I come back seeing deluge-gtk interface on my desktop, it crashed and launch a ton of apport instances,
just when I switch to files tab.

Altought Transdroid action, files priority has not been changed.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: deluge-gtk 1.3.4-1
Uname: Linux 3.2.13-030213-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.0-0ubuntu2
Architecture: i386
CrashCounter: 1
Date: Sun Apr 1 11:02:02 2012
ExecutablePath: /usr/bin/deluge-gtk
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110921.2)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/deluge-gtk
PythonArgs: ['/usr/bin/deluge-gtk']
SourcePackage: deluge
Title: deluge-gtk crashed with KeyError in cell_priority_icon(): 3
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Mtt.Castelli (mtt.castelli) wrote :
visibility: private → public
Cas (calumlind) wrote :

This is an issue in Transdroid because the value '3' has been set but the only valid values for priorities are the following:

    0: "Do Not Download",
    1: "Normal Priority",
    5: "High Priority",
    7: "Highest Priority",

However saying that, the core method should probably verify valid priorities before setting.

Changed in deluge (Ubuntu):
importance: Undecided → Low
tags: removed: need-duplicate-check
Cas (calumlind) on 2012-04-02
Changed in deluge (Ubuntu):
status: New → Confirmed
Changed in deluge:
status: Unknown → New
Cas (calumlind) on 2012-04-08
Changed in deluge (Ubuntu):
status: Confirmed → Fix Committed
Changed in deluge:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package deluge - 1.3.5-0ubuntu1

---------------
deluge (1.3.5-0ubuntu1) precise; urgency=low

  * New upstream bug-fix release.
   - Bring MainWindow to front when opening another
     instance (LP: #939707).
   - Fix KeyError in gtkui when file priority set to
     value '3' (LP: #970689).
   - And many more...
  * Retroactively fix changelog versioning for last
    upload (LP: #962366).
 -- Andrew Starr-Bochicchio <email address hidden> Tue, 10 Apr 2012 11:27:37 -0400

Changed in deluge (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.