config.py IndexError in save(): list index out of range

Bug #852454 reported by christopher pijarski on 2011-09-17
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Deluge
Fix Released
Unknown
deluge (Ubuntu)
Undecided
Unassigned

Bug Description

after some update ( don't know which) deluge stopped loading with the following message:

Traceback (most recent call last):
  File "/usr/bin/deluge", line 9, in <module>
    load_entry_point('deluge==1.3.3', 'gui_scripts', 'deluge')()
  File "/usr/lib/python2.7/dist-packages/deluge/main.py", line 126, in start_ui
    UI(options, args, options.args)
  File "/usr/lib/python2.7/dist-packages/deluge/ui/ui.py", line 127, in __init__
    config.save()
  File "/usr/lib/python2.7/dist-packages/deluge/config.py", line 409, in save
    start, end = objects[0]
IndexError: list index out of range

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: deluge 1.3.3-1
ProcVersionSignature: Ubuntu 3.0.0-11.17-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
ApportVersion: 1.22.1-0ubuntu2
Architecture: amd64
Date: Sat Sep 17 11:23:56 2011
ExecutablePath: /usr/bin/deluge
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110803.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/deluge
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
PythonArgs: ['/usr/bin/deluge']
SourcePackage: deluge
Title: deluge crashed with IndexError in save(): list index out of range
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

tags: removed: need-duplicate-check
Cas (calumlind) wrote :

Can you try running deluge with a fresh config.

visibility: private → public
Cas (calumlind) on 2011-11-13
Changed in deluge (Ubuntu):
status: New → Incomplete

hello & sorry for not providing any feedback for this - Cas, thank you for the hint! I tried running with a fresh config and everything started working. I suppose this solves my "bug" doesn't it?

Cas (calumlind) wrote :

Did you upgrade from an older version of Deluge? Also do you to still have the old config, in particular the ui.conf or gtkui.conf files to see what might be causing the issue.

It is a difficult issue to debug as I cannot replicate but it seems some Fedora users have encountered it from time to time so I'll leave it as new for now.

Changed in deluge (Ubuntu):
status: Incomplete → New
summary: - deluge crashed with IndexError in save(): list index out of range
+ config.py IndexError in save(): list index out of range
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in deluge (Ubuntu):
status: New → Confirmed
iMac (imac-netstatz) wrote :

Is the clear config workaround "gconftool-2 --recursive-unset /apps/deluge"?

Cas (calumlind) wrote :

The problem will be with either ui.conf or gtkui.conf in '~/.config/deluge' so if you can move/rename those files to see if that solves the issue.

The alternative is to start deluge from the terminal and use the '-c' option to specify a new config location.

iMac (imac-netstatz) wrote :

I moved my .config/deluge out of the way completely and it resolved my issue. I kept it around if it is useful, but it sounds like this issue has been identified.

Cas (calumlind) on 2011-11-22
Changed in deluge (Ubuntu):
status: Confirmed → Fix Committed
Changed in deluge:
status: Unknown → Fix Released
Cas (calumlind) on 2012-03-22
Changed in deluge (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.