Unhandled UnpicklingError with corrupt state file

Bug #750146 reported by John Ryler
36
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Deluge
Fix Released
Unknown
deluge (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: deluge

unable to open the soft crashes before opening

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: deluge-gtk 1.3.1-1ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
Architecture: i386
Date: Mon Apr 4 12:19:28 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/deluge-gtk
InterpreterPath: /usr/bin/python2.7
ProcCmdline: /usr/bin/python /usr/bin/deluge-gtk
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/deluge-gtk']
SourcePackage: deluge
Title: deluge-gtk crashed with UnpicklingError in load_state(): invalid load key, '�'.
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Revision history for this message
John Ryler (johnryler) wrote :
tags: removed: need-duplicate-check
Cas (calumlind)
visibility: private → public
Revision history for this message
Cas (calumlind) wrote :

This is caused by a corrupt state file.

There is forum thread that contains steps to fix: http://ubuntuforums.org/showthread.php?t=1497782

I'll leave this bug open as the error should be handled properly.

Changed in deluge (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
summary: - deluge-gtk crashed with UnpicklingError in load_state(): invalid load
- key, 'Õ'.
+ Unhandled UnpicklingError with corrupt state file
Cas (calumlind)
Changed in deluge (Ubuntu):
status: Confirmed → Fix Committed
Changed in deluge:
status: Unknown → Fix Released
Bilal Shahid (s9iper1)
Changed in deluge (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Cas (calumlind) wrote :

This fix has not been released, we use our bug tracker differently.

Changed in deluge (Ubuntu):
status: Fix Released → Fix Committed
Cas (calumlind)
Changed in deluge (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.