deluge-common should not depend on python-libtorrent

Bug #672069 reported by Marcus
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
deluge (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: deluge

If you use deluge-gtk with a deluged running on a headless server, deluge-gtk depends on deluge-common which in return depends on python-libtorrent.
However, if you do not run a local deluged, there is absolutely no reason for deluge-common to pull in python-libtorrent.
This should be packaged cleaner.

I have not checked in detail, but i would assume that this might be the case for other deluge-common dependencies as well.

Marcus (m-beyer5)
tags: added: packaging
Cas (calumlind)
Changed in deluge (Ubuntu):
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package deluge - 1.3.2-1

---------------
deluge (1.3.2-1) unstable; urgency=low

  * New upstream version.
    - fix arguments handling in deluge-console (Closes: #619565).
    - new_release_check.patch: refreshed.
  * debian/{control,rules}: switch from python-support to dh_python2.
  * debian/control: bump up Standards-Version to 3.9.2.
  * debian/control: move the python-libtorrent dependency from package
    deluge-common to packages deluged and deluge and clarify packages
    description, in order to be able to run the GTK+ user-interface as
    a thin client (LP: #672069).
 -- Andrew Starr-Bochicchio <email address hidden> Sat, 11 Jun 2011 11:23:10 +0000

Changed in deluge (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers