Ubuntu

indicator for deluge

Reported by Sergey Klimov on 2010-05-23
70
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Ayatana Ubuntu
Wishlist
Karl Lattimer
Deluge
Fix Released
Unknown
deluge (Ubuntu)
Wishlist
Andrew Starr-Bochicchio

Bug Description

Binary package hint: deluge

deluge needs indicator (via dbus/libindicator i think)

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: deluge 1.2.2-2
Uname: Linux 2.6.34-999-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sun May 23 20:39:46 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
PackageArchitecture: all
ProcEnviron:
 LANG=ru_UA.utf8
 SHELL=/bin/bash
SourcePackage: deluge

Related branches

Sergey Klimov (nbdarvin) wrote :

Some relevant upstream discussion starting here:

http://<email address hidden>/msg00794.html

tags: added: indicator-application
Changed in deluge (Ubuntu):
status: New → Confirmed
importance: Undecided → Wishlist
Robert Roth (evfool) on 2010-07-01
tags: added: trayaway
removed: indicator-application
Robert Roth (evfool) on 2010-07-01
tags: added: indicator-application

I was going to file a bug about it, I hope they implement this for maverick.

Sense Egbert Hofstede (sense) wrote :

I'm working on this, but work is being blocked by bug #608219.

Changed in deluge (Ubuntu):
assignee: nobody → Sense Hofstede (sense)
status: Confirmed → In Progress
Sense Egbert Hofstede (sense) wrote :

The attached patch contains the bulk of the code for creating an Application Indicator for Deluge HEAD.

It doesn't work yet, as it depends on bug #608219, and might need some changes after that bug is fixed.

By default the Application Indicator component is disabled and the systemtray extension is used. Set the preference 'enable_application_indicator' to True. You can find it at 'deluge/ui/gtkui/gtkui.py:113'.

Jorge O. Castro (jorge) on 2010-08-05
Changed in deluge (Ubuntu):
assignee: Sense Hofstede (sense) → nobody
assignee: nobody → Karl Lattimer (karl-qdh)
Andrew Resch (andar) wrote :

I'd like to include this upstream, but I am not entirely convinced of the approach taken in this patch. Adding an additional component that is essentially a copy and paste of the existing SystemTray component isn't really ideal. There is way too much code duplication and this will become a maintenance nightmare.

The better approach would be to modify SystemTray to use either a gtkStatusIcon or the Appindicator possibly based on a configuration value or simply in an order of preference, eg, use the Appindicator if the 'import appindicator' succeeds. I haven't taken a hard look at the patch, but it's likely that this could be accomplished with far less new lines of code. There are other options too, you could for instance, create a base class and subclass the SystemTray and Appindicator respectively.

Thanks for your time in adding this functionality, I hope that we can add it to Deluge in the future.

Karl Lattimer (karl-qdh) wrote :

Thats really not too hard to do, so I'll have a poke at it tomorrow as I've just been given this bug :)

Changed in deluge (Ubuntu):
assignee: Karl Lattimer (karl-qdh) → nobody
Johannes Hell (johanneshell) wrote :

Are there any news on indicator support for deluge? It would be ver nice if this was included.

Sense Egbert Hofstede (sense) wrote :

There is some large work planned to merge the GtkMenu processing code of AppMenu and Application Indicators, which will probably solve a lot of bugs we are experiencing right now, and which are also blocking this indicator.

I have already got an indicator that is almost finished, it is just buggy. When the bugs are gone I expect it to be very easy to finish it and submit the Deluge Application Indicator.

Karl Lattimer (karl-qdh) on 2010-11-04
Changed in deluge (Ubuntu):
assignee: nobody → Karl Lattimer (karl-qdh)
David Barth (dbarth) on 2010-11-09
tags: added: dev
Changed in ayatana-ubuntu:
status: New → In Progress
importance: Undecided → Wishlist
assignee: nobody → Karl Lattimer (karl-qdh)
Karl Lattimer (karl-qdh) wrote :

latest patch, this almost works around the download/upload speed menu items not having the submenus but still those submenus emit signals on the wrong radio menu item.

This patch also merges together the systemtray and appindicator modules as they were far too similar.

Karl Lattimer (karl-qdh) wrote :

@Andrew Resch: Is the patch in comment #10 more to your liking, would you care to accept this upstream?

Changed in deluge (Ubuntu):
assignee: Karl Lattimer (karl-qdh) → nobody
Karl Lattimer (karl-qdh) on 2011-03-07
Changed in ayatana-ubuntu:
status: In Progress → Triaged
Changed in deluge (Ubuntu):
status: In Progress → Confirmed
Anatoly Kudinov (zz) wrote :

This is already in 1.3-stable branch http://dev.deluge-torrent.org/ticket/1514#comment:3, but deb is not updated since patch inclusion so i cant say if it works or not

It should be included in the next Deluge point release 1.3.2. Here's the commit:

http://git.deluge-torrent.org/deluge/commit/?h=1.3-stable&id=fd3a33af03b96a868545fa20e9f67af7d1a1b157

I'll look into backporting this to Ubuntu.

Changed in deluge (Ubuntu):
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
status: Confirmed → Triaged
Changed in deluge (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package deluge - 1.3.1-1ubuntu2

---------------
deluge (1.3.1-1ubuntu2) natty; urgency=low

  * Backport indicator support from upstream 1.3.x
    stable branch (LP: #584669).
 -- Andrew Starr-Bochicchio <email address hidden> Sun, 13 Mar 2011 14:36:24 -0400

Changed in deluge (Ubuntu):
status: In Progress → Fix Released
Karl Lattimer (karl-qdh) on 2011-03-28
Changed in ayatana-ubuntu:
status: Triaged → Fix Released
Cas (calumlind) on 2012-03-23
Changed in deluge:
importance: Undecided → Unknown
status: New → Unknown
Changed in deluge:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.