Deluge unable to delete torrents with delete key

Bug #362225 reported by David Kelly
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Deluge
Fix Released
Unknown
deluge (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: deluge

In previous versions of Ubuntu/Deluge, pressing the delete key on the keyboard caused selected torrents to be deleted. During recent updates this functionality has stopped working. Pressing the delete key now does nothing. One must manually click on "Remove Torrent" in order for them to be removed. This is in reference to the GTK Interface of Deluge.

Description: Ubuntu 9.04
Release: 9.04

deluge:
  Installed: 1.1.6+dfsg-2ubuntu1
  Candidate: 1.1.6+dfsg-2ubuntu1
  Version table:
 *** 1.1.6+dfsg-2ubuntu1 0
        500 http://us.archive.ubuntu.com jaunty/universe Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: deluge 1.1.6+dfsg-2ubuntu1
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: deluge
Uname: Linux 2.6.28-11-generic i686

Revision history for this message
David Kelly (davidkelly999) wrote :
Revision history for this message
David Kelly (davidkelly999) wrote :

Here is a patch which sets the delete key to remove selected torrents

Revision history for this message
Andrew Starr-Bochicchio (andrewsomething) wrote :

Thanks for your work! Forwarded upstream for comment.

Changed in deluge (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in deluge:
status: Unknown → New
Revision history for this message
Cristian Greco (cgreco) wrote : wishlist

 importance wishlist

Thanks,
--
Cristian Greco
GPG key ID: 0x0C095825

Changed in deluge (Ubuntu):
importance: Low → Wishlist
Revision history for this message
Przemysław Kochański (kochas315) wrote :

It's been half a year now, the patch has been provided bit the bug still persist in 1.1.9 on Ubuntu Karmic 9.10. When it will be implemented upstream?

Changed in deluge:
status: New → Fix Released
Revision history for this message
Timmy Shih Jun Yee (shijun) wrote :

The delete key works as intended in Deluge 1.2.2-2 (on Lucid).

Changed in deluge (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.