Please merge deluge 1.1.5+dfsg-1 from Debian unstable (main)

Bug #340481 reported by Hew on 2009-03-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
deluge (Ubuntu)
Wishlist
Unassigned

Bug Description

Deluge 1.1.5 - (16 March 2009)
Core

    * Fix config file saving when no current config file exists

GtkUI

    * Add 'Comments' field to the Details tab
    * Fix #841 maximum upload slots tooltip

Deluge 1.1.4 - (08 March 2009)
Core

    * Fix displaying file errors when the torrent isn't paused
    * Fix issue where torrents being check would get removed due to "stop at ratio" rules
    * Fix #790 tracker hosts not correct for some .uk trackers
    * Make sure config files, resume data and state are fsync'd when saved. This should help prevent data losses on crashes/improper shutdowns.

GtkUI

    * Fix hiding bottom pane when no tabs are enabled upon restart
    * Fix saving file priorities when switching torrents in the addtorrentdialog
    * Fix the allocate mode not being preserved when selecting different torrents in addtorrentdialog
    * Fix #655 issue where default torrent options wouldn't be set for new torrents added to the addtorrentdialog
    * Fix #817 email notifications fail to substitute format strings

Plugins

    * Label: Fix setting 'Move on completed' folder when connected to a remote daemon

Debian changes:

deluge (1.1.5+dfsg-1) unstable; urgency=low

  * New upstream version.
    - debian/patches: remove 20-fix-config-files-backup.dpatch (fixed
      upstream).
  * debian/watch: updated upstream tarball location.
  * debian/control: added Depends: on xdg-utils for deluge-core (Closes:
    #519763).

 -- Cristian Greco <email address hidden> Tue, 17 Mar 2009 23:34:51 +0100

deluge (1.1.4+dfsg-2) unstable; urgency=low

  * debian/patches: new patch 20-fix-config-files-backup.dpatch pulled from
    upstream svn should fix a problem with config files (Closes: #519042).
  * debian/control: bump up Standards-Version to 3.8.1 (no changes required).

 -- Cristian Greco <email address hidden> Thu, 12 Mar 2009 09:51:32 +0100

deluge (1.1.4+dfsg-1) unstable; urgency=low

  * New upstrean version.
  * debian/copyright: updated.
  * debian/control: depends on python-libtorrent (>= 0.14.2).
  * Upload to unstable.

 -- Cristian Greco <email address hidden> Sun, 08 Mar 2009 20:44:36 +0100

Changes made to proposed 1.1.4:

deluge (1.1.4+dfsg-2ubuntu1) jaunty; urgency=low

  * Merge from debian unstable (LP: #340481), remaining changes:
   - Python 2.6 transition (LP: #336229):
    + debian/*.intall: Install to usr/lib/python*/*-packages/
    + debian/rules: Pass --install-layout=deb to setup.py

 -- Andrew Starr-Bochicchio <email address hidden> Thu, 12 Mar 2009 17:02:06 +0000

Related branches

Changed in deluge:
status: New → Confirmed

This actually needs to be a merge due to the python 2.6 transition....

Changed in deluge (Ubuntu):
assignee: nobody → andrewsomething
importance: Undecided → Wishlist
status: Confirmed → In Progress
Changed in deluge (Ubuntu):
assignee: andrewsomething → nobody
status: In Progress → Confirmed
description: updated
Hew (hew) on 2009-03-18
description: updated
Hew (hew) wrote :

Fortunately or unfortunately, depending on how you look at it, there is a new Deluge bugfix release barely a week after the previous one. Please merge deluge 1.1.5+dfsg-1.

Thanks for your work Andrew.

Changed in deluge (Ubuntu):
status: Confirmed → New

Here are updated debdiffs. Deleting the old ones so there's no confusion.

Changed in deluge (Ubuntu):
status: New → Confirmed
Dmitry Korzhevin (korg) wrote :

Please, sync Deluge 1.1.5 to Ubuntu 9.04

 status inprogress
 assignee quadrispro

--
Alessio Treglia <email address hidden>
Ubuntu MOTU Developer | Homepage: http://www.alessiotreglia.com
0FEC 59A5 E18E E04F 6D40 593B 45D4 8C7C DCFC 3FD0

Changed in deluge:
assignee: nobody → quadrispro
status: Confirmed → In Progress

Uploaded, thanks for your work.
Please submit this debdiff to debian BTS.

 status fixcommitted
 assignee nobody

--
Alessio Treglia <email address hidden>
Ubuntu MOTU Developer | Homepage: http://www.alessiotreglia.com
0FEC 59A5 E18E E04F 6D40 593B 45D4 8C7C DCFC 3FD0

Changed in deluge:
assignee: quadrispro → nobody
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package deluge - 1.1.5+dfsg-1ubuntu1

---------------
deluge (1.1.5+dfsg-1ubuntu1) jaunty; urgency=low

  * Merge from debian unstable (LP: #340481), remaining changes:
   - Python 2.6 transition (LP: #336229):
    + debian/*.intall: Install to usr/lib/python*/*-packages/
    + debian/rules: Pass --install-layout=deb to setup.py

 -- Andrew Starr-Bochicchio <email address hidden> Wed, 18 Mar 2009 10:55:02 +0000

Changed in deluge:
status: Fix Committed → Fix Released
Dmitry Korzhevin (korg) wrote :

deluge 1.1.6 released, this is fix only release, please update it for Ubuntu 9.04

Changelog for deluge 1.1.6

Deluge 1.1.6 - (06 April 2009)
Core

    * Fix udp trackers being classified as DHT source
    * Fix #855 force a resume on a torrent if a 'Force Recheck' is initiated
    * Fix #862 deluged crash when access http://localhost:58846

GtkUI

    * Fix displaying torrents with non-utf8 encodings in add torrent dialog

WebUI

    * Fix #870 use proper config location for loading ssl cert

Misc

    * Add OpenSSL exception to license

@Dmitry

Already done. See LP Bug #357126

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers