deluged errors related to wrong libtorrent version installed.

Bug #1633785 reported by Troy Rockwood on 2016-10-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Deluge
Unknown
Low
deluge (Ubuntu)
Undecided
Andrew Starr-Bochicchio
libtorrent-rasterbar (Ubuntu)
High
Unassigned

Bug Description

When invoking deluged I get the following error messages:

/usr/lib/python2.7/dist-packages/deluge/_libtorrent.py:59: RuntimeWarning: to-Python converter for boost::shared_ptr<libtorrent::alert> already registered; second conversion method ignored.
  import libtorrent as lt
[ERROR ] 15:23:59 preferencesmanager:502 Unable to load geoip database!
[ERROR ] 15:23:59 preferencesmanager:503 'session' object has no attribute 'load_country_db'
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/deluge/core/preferencesmanager.py", line 500, in _on_geoip_db_location
    self.session.load_country_db(str(geoip_db))
AttributeError: 'session' object has no attribute 'load_country_db'

according to http://dev.deluge-torrent.org/ticket/2902 this is caused by the wrong version of libtorrent being installed (16.10 has libtorrent 1.1.0-3 but apparently deluged needs 1.1.1.)

The error causes the thin client deluge to not be able to connect to the daemon.

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: deluged 1.3.12-1ubuntu1
ProcVersionSignature: Ubuntu 4.8.0-22.24-generic 4.8.0
Uname: Linux 4.8.0-22-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.3-0ubuntu8
Architecture: amd64
CurrentDesktop: Unity
Date: Sat Oct 15 15:57:42 2016
InstallationDate: Installed on 2016-10-13 (2 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
PackageArchitecture: all
SourcePackage: deluge
UpgradeStatus: Upgraded to yakkety on 2016-10-15 (0 days ago)

Troy Rockwood (troyrock) wrote :
Troy Rockwood (troyrock) on 2016-10-17
description: updated
Cas (calumlind) on 2016-10-17
Changed in libtorrent-rasterbar (Ubuntu):
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
importance: Undecided → High
Changed in deluge (Ubuntu):
status: New → Invalid
Cas (calumlind) on 2016-10-17
Changed in libtorrent-rasterbar (Ubuntu):
status: New → Confirmed
status: Confirmed → Invalid
Cas (calumlind) wrote :

I just realised this is not a bug, geoip support was dropped in 1.1 and this is simply a log message from Deluge 1.3 when it encounters the missing method.

See Deluge ticket for details.

Changed in deluge (Ubuntu):
status: Invalid → New
Cas (calumlind) on 2016-10-17
Changed in deluge (Ubuntu):
status: New → Fix Committed
Cas (calumlind) wrote :

@andrewsomething You could patch Deluge with the improved log message so users won't see this exception: http://dev.deluge-torrent.org/changeset/6c73105a7307508

Changed in deluge:
importance: Unknown → Low
Changed in libtorrent-rasterbar (Ubuntu):
assignee: Andrew Starr-Bochicchio (andrewsomething) → nobody
Changed in deluge (Ubuntu):
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
Cas (calumlind) wrote :

Also to add that the libtorrent boost RuntimeWarning can be ignored but has been reported upstream for fixing: https://github.com/arvidn/libtorrent/issues/1217

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package deluge - 1.3.13+git20161130.48cedf63-1ubuntu1

---------------
deluge (1.3.13+git20161130.48cedf63-1ubuntu1) zesty; urgency=medium

  * Merge from Debian (LP: #1663754), remaining changes:
   - Explicitly recommend python-appindicator to ensure
     panel indicator is available (LP: #1384508).

deluge (1.3.13+git20161130.48cedf63-1) unstable; urgency=medium

  * New upstream git snapshot (Closes: #835049) (LP: #1633785).

deluge (1.3.13-1) unstable; urgency=medium

  * New upstream release (Closes: #838640).
  * Remove revert-erroneous-commit.patch, applied upstream.
  * Bump Standards-Version to 3.8.8, no changes needed.
  * Remove unused license stanza in debian/control.

 -- Unit 193 <email address hidden> Fri, 10 Feb 2017 14:20:55 -0800

Changed in deluge (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.