TypeError: attributes() got an unexpected keyword argument 'apply_with_init'

Bug #1492394 reported by Nicholas Skaggs on 2015-09-04
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
NULL Project
Undecided
Unassigned
deluge (Ubuntu)
Undecided
Unassigned
python-service-identity (Debian)
Fix Released
Unknown
python-service-identity (Ubuntu)
Critical
Unassigned

Bug Description

attempting to launch deluge-gtk results in this crash.

Traceback (most recent call last):
  File "/usr/bin/deluge-gtk", line 9, in <module>
    load_entry_point('deluge==1.3.11', 'gui_scripts', 'deluge-gtk')()
  File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 558, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2682, in load_entry_point
    return ep.load()
  File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2355, in load
    return self.resolve()
  File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2361, in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
  File "/usr/lib/python2.7/dist-packages/deluge/ui/gtkui/__init__.py", line 1, in <module>
    from gtkui import start
  File "/usr/lib/python2.7/dist-packages/deluge/ui/gtkui/gtkui.py", line 87, in <module>
    from deluge.ui.client import client
  File "/usr/lib/python2.7/dist-packages/deluge/ui/client.py", line 37, in <module>
    from twisted.internet import reactor, ssl, defer
  File "/usr/lib/python2.7/dist-packages/twisted/internet/ssl.py", line 223, in <module>
    from twisted.internet._sslverify import (
  File "/usr/lib/python2.7/dist-packages/twisted/internet/_sslverify.py", line 192, in <module>
    verifyHostname, VerificationError = _selectVerifyImplementation(OpenSSL)
  File "/usr/lib/python2.7/dist-packages/twisted/internet/_sslverify.py", line 167, in _selectVerifyImplementation
    from service_identity import VerificationError
  File "/usr/lib/python2.7/dist-packages/service_identity/__init__.py", line 12, in <module>
    from . import pyopenssl
  File "/usr/lib/python2.7/dist-packages/service_identity/pyopenssl.py", line 14, in <module>
    from ._common import (
  File "/usr/lib/python2.7/dist-packages/service_identity/_common.py", line 136, in <module>
    @attributes(["pattern"], apply_with_init=False)
TypeError: attributes() got an unexpected keyword argument 'apply_with_init'

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: deluge-gtk 1.3.11-0ubuntu2
ProcVersionSignature: Ubuntu 4.1.0-3.3-generic 4.1.3
Uname: Linux 4.1.0-3-generic x86_64
ApportVersion: 2.18-0ubuntu9
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Sep 4 12:50:42 2015
PackageArchitecture: all
SourcePackage: deluge
UpgradeStatus: No upgrade log present (probably fresh install)

Nicholas Skaggs (nskaggs) wrote :
summary: - Deluge crashes on start
+ TypeError: attributes() got an unexpected keyword argument
+ 'apply_with_init'
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in deluge (Ubuntu):
status: New → Confirmed
Changed in deluge:
status: Unknown → New
Cas (calumlind) on 2015-09-04
Changed in deluge (Ubuntu):
status: Confirmed → Invalid
Changed in python-service-identity (Ubuntu):
status: New → Confirmed

Workaround to start Deluge:
comment out all appearances of "apply_with_init=False" in /usr/lib/python2.7/dist-packages/service_identity/_common.py
E.g., from:
@attributes(["pattern"], apply_with_init=False)
To:
@attributes(["pattern"]) #, apply_with_init=False)

Cas (calumlind) wrote :

The problem is a result of python-service-identity package not requiring python-characteristics>=14.0.0

https://github.com/pyca/service_identity/blob/14.0.0/setup.py#L39

Changed in python-service-identity (Ubuntu):
importance: Undecided → Critical
Changed in python-service-identity (Debian):
status: Unknown → New

It looks like there was briefly a version mismatch between python-service-identity and python-characteristic. I can not longer reproduce this. Can someone who was experiencing the problem before confirm that, after the python-characteristic 14.3.0-1 update is installed, the problem no longer occurs?

affects: deluge → null-and-void
Changed in null-and-void:
importance: Unknown → Undecided
status: New → Invalid
Changed in python-service-identity (Ubuntu):
status: Confirmed → Incomplete
Changed in python-service-identity (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.