deluge-gtk's indicator has no title

Bug #1000350 reported by Chow Loong Jin
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Deluge
Fix Released
Unknown
deluge (Ubuntu)
Low
Chow Loong Jin
Precise
Undecided
Unassigned

Bug Description

In the HUD, the Deluge indicator's menu items show up as "Untitled Indicator (deluge) > …."

TEST CASE:
1. Launch Deluge (deluge-gtk)
2. Press Alt to activate the HUD.
3. Type "Show Deluge"

With fix:
The HUD entry shows "Deluge > Show Deluge"

Without fix:
The HUD entry shows "Untitled Indicator (deluge) > Show Deluge" (or similar).

Related branches

Changed in deluge (Ubuntu):
assignee: nobody → Chow Loong Jin (hyperair)
status: New → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package deluge - 1.3.5-0ubuntu2

---------------
deluge (1.3.5-0ubuntu2) quantal; urgency=low

  * debian/patches/ubuntu_indicator.patch:
    - Set indicator title for HUD (LP: #1000350)
  * debian/control:
    - Make deluge-gtk depend on python-appindicator
 -- Chow Loong Jin <email address hidden> Thu, 17 May 2012 01:10:19 +0800

Changed in deluge (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Andrew Starr-Bochicchio (andrewsomething) wrote :

Hmm... I can seem to make that string show up in the HUD, but looking at the code it indeed does not set an indicator title. It should be as simple as adding something like: self.indicator.set_title("Deluge") around line 112 of deluge/ui/gtkui/systemtray.py

I imagine that upstream would take this.

Revision history for this message
Andrew Starr-Bochicchio (andrewsomething) wrote :

^
s/can/can't/

Revision history for this message
Chow Loong Jin (hyperair) wrote :

If you have a newer libindicate installed, it might be that the Glib application name as set by g_set_application_name() is used for the indicator title. However, this version of libindicate is not in Precise, so it might be nice to SRU this fix as well.

Revision history for this message
Andrew Starr-Bochicchio (andrewsomething) wrote :

Thanks for the patch, hyperair.

In the past I've specifically not added a direct dependency on python-appindicator. It keeps us closer to Debian. Also the code gracefully falls back to the old systray even if "enable_appindicator": True is set if it's not installed. So if you install it on Unity the indicator will just work, but if you install it on another desktop you won't pull in the indicator stack.

Does that make sense?

If we think that we need the dependency, I've got a good relation with the Debian maintainer. I imagine he'd be open to using dpkg-vendor to generate Ubuntu specific depends if I provided the patch.

Changed in deluge (Ubuntu):
importance: Undecided → Low
description: updated
Changed in deluge (Ubuntu Precise):
status: New → Confirmed
Revision history for this message
Chow Loong Jin (hyperair) wrote : Re: [Bug 1000350] Re: deluge-gtk's indicator has no title

On 17/05/2012 01:56, Andrew Starr-Bochicchio wrote:
> Thanks for the patch, hyperair.
>
> In the past I've specifically not added a direct dependency on python-
> appindicator. It keeps us closer to Debian. Also the code gracefully
> falls back to the old systray even if "enable_appindicator": True is set
> if it's not installed. So if you install it on Unity the indicator will
> just work, but if you install it on another desktop you won't pull in
> the indicator stack.
>
> Does that make sense?

Yes, that makes sense, actually. I didn't notice that the import appindicator
was optional.

How about listing it under Recommends instead of Depends?

> If we think that we need the dependency, I've got a good relation with
> the Debian maintainer. I imagine he'd be open to using dpkg-vendor to
> generate Ubuntu specific depends if I provided the patch.

Sure, why not?

--
Kind regards,
Loong Jin

Changed in deluge:
status: Unknown → New
Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Hello Chow, or anyone else affected,

Accepted deluge into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in deluge (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: added: verification-needed
Revision history for this message
Chow Loong Jin (hyperair) wrote :

Looks like it works.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package deluge - 1.3.5-0ubuntu2~precise1

---------------
deluge (1.3.5-0ubuntu2~precise1) precise-proposed; urgency=low

  * Upload to precise-proposed

deluge (1.3.5-0ubuntu2) quantal; urgency=low

  * debian/patches/ubuntu_indicator.patch:
    - Set indicator title for HUD (LP: #1000350)
  * debian/control:
    - Make deluge-gtk depend on python-appindicator
 -- Chow Loong Jin <email address hidden> Thu, 17 May 2012 02:05:53 +0800

Changed in deluge (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in deluge:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.