Deluge torrent client: Cannot set file priority, as it continually claims that Full Allocation is not set

Bug #149050 reported by Dylan McCall
4
Affects Status Importance Assigned to Milestone
deluge-torrent (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Binary package hint: deluge-torrent

In Deluge 0.5.4, it is impossible to change the priority of files in a torrent; Deluge says "File priority can only be set when using Full Allocation".

This issue is solved in Deluge 5.5. I suggest an update to the package in official repositories before Gutsy's release.

Revision history for this message
Joe Terranova (joeterranova) wrote :

Also having this issue. Let me know if there's any sort of debugging you want for this. The console spits out nothing, and strace is useless. Ran into this issue using the "torrent-files" plugin, which comes with this package.

Changed in deluge-torrent:
status: New → Confirmed
Revision history for this message
Joe Terranova (joeterranova) wrote :
Revision history for this message
Joe Terranova (joeterranova) wrote :

Proposed patch from Deluge developer Marcos Pinto (markybob)
http://dpaste.com/21597/

I'll build it now and let you know if it works

Revision history for this message
Joe Terranova (joeterranova) wrote :

Converted markybob's patch to dpatch, tested patch against current package. Tested and works for me.

Changed in deluge-torrent:
assignee: nobody → joeterranova
status: Confirmed → In Progress
Revision history for this message
Joe Terranova (joeterranova) wrote :

deb diff

Revision history for this message
Joe Terranova (joeterranova) wrote :

New debdiff.

Revision history for this message
Joe Terranova (joeterranova) wrote :

Changed changelog to motu suggestions

Changed in deluge-torrent:
assignee: joeterranova → nobody
status: In Progress → Confirmed
Changed in deluge-torrent:
assignee: nobody → norsetto
status: Confirmed → In Progress
Revision history for this message
Cesare Tirabassi (norsetto) wrote :

Uploaded (with some modifications to changelog and patch comments).
Thanks for your contribution.

Changed in deluge-torrent:
assignee: norsetto → nobody
status: In Progress → Fix Committed
Revision history for this message
Joe Terranova (joeterranova) wrote :

deluge-torrent (0.5.4.1-1ubuntu3) gutsy; urgency=low

  * Add 002-Fix_Allocation_Type.dpatch to fix both use_compact_storage
    and use_full_storage set to true. (LP: #149050)
    Thanks to Marcos Pinto (markybob).

 -- Joseph Terranova <email address hidden> Fri, 06 Oct 2007 19:18:00 -0400

Changed in deluge-torrent:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers