GRUB menu pops up needlessly during factory install process

Bug #771560 reported by Mario Limonciello
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dell-recovery (Ubuntu)
Fix Released
Undecided
Unassigned
Natty
Fix Released
Undecided
Unassigned

Bug Description

Binary package hint: dell-recovery

version: 0.98

In a very specific factory install process, WinPE is present on one of the partitions for the duration of install, but gone after install completes. Because of this, grub-installer seems to get it in it's mind that there should be a Windows option in the grub menu.

That windows option is easily overridden by placing GRUB_DISABLE_OS_PROBER=true in /etc/default/grub, but the 10 second menu is still generated because of os-prober.

In scenarios that it's guaranteed only one OS is around, the os-prober binary can be moved out of $PATH to prevent these problems.

Fix:
one line fix, os-prober is renamed in the above scenario.

Regression Potential:
None. This only affects dell factory install process.

description: updated
Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Accepted dell-recovery into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in dell-recovery (Ubuntu Natty):
status: New → Fix Committed
tags: added: verification-needed
Revision history for this message
Mario Limonciello (superm1) wrote :

I've confirmed that the binary generated here does resolve the problem.

Thanks!

Martin Pitt (pitti)
tags: added: verification-done
removed: verification-needed
Revision history for this message
Martin Pitt (pitti) wrote :

As per Mario's request, I'm waiving the 7 day maturing period for this. This is blocking Dell, and only really affects Dell.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dell-recovery - 0.98.1

---------------
dell-recovery (0.98.1) natty-proposed; urgency=low

  * Move os-prober out of $PATH if installing to a single OS machine to prevent
    WinPE from setting off os-prober during grub-installer. (LP: #771560)
 -- Mario Limonciello <email address hidden> Tue, 26 Apr 2011 19:10:34 -0500

Changed in dell-recovery (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers