Can't restore from remote server after prompt for root password

Bug #929139 reported by Gary Mellor on 2012-02-08
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Déjà Dup
High
Unassigned
deja-dup (Ubuntu)
Undecided
Unassigned

Bug Description

~*~*~*~*~*~*~*~*~
ISSUE
~*~*~*~*~*~*~*~*~

I successfully backed my entire machine (/) up to an external NAS drive (Western Digital 500GB MyBook). However, when I came to test the restore I keep getting the same message: "Restore Failed: Connection failed, please check your password: Failed to mount Windows Share". This seems strange since I was able to write the backup to the NAS drive. I backed up over wifi and I am trying to restore via wifi.

~*~*~*~*~*~*~*~*~
STEPS
~*~*~*~*~*~*~*~*~

In the settings of Deja Dup, in the 'Storage' section, I have the following:

Backup location: Windows Share
Server: <my_server_network_name>
Folder: <my_backup_folder>
Username: <my_username>
Domain: WORKGROUP

I have triple checked these entries for schoolboy errors like typos and all is correct. One thing I did note is that I am not asked for the password to accompany the username.

So, I select the 'Restore' option from the 'Overview' section and a small 'Restore' dialog appears. The details here are exactly as I entered them. I also make sure at this point that the NAS share is *not* mounted. I then click 'Forward'. At this point the share is mounted - I can see it in the file explorer - it also correctly identifies the one and only backup made in the 'Date' drop down list box. I click 'Forward' again. In the 'Restore to where?' section I leave all at the defaults ('Restore to original file locations') and click 'Forward'. The 'Summary' screen shows. I then click 'Restore'. At this point I get a 'Preparing' progress bar. Expanding the details section shows nothing. My screen then goes black an I am asked to enter my administrator password ince Deja Dup will be modifying my system. I do this and then I get the error as mentioned: "Restore Failed: Connection failed, please check your password: Failed to mount Windows Share" - the share is already mounted at this point though so I am totally confused. I have tried specifying the NAS by network name and IP and manually mounting it and it results in the same error message each time. I was expecting it to restore the backup I just took. I will admit that the wording of the error message would indicate an error on my part but since the NAS share is mounted at the point I indicated earlier it seems somewhat misleading.

~*~*~*~*~*~*~*~*~
PACKAGE DETAILS
~*~*~*~*~*~*~*~*~

deja-dup:
  Installed: 20.1-0ubuntu0.2
  Candidate: 20.1-0ubuntu0.2
  Version table:
 *** 20.1-0ubuntu0.2 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     20.0-0ubuntu3 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages

~*~*~*~*~*~*~*~*~
SYSINFO
~*~*~*~*~*~*~*~*~

System information report, generated by Sysinfo: 08/02/2012 21:29:38
http://sourceforge.net/projects/gsysinfo

SYSTEM INFORMATION
 Running Ubuntu Linux, the Ubuntu 11.10 (oneiric) release.
 GNOME: 2.32.1 (Ubuntu 2011-04-14)
 Kernel version: 3.0.0-15-generic (#26-Ubuntu SMP Fri Jan 20 17:23:00 UTC 2012)
 GCC: 4.6.1 (x86_64-linux-gnu)
 Xorg: 1.10.4 (19 October 2011 05:21:26AM) (19 October 2011 05:21:26AM)
 Hostname: V5535
 Uptime: 0 days 0 h 55 min

CPU INFORMATION
 GenuineIntel, Intel(R) Core(TM)2 Duo CPU T7300 @ 2.00GHz
 Number of CPUs: 2
 CPU clock currently at 1200.000 MHz with 4096 KB cache
 Numbering: family(6) model(15) stepping(10)
 Bogomips: 4000.49
 Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm lahf_lm ida dts tpr_shadow vnmi flexpriority

MEMORY INFORMATION
 Total memory: 2761 MB
 Total swap: 2810 MB

STORAGE INFORMATION
 SCSI device - scsi0
  Vendor: HL-DT-ST
  Model: DVDRAM GSA-T20N
 SCSI device - scsi2
  Vendor: ATA
  Model: OCZ-VERTEX2

HARDWARE INFORMATION
MOTHERBOARD
 Host bridge
  Silicon Integrated Systems [SiS] 671MX
  Subsystem: Fujitsu Technology Solutions Device 1125
 PCI bridge(s)
  Silicon Integrated Systems [SiS] AGP Port (virtual PCI-to-PCI bridge) (prog-if 00 [Normal decode])
  Silicon Integrated Systems [SiS] PCI-to-PCI bridge (prog-if 00 [Normal decode])
  Silicon Integrated Systems [SiS] PCI-to-PCI bridge (prog-if 00 [Normal decode])
  Silicon Integrated Systems [SiS] PCI-to-PCI bridge (prog-if 00 [Normal decode])
  Silicon Integrated Systems [SiS] AGP Port (virtual PCI-to-PCI bridge) (prog-if 00 [Normal decode])
  Silicon Integrated Systems [SiS] PCI-to-PCI bridge (prog-if 00 [Normal decode])
  Silicon Integrated Systems [SiS] PCI-to-PCI bridge (prog-if 00 [Normal decode])
  Silicon Integrated Systems [SiS] PCI-to-PCI bridge (prog-if 00 [Normal decode])
 USB controller(s)
  Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f) (prog-if 10 [OHCI])
  Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f) (prog-if 10 [OHCI])
  Silicon Integrated Systems [SiS] USB 2.0 Controller (prog-if 20 [EHCI])
  Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f) (prog-if 10 [OHCI])
  Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f) (prog-if 10 [OHCI])
  Silicon Integrated Systems [SiS] USB 2.0 Controller (prog-if 20 [EHCI])
 ISA bridge
  Silicon Integrated Systems [SiS] SiS968 [MuTIOL Media IO] (rev 01)
 IDE interface
  Silicon Integrated Systems [SiS] SATA Controller / IDE mode (rev 03) (prog-if 8f [Master SecP SecO PriP PriO])
  Subsystem: Silicon Integrated Systems [SiS] SATA Controller / IDE mode

GRAPHIC CARD
 VGA controller
  Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10) (prog-if 00 [VGA controller])
  Subsystem: Fujitsu Technology Solutions Device 1125

SOUND CARD
 Multimedia controller
  Silicon Integrated Systems [SiS] Azalia Audio Controller
  Subsystem: Fujitsu Technology Solutions Device 1125

NETWORK
 Ethernet controller
  Atheros Communications Inc. AR242x / AR542x Wireless Network Adapter (PCI-Express) (rev 01)
  Subsystem: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: deja-dup 20.1-0ubuntu0.2
ProcVersionSignature: Ubuntu 3.0.0-15.26-generic 3.0.13
Uname: Linux 3.0.0-15-generic x86_64
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Wed Feb 8 21:31:21 2012
ExecutablePath: /usr/bin/deja-dup
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
SourcePackage: deja-dup
UpgradeStatus: No upgrade log present (probably fresh install)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in deja-dup (Ubuntu):
status: New → Confirmed
Wouter Smaal (w-smaal) on 2012-02-09
Changed in deja-dup (Ubuntu):
assignee: nobody → Wouter Smaal (w-smaal)
assignee: Wouter Smaal (w-smaal) → nobody
Wouter Smaal (w-smaal) wrote :

I have the same error message after restore missing files (Ubuntu 11.10):
"Restore Failed: Connection failed, please check your password: Failed to mount Windows Share"

My (temporary?) work-around is: Mount the Backup (NAS) directory to /mnt
(sudo mount.cifs //NAS/Backup /mnt/NAS/ -o user= your-uid,passwd=your-password

In Deja-dup (aka backup) Storage/Backup location = Local Folder (instead of Windows Share) and Choose folder = /mnt/NAS/Backup

Restore Missing files from my NAS to the external usb disk (/media/usb) now succeeded (with admin passwd) ...

Thanks for the workaround Wouter. I had to modify it slightly to:

sudo mount -t cifs //NAS/Backup /mnt/NAS/ -o user=your-uid,passwd=your-password,uid=1000

This was because:

[a] mount.cifs was not recognised, and;
[b] I couldn't get control of the /mnt/NAS/ directory so had to tell it who I was (uid=1000)

While this allowed me to get beyond my original issue (and I did see the restore start to take place) I kept getting another issue when it was attempting to restore .ko files. I tried 4 times to do the restore and each time it failed at a .ko file. The first three times it was at the same .ko file. The fourth time it was another (I don't remember the exact names and for reasons that will become apparent in a moment I was unable to get any screenshots).

When the problem occurred the machine 'locked up'; the keyboard stopped working as did the touchpad and touchpad buttons. Then the num-lock and scroll-lock lights flashed continuosly. Unsure of what was going on I left the laptop in this state for over 15 minutes/20 minutes/25 minutes and finally half and hour. It never recovered on any attempt and no further restore progress was made. On each occassion I was forced to power the machine off (not something I like doing but the machine was completely unresponsive due to the lack of keyboard/mouse controll). I couldn't even break out of X. On the fourth such power off the machine was left in a corrupted state and would no longer boot (I am unsure if this is as a direct result of removing the power or because of a partial restore). The machine got past BIOS and then I had a black screen with the num-lock and scroll-lock lights flashing on and off again.

I am now in the process of rebuilding that particular laptop. As I mentioned in my earlier post, the machine in question is a experimental machine for trying things out that I wouldn't like to do on my main machine. To this end it has served its purpose well. Given the issues with Deja Dup I won't be using it as my backup program.

I am very sorry I cannot provide you with more details about the .ko files it stopped at but due to the time involved in rebuilding the machine I won't be able to repeat the exercise.

Perhaps Deja Dup is good at restoring some folders and files but not the entire filesystem - perhaps that is why I have had this experience?

Regards

Gary.

Wouter Smaal (w-smaal) wrote :

For backing up and restoring trivial data, especially user home directories, Deja dup is (indeed) a good alternative. The restore problem which I have/had from NAS to the (external) usb disk is a permission problem, which I noticed too with other rsync programs and the command-line rsync.

I share the usb disk (documents and pictures) with Windows 7 (dual boot Ubuntu and Windows). In case of a hard problem of the Linux OS, I prefer to reinstall Ubuntu and restore from NAS the user home directory.

For an image of the entire linux file-system use a more specific program.

Hi Wouter,

Thanks for this. What would you suggest as the more specific program?

Also, I'm unsure as to whether trying to restore an entire filesystem would cause issues while on the actual machine - surely the kernel files/drivers etc would get over-written as the machine was doing the restore. Would this cause it to become 'broke' as a result of such critical files getting written at the same time as they were in use?

You'll have to excuse my lack of knowledge in this area only I've never needed to backup/restore before and it was something I felt I should learn more about. Perhaps this scenario is why I saw the lockup of the machine last night - is this down to me misunderstanding the process and what is involved? Perhaps the keyboard and touchpad became unresponsive as the driver files were being restored? I've no idea.

THank you again.

Regards

Gary.

Wouter Smaal (w-smaal) wrote :

Hi Gary,

My experience is to long ago to suggest now a more specific program. Except tar, I remember dump / restore, cp, dd and cpio.

Regards,
Wouter

Michael Terry (mterry) wrote :

Hello! Sorry for not being involved in this thread earlier. I bet I know what's going on.

It's because it's running duplicity as root, and root doesn't have easy access to your nautilus mount. If you instead restored to a new folder as your user, it would work fine I bet.

This is certainly a bug... But I'll have to think about how best to fix it.

summary: - Cannot restore backup from NAS using Deja Dup
+ Can't restore from remote server after prompt for root password
Changed in deja-dup:
importance: Undecided → High
status: New → Confirmed
Michael Terry (mterry) on 2012-03-22
Changed in deja-dup:
status: Confirmed → Fix Released
milestone: none → 22.0
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package deja-dup - 22.0-0ubuntu1

---------------
deja-dup (22.0-0ubuntu1) precise; urgency=low

  * New upstream release
    - Fixes "Can't restore from remote server after prompt for root
      password" (LP: #929139)
  * debian/control:
    - Add gvfs-backends to Recommends (LP: #880273)
 -- Michael Terry <email address hidden> Thu, 22 Mar 2012 08:39:50 -0400

Changed in deja-dup (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers