Where is the GUI?

Bug #819029 reported by Sam_ on 2011-07-31
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
deja-dup (Ubuntu)
Undecided
Unassigned

Bug Description

Not in dash, not displayed with alt+f2, only in terminal it displays usage, help- and application options. Oneiric is updated.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: deja-dup 19.4-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-7.9-generic 3.0.0
Uname: Linux 3.0.0-7-generic x86_64
Architecture: amd64
Date: Sun Jul 31 23:55:35 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110423)
ProcEnviron:
 LANG=C
 SHELL=/bin/bash
SourcePackage: deja-dup
UpgradeStatus: Upgraded to oneiric on 2011-07-30 (0 days ago)

Sam_ (and-sam) wrote :
Michael Terry (mterry) wrote :

Search for "backup" or look in System Settings for "Backup"

Sam_ (and-sam) wrote :

I did search keywords like backup. Your answer suggests you have a GUI, then please tell how to view it.
I'd expect to see something like this icon there.
http://packages.ubuntu.com/oneiric/deja-dup

Sam_ (and-sam) wrote :
Michael Terry (mterry) wrote :

Interesting. Thanks, that video and screenshot make it pretty clear. Oddly, I do see it in my dash and system settings.

As a workaround for this issue, you can run "deja-dup-preferences" in the Terminal.

Sam_ (and-sam) wrote :

Thanks for the hint. There isn't also a deja-dup folder in /home/user as the GUI suggests. Assume it should’ve been created after installation.

Part of the issue might be due to localization: backup is translated as "Datensicherung" in German, this is what I can use in dash to find deja dup (although I doubt anyone would try using that term). I do however also see it both in system settings and in the "installed applications" section in dash with a German locale, so that seems to be another problem.

Sam_ (and-sam) wrote :

Thanks Marcel, but I've tried of course also german wording, nothing found.
I don't have a problem with reinstalling or else, but not sure if it helps Terry to triage the issue then. Terry?

Michael Terry (mterry) wrote :

I tried a fresh install of 11.10 and didn't see this issue.

Sam_, I guess try reinstalling. It may shed some light on this.

Sam_ (and-sam) wrote :

Thanks for the ok Michael and here is my report.
Purged deja-dup and autoremoved the other too. Reinstalled all.
Open dash - more applications - installed 'show more results..', a 'safe' icon appears - but - it opens gnome-control-center. Deja-dup isn't in g-c-c.

On dash it calls 'Datensicherung' in german, which is like 'backup'.
In /usr/share/applications/deja-dup.desktop it says:
X-Ubuntu-Software-Center-Name[de]=Déjà Dup Datensicherungswerkzeug
which is like 'backup-tool'.

Run via alt+f2 deja-dup-preferences, it displays the 'safe' icon and displays in launcher as 'Datensicherung'.

Attached terminal output of installation, extracted relevant lines from .xsession-errors, video from dash and running alt+f2.

Sam_ (and-sam) wrote :
Sam_ (and-sam) wrote :
Sam_ (and-sam) wrote :

Should've mentioned that Oneiric is alpha3 updated.
$ apt-cache policy deja-dup
deja-dup:
  Installed: 19.4-0ubuntu2
  Candidate: 19.4-0ubuntu2
  Version table:
 *** 19.4-0ubuntu2 0

Sam_ (and-sam) wrote :

Video of #12 maybe not so clear, when running alt+f2 typing deja-dup it displays the 'safe' icon titled as 'deja-dup', but when pressing [Enter] nothing happens.

## Opinion.
Not sure either as #7, no matter if geek or converted, I doubt they look for 'Datensicherung', it's maybe political correct, but in real life the wording 'backup' is probably more common in german locales, like 'kindergarden' in US. Or just let it run under it's origin 'deja-dup' which by now gains popularity due to Oneiric news anyway.

Michael Terry (mterry) wrote :

Thanks for sticking with this bug Sam, and providing such excellent videos!

So assuming the first problem you had before the reinstall were just flukes... the bugs you've seen are this:

1) Alt-F2, 'deja-dup' doesn't do anything
2) Applications, 'Datensicherung' launches g-c-c but no deja-dup
3) deja-dup-preferences when saved in launcher does not notice it is running after being launched

#1 is expected. The deja-dup executable requires arguments to do anything (try running it in a console to see the help output).

#2 is not at all expected. I see it in my g-c-c. Not sure why it wouldn't work for you...

#3 is also not expected. I'll look into it.

Sam_ (and-sam) wrote :

#1 acknowlegded. It isn't confusing in terminal. One can start there only with 'deja-dup' and views an overwie what can be done.

The GUI doesn't reveal that it actually starts deja-dup-preferences.
The name under the 'safe' icon says deja-dup, but clicking on it does nothing, instead clicking on deja-dup-preferences with the 'settings' icon opens the GUI, which again displays the 'safe' icon in launcher.
It seems to me when I ran it from Alt+F2 as deja-dup it assigned the 'safe' icon. It may confuse a user when it actually does nothing then, but the 'settings' icon named deja-dup-preferences opens the app.
When wrongly running only 'deja-dup' by Alt+F2 it shouldn't assign the 'safe' icon to it which makes a user think it would open 'deja-dup' but it actually doesn't.

It's also a somewhat confusing german translation, acknowleged this needs to be discussed with translation-team.

#2 is correct.
I wonder if the 'safe' icon in dash is assigned to deja-dup only as in Alt+F2 since I mistakenly ran it from there.
I'll clean-up zeitgeist cache and see what it does.

#3 The launcher icon just behaved a little weird, but I think it isn't due to deja-dup, rather to launcher itself.
When deja-dup ran fine, I've wanted to close it via launcher, the right click on the icon displayed only 'keep in launcher', the rest was empty (white). After that it started blinking again while I moved the mouse to the window in order to close it from there.

I'll test behaviour again the next days and report back.

Sam_ (and-sam) wrote :

Oneiric is up-to-date.
Again no icon in dash present, same as before I reinstalled.
When I start typing: dat
it displays the icon but still opens g-c-c.

New and weird.
Open dash, click on more applications+, start typing deja
it displays the app to download.
But as one can see in terminal output and video, it is already installed.

The launcher behaviour is ok now.

Sam_ (and-sam) wrote :

Open dash, more applications+, applications menu -> accessories, it displays deja-dup.

Michael Terry (mterry) wrote :

Just a quick word on why the icon is assigned to deja-dup executable and not deja-dup-preferences. Here's my theory.

There are three .desktop files shipped:
1) deja-dup (for deja-dup executable, just so that when it is running, bamf and the launcher can match it better and give it appropriate icon)

2) deja-dup-preferences (for deja-dup-preferences executable, only used in non-GNOME environments -- it asks to be ignored in GNOME and Unity)

3) deja-dup-ccpanel (for gnome-control-center plugin, used in GNOME and Unity and nowhere else)

So I bet that deja-dup executable rightly has the icon because of #1. deja-dup-preferences executable does not have the icon because Unity is ignoring #2 (as it is told to do). #3 doesn't show up in Alt+F2 because it's not an executable but a plugin.

Not sure there's really something we want to do here... It's kind of an odd case. Maybe Unity should only partly ignore #2 and still show the icon?

Sam_ (and-sam) wrote :

Michael, thanks a lot for sorting it out.
Actually deja-dup-preferences is what's behind the GUI here using Unity, since I've got the hint from you to open it like this.
If correctly understood from #2 it should be ignored.

I need to wait anyway to test if it's displayed on dash because it's broken at the moment. Bug #824842
It still isn't in g-c-c.
Anyway, when Beta arrives I may reinstall deja-dup and report back if the confusion is solved.

Michael Terry (mterry) wrote :

To solve your concern about the translation, I've added keywords to the .desktop file.

So the German translators can add 'backup' to the string if they think it's likely users will search for it that way. See https://translations.launchpad.net/deja-dup/20/+pots/deja-dup/de/+translate?batch=10&show=all&search=dup%3B

I've also filed a bug against Unity (bug 828356) to support such keywords. Only gnome-control-center does so far.

Sam_ (and-sam) wrote :

Thanks Michael, I'll submit a request to german translation team.

I've updated today, purged and reinstalled deja-dup again. No luck, search with deja-dup brought no result. Search for backup yes but it still openes g-c-c.
The video is awful because my dash is canary yellow since updates and I couldn't barely see what I'm looking for, sorry.
The deja-dup-ccpanel file lists in line #14 g-c-c first, I wonder if this the reason why it's opening in g-c-c. Certainly not an expert speaking here.

Sam_ (and-sam) wrote :

Better video. After purge and reinstall (also duplicity), deja-dup is again missing in dash applications and says it's available for download. Software-center of course says it's installed.
When I run deja-dup-preferences it still displays last settings although I've removed it's folder from ~/.cache before reinstalling.
Attached terminal output from locate deja-dup.

Sam_ (and-sam) wrote :
Sam_ (and-sam) wrote :

Fixed with latest updates.
deja-dup:
  Installed: 19.90-0ubuntu1
  Candidate: 19.90-0ubuntu1
  Version table:
 *** 19.90-0ubuntu1 0

Deja-dup is available in dash and g-c-c, and opens as expected. Thanks!

Changed in deja-dup (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers