pass in trusty, but fails ADT tests in utopic

Bug #1315185 reported by Dimitri John Ledkov
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Déjà Dup
Undecided
Unassigned
dbus-test-runner (Ubuntu)
High
Unassigned
deja-dup (Ubuntu)
High
Michael Terry

Bug Description

I've uploaded a no change rebuild of gvfs, yet it's currently blocked on deja-dup and dbus-test-runner ADT tests failing in utopic, yet they pass in trusty.

This should be investigated and if something is wrong, appropriately fixed.

Tags: adt Edit Tag help
Revision history for this message
Dimitri John Ledkov (xnox) wrote :
Revision history for this message
Dimitri John Ledkov (xnox) wrote :
Changed in deja-dup (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Changed in dbus-test-runner (Ubuntu):
status: New → Confirmed
importance: Undecided → High
tags: added: adt
summary: - passes in trusty, but fails ADT tests in utopic
+ pass in trusty, but fails ADT tests in utopic
Revision history for this message
Martin Pitt (pitti) wrote :

FTR, deja-dup failure (during package build):

71/94 Test #71: disk-full.test ...........................***Exception: Other 4.22 sec

** (./test-runner:17242): CRITICAL **: uint64_parse: assertion 'str != NULL' failed
/scripts/disk-full:

dbus-test-runner failure: This looks like a missing test dep?

adt-run: & apt0t-with-bustle: - - - - - - - - - - stderr - - - - - - - - - -
./configure: line 4007: intltool-update: command not found
configure: error: Your intltool is too old. You need intltool 0.35.0 or later.

Revision history for this message
Dimitri John Ledkov (xnox) wrote : Re: [Bug 1315185] Re: pass in trusty, but fails ADT tests in utopic

On 2 May 2014 07:10, Martin Pitt <email address hidden> wrote:
> FTR, deja-dup failure (during package build):
>
> 71/94 Test #71: disk-full.test ...........................***Exception:
> Other 4.22 sec
>
> ** (./test-runner:17242): CRITICAL **: uint64_parse: assertion 'str != NULL' failed
> /scripts/disk-full:
>
> dbus-test-runner failure: This looks like a missing test dep?
>
> adt-run: & apt0t-with-bustle: - - - - - - - - - - stderr - - - - - - - - - -
> ./configure: line 4007: intltool-update: command not found
> configure: error: Your intltool is too old. You need intltool 0.35.0 or later.
>

At first it was missing a C compiler, so i've added "build-essential"
to Depends, in trusty however that was not neccessary as the
"build-needed" restriction kept both build-essential & build-depends
installed during test execution step.
--
Regards,

Dimitri.

Revision history for this message
Michael Terry (mterry) wrote :

I can reproduce the deja-dup failure and am looking at it.

(I'd really like a way to subscribe to adt failures for deja-dup in *any* series. I missed this failure because I wasn't subscribed to utopic specifically.)

Changed in deja-dup (Ubuntu):
assignee: nobody → Michael Terry (mterry)
status: Confirmed → In Progress
Michael Terry (mterry)
Changed in deja-dup:
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package deja-dup - 30.0-0ubuntu5

---------------
deja-dup (30.0-0ubuntu5) utopic; urgency=medium

  * debian/patches/support-valac-0.24.patch:
    - Fix an array slice usage that changed in valac 0.24 (only affects
      testing code). Patch from upstream. LP: #1315185
 -- Michael Terry <email address hidden> Fri, 02 May 2014 09:59:35 -0400

Changed in deja-dup (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Martin Pitt (pitti) wrote :

Sorry, it still fails:

https://jenkins.qa.ubuntu.com/job/utopic-adt-deja-dup/11/ARCH=i386,label=adt/console

adt-run: & apt0t-check: - - - - - - - - - - results - - - - - - - - - -
apt0t-check FAIL non-zero exit status 2
adt-run: & apt0t-check: - - - - - - - - - - stderr - - - - - - - - - -
CMake Error: Target DependInfo.cmake file not found
CMake Error: Directory Information file not found
env: dbus-launch: No such file or directory
make[3]: *** [libdeja/tests/CMakeFiles/test-system-verify.test] Error 127
make[2]: *** [libdeja/tests/CMakeFiles/test-system-verify.test.dir/all] Error 2
make[1]: *** [CMakeFiles/test-system.dir/rule] Error 2
make: *** [test-system] Error 2

Changed in deja-dup (Ubuntu):
status: Fix Released → Confirmed
Revision history for this message
Michael Terry (mterry) wrote :

deja-dup (30.0-0ubuntu6) utopic; urgency=medium

  * debian/control:
    - Add appdata-tools to Build-Deps to validate appdata file
  * debian/tests/control:
    - Add dbus-x11 to test deps to fix autopkgtest runs
 -- Michael Terry <email address hidden> Fri, 02 May 2014 14:05:32 -0400

Changed in deja-dup (Ubuntu):
status: Confirmed → Fix Released
Ted Gould (ted)
no longer affects: dbus-test-runner
Changed in dbus-test-runner (Ubuntu):
status: Confirmed → Invalid
Vej (vej)
Changed in deja-dup:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers