dfontmgr ships no .desktop

Bug #49443 reported by Vassilis Pandis on 2006-06-12
4
Affects Status Importance Assigned to Milestone
defoma (Debian)
Fix Released
Unknown
defoma (Ubuntu)
Wishlist
Michael Vogt

Bug Description

I couldn't find an Icon. This gets installed under System->Administration. Maybe System->Preferences would be a better choice, but I couldn't figure out how to do this. Other than these, it validates and shows in the menus. Thanks.

.

Changed in defoma:
importance: Untriaged → Wishlist
Changed in defoma:
status: Unknown → Unconfirmed
Siegfried Gevatter (rainct) wrote :

This one shows up in System -> Preferences (the category name for that is as simple as "Preferences"), and includes translation for Catalan, German and Spanish.

Siegfried Gevatter (rainct) wrote :

Well, if there's nothing better Font Selection's icon can be used?

Changed in defoma:
status: Unconfirmed → Confirmed
Siegfried Gevatter (rainct) wrote :

Couldn't get a working debdiff yesterday, but will check it again later.

Changed in defoma:
assignee: nobody → rainct
status: Confirmed → In Progress
Siegfried Gevatter (rainct) wrote :

At moment here is a patch.

(By the way, this program looks really ugly xDD)

Siegfried Gevatter (rainct) wrote :

Here is a debdiff. Tried building the package and installing, should be working.

Changed in defoma:
assignee: rainct → nobody
status: In Progress → Confirmed
Daniel Holbach (dholbach) wrote :

Michael, can you take a look at it?

Changed in defoma:
assignee: nobody → mvo
Michael Vogt (mvo) wrote :

Thanks for looking into this and sorry for my late reply.

I looked into this patch and I would suggest to push it directly into debian and ask for inclusion there. I'm not sure that we should provide a desktop file for this application. It seems of limited use if you run it as non-root. And I found it overall quite complicated and non-intuitive.

What do you think?

Cheers,
 Michael

Siegfried Gevatter (rainct) wrote :

I agree with your opinion about this application and with the addition that it seems to be very old (or at least has an awful design) I don't really think that it's needed in Ubuntu (or at least not in main), but if it's there I think being a graphical application it should have it's menu entry.

Anyway, if you prefer to wait for it to be included in Debian that's okay for me...

Daniel Holbach (dholbach) wrote :

Unsubscribing Ubuntu Sponsors for main from this bug for now.

Michael Vogt (mvo) wrote :

I checked the debian archive and dfontmgr is no longer build with defoma [1]. I close this bug for now until a new tool becomes available.

[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=282225

Changed in defoma:
status: Confirmed → Won't Fix
Changed in defoma (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.