[Master] font package failed to install/upgrade: post-installation exit status 1 - /var/lib/defoma/locked exists.

Bug #386763 reported by Mahendra
876
This bug affects 120 people
Affects Status Importance Assigned to Milestone
defoma (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: ttf-dejavu

Under certain circumstances font packages failed to install with the following error

Setting up ttf-dejavu-extra (2.28-1) ...
E: /var/lib/defoma/locked exists.
E: Another defoma process seems running, or you aren't root.
E: If you are root and defoma process isn't running undoubtedly,
E: it is possible that defoma might have aborted.
E: Please run defoma-reconfigure -f to fix its broken status.
dpkg: error processing ttf-dejavu-extra (--configure):
 subprocess post-installation script returned error exit status 1

== WORKAROUND ==
Open a terminal (Applications -> Accessories -> Terminal ) and run the following command:
$ sudo defoma-reconfigure -f

ProblemType: Package
Architecture: i386
DistroRelease: Ubuntu 9.04
ErrorMessage: subprocess post-installation script returned error exit status 1
Package: ttf-dejavu-extra 2.28-1
PackageArchitecture: all
SourcePackage: ttf-dejavu
Title: package ttf-dejavu-extra 2.28-1 failed to install/upgrade: subprocess post-installation script returned error exit status 1
Uname: Linux 2.6.28-11-generic i686

Revision history for this message
Mahendra (qanda-mahendra) wrote :
Revision history for this message
bihari sharan pandit (bbbbbihari) wrote :

how to solve this please help me out I'm getting embarrased

summary: - package ttf-dejavu-extra 2.28-1 failed to install/upgrade: subprocess
- post-installation script returned error exit status 1
+ package ttf-* failed to install/upgrade: post-installation exit status 1
+ - /var/lib/defoma/locked exists.
affects: ttf-dejavu (Ubuntu) → defoma (Ubuntu)
Changed in defoma (Ubuntu):
status: New → Triaged
summary: - package ttf-* failed to install/upgrade: post-installation exit status 1
- - /var/lib/defoma/locked exists.
+ [Master] font package failed to install/upgrade: post-installation exit
+ status 1 - /var/lib/defoma/locked exists.
description: updated
tags: added: metabug
tags: added: workaround
Changed in defoma (Ubuntu):
importance: Undecided → Low
Revision history for this message
Lex (lex-eckersley) wrote :

defoma-reconfigure -f isn' t working for me.

$ sudo defoma-reconfigure -f
Error: /var/lib/defoma/locked exists.
Another defoma process seems running, or you aren't root.
If you are root and defoma process isn't running undoubtedly,
it is possible that defoma might have aborted.
Please run defoma-reconfigure -f to fix its broken status.

sudo apt-get install ttf-mscorefonts-installer -qq
Instellen van ttf-droid (1.00~b112+dfsg+1-0ubuntu1) ...
E: /var/lib/defoma/locked exists.
E: Another defoma process seems running, or you aren't root.
E: If you are root and defoma process isn't running undoubtedly,
E: it is possible that defoma might have aborted.
E: Please run defoma-reconfigure -f to fix its broken status.
dpkg: fout bij afhandelen van ttf-droid (--configure):
 subproces installed post-installation script gaf een foutwaarde 1 terug
Instellen van ttf-mscorefonts-installer (3.3ubuntu3) ...

These fonts were provided by Microsoft "in the interest of cross-
platform compatibility". This is no longer the case, but they are
still available from third parties.

You are free to download these fonts and use them for your own use,
but you may not redistribute them in modified form, including changes
to the file name or packaging format.

All fonts downloaded and installed.
E: /var/lib/defoma/locked exists.
E: Another defoma process seems running, or you aren't root.
E: If you are root and defoma process isn't running undoubtedly,
E: it is possible that defoma might have aborted.
E: Please run defoma-reconfigure -f to fix its broken status.
dpkg: fout bij afhandelen van ttf-mscorefonts-installer (--configure):
 subproces installed post-installation script gaf een foutwaarde 1 terug
Fouten gevonden tijdens behandelen van:
 ttf-droid
 ttf-mscorefonts-installer
E: Sub-process /usr/bin/dpkg returned an error code (1)

tags: added: bugpattern-written
Revision history for this message
Adolfo Jayme (fitojb) wrote :

defoma is obsolete software, and has been removed from both Debian and Ubuntu for a while.

Changed in defoma (Ubuntu):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers