Please make PyGI overrides available to Python3

Bug #905085 reported by Jason Gerard DeRose on 2011-12-16
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
Unassigned
dee
High
Unassigned
dee (Ubuntu)
High
Unassigned
Precise
Undecided
Łukasz Zemczak
unity (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

[Test Case]

1. Start python3
2. from gi.repository import Dee
   -> Make sure that Dee is importable through gi.repository and that it's usuable from python3

[Regression Potential]

As this does not modify existing code, no real regression potential.

Original description:

Currently the GI overrides are only usable from Python2, not Python3. I'm working through a lens tutorial using Python3, and got stumped by Dee.Model.append() being missing. Looking a bit at Dee.py, seems it should be trivial to have the same code work under Python2 and Python3, although I'm not sure the correct way to do this packaging-wise.

Files currently installed by gir1.2-dee-0.5:

jderose@jgd-ws:~/bzr/dmedia/lens$ dpkg -L gir1.2-dee-0.5
/.
/usr
/usr/share
/usr/share/doc
/usr/share/doc/gir1.2-dee-0.5
/usr/share/doc/gir1.2-dee-0.5/copyright
/usr/share/pyshared
/usr/share/pyshared/gi
/usr/share/pyshared/gi/overrides
/usr/share/pyshared/gi/overrides/Dee.py
/usr/lib
/usr/lib/girepository-1.0
/usr/lib/girepository-1.0/Dee-0.5.typelib
/usr/lib/python2.7
/usr/lib/python2.7/dist-packages
/usr/lib/python2.7/dist-packages/gi
/usr/lib/python2.7/dist-packages/gi/overrides
/usr/share/doc/gir1.2-dee-0.5/changelog.Debian.gz
/usr/lib/python2.7/dist-packages/gi/overrides/Dee.py

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gir1.2-dee-0.5 0.5.22-1
ProcVersionSignature: Ubuntu 3.2.0-4.10-generic 3.2.0-rc5
Uname: Linux 3.2.0-4-generic x86_64
ApportVersion: 1.90-0ubuntu1
Architecture: amd64
Date: Thu Dec 15 19:33:51 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110921.2)
SourcePackage: dee
UpgradeStatus: Upgraded to precise on 2011-12-01 (14 days ago)

Related branches

Jason Gerard DeRose (jderose) wrote :
summary: - Please make GI overrides available to Python3
+ Please make PyGI overrides available to Python3
Changed in dee:
importance: Undecided → High
status: New → Confirmed
Changed in dee (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Didier Roche (didrocks) on 2012-02-01
Changed in unity:
status: New → Confirmed
Changed in dee:
status: Confirmed → Fix Committed
description: updated
Changed in dee:
status: Fix Committed → Confirmed
status: Confirmed → Triaged
Didier Roche (didrocks) on 2012-06-29
Changed in dee:
status: Triaged → Fix Committed
Changed in unity:
milestone: none → 6.0
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dee - 1.0.10-0ubuntu2

---------------
dee (1.0.10-0ubuntu2) quantal; urgency=low

  [ Didier Roche ]
  * debian/rules, debian/control:
    - install the python3 version of the override gobject introspection file

  [ Łukasz 'sil2100' Zemczak ]
  * Cherry-pick upstream:
    - dee doesnt compile with latest gobject-introspection (LP: #1017277)
    - Please make PyGI overrides available to Python3 (LP: #905085)
 -- Didier Roche <email address hidden> Tue, 10 Jul 2012 08:45:33 +0200

Changed in dee (Ubuntu):
status: Confirmed → Fix Released
Didier Roche (didrocks) on 2012-07-10
Changed in dee:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Changed in dee (Ubuntu Precise):
status: New → In Progress
assignee: nobody → Łukasz Zemczak (sil2100)
description: updated

Hello Jason, or anyone else affected,

Accepted dee into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/dee/1.0.10-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in dee (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Timo Jyrinki (timo-jyrinki) wrote :

Seems to be fixed after update.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dee - 1.0.10-0ubuntu1.1

---------------
dee (1.0.10-0ubuntu1.1) precise-proposed; urgency=low

  * Cherry-pick upstream:
    - 'SharedModel' object has no attribute 'append' using Python 3 on 12.04
      (LP: #1096708) (LP: #905085)
  * debian/control, debian/rules:
    - install the python3 version of the override gobject introspection file,
      as made by Didier Roche
 -- Lukasz 'sil2100' Zemczak <email address hidden> Wed, 30 Jan 2013 16:50:42 +0100

Changed in dee (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: New → Fix Released
Jaime Pérez (jaime-91) on 2015-10-13
Changed in unity (Ubuntu Precise):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers