Unity freezes when launched with places installed

Bug #709264 reported by Marek Tyburec
52
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Unity
Invalid
Critical
Unassigned
dee
Critical
Mikkel Kamstrup Erlandsen
dee (Ubuntu)
Critical
Unassigned

Bug Description

Binary package hint: unity

After updating to the latest Unity (3.2.16-0ubuntu1) after starting it it loads without indicators and the whole desktop does not respond on any mouse clicks nor pressed keys. The only way is to manually turn off the computer and start with gnome-panel.

Active compiz plugins: core, bailer, detection, composite, opengl, decor, mousepoll, vpswitch, regex, animation, snap, expo, move, compiztoolbox, place, grid, gnomecompat, wall, ezoom, workarounds, staticswitcher, resize, fade, scale, session, unityshell

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
Intel Core2Duo 2,2GHz, 3GB RAM

security vulnerability: yes → no
visibility: private → public
Revision history for this message
Didier Roche (didrocks) wrote :

Thanks for your bug report,

Can you try apt-get remove unity-place-files unity-place-applications?

Revision history for this message
Marek Tyburec (marek-tyburec) wrote :

Thanks a lot, it works now.

Revision history for this message
Didier Roche (didrocks) wrote :

excellent, I'll make the package conflicts right now.

Revision history for this message
Didier Roche (didrocks) wrote :

Hum, thinking about it, conflicts isn't the right solution as most of people won't do partial upgrade if they are already impacted and alpha2 should get the fix. Just let the bug opened right now for people finding the solution

Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → Critical
Changed in unity:
status: New → Triaged
importance: Undecided → Critical
milestone: none → 3.4
summary: - Unity freezes when launched
+ Unity freezes when launched with places installed
Revision history for this message
Sam Spilsbury (smspillaz) wrote :

Interesting - I've been hitting something similar to this while messing around with the startup order of compiz trying to get the glib mainloop to start before anything else g* starts. Could people who are having this problem do the following?

1. Drop to a VT
2. pidof compiz #note the number that it spits out
3. sudo gdb #needed to attach to arbitrary applications
4. attach the_number
5. set logging-file ~/glib-bug.txt
6. bt
7. bt full
8. exit

And then post the resulting glib-bug.txt in their home dir? That would be fantastic.

Also, Unity Team members - please assign yourself if this bug is related to you.

Changed in unity:
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
Revision history for this message
Hernando Torque (htorque) wrote :
Revision history for this message
Mikkel Kamstrup Erlandsen (kamstrup) wrote :

Releasing dee-0.5.6 right now which will fix this

Changed in dee:
importance: Undecided → Critical
milestone: none → 0.5.6
status: New → Fix Released
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
Revision history for this message
Mikkel Kamstrup Erlandsen (kamstrup) wrote :

As it turns out this wasn't a bug in Unity or Compiz, but a double unref in dee.

Changed in unity:
assignee: Sam "SmSpillaz" Spilsbury (smspillaz) → nobody
status: Triaged → Invalid
Didier Roche (didrocks)
affects: unity (Ubuntu) → dee (Ubuntu)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dee - 0.5.6-0ubuntu1

---------------
dee (0.5.6-0ubuntu1) natty; urgency=low

  * New upstream release:
    - Fix the freeze when places are installed due to a gvariant freeze on
      double freeing (LP: #709264)
 -- Didier Roche <email address hidden> Mon, 31 Jan 2011 12:13:03 +0100

Changed in dee (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Yuriy Voziy (yuretsz) wrote :

Running latest unity. (Natty with all updated) This bug is not fixed!

Revision history for this message
Yuriy Voziy (yuretsz) wrote :

To get unity working I do:
Ctrl+Alt+F1
Kill all compiz processes ( kill -9 flag only works )
nohup compiz &
kill all unity processes
nohup unity &

After that I can use unity as normal.

Revision history for this message
Alessio Fattorini (alessio.fattorini) wrote :

Not fixed, see #758482
Very big bug :-|

Revision history for this message
Agent Vimsical (vimsical) wrote :

Same issue. pgrep -fl compiz gives two processes:
# pgrep -fl compiz
5677 compiz
5810 compiz --replace --sm-disable --ignore-desktop-hints ccp

killing the first one allow unity desktop to appear!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments