[FTBFS] decibel (0.5.0+svn737972-2) fails to build in hardy

Bug #180344 reported by Marco Rodrigues
10
Affects Status Importance Assigned to Milestone
decibel (Ubuntu)
Low
Rich Johnson

Bug Description

It needs the latest telepathy-qt and tapioca-qt from Debian experimental. Waiting for them to be synced.

http://launchpadlibrarian.net/11124056/buildlog_ubuntu-hardy-i386.decibel_0.5.0%2Bsvn737972-2_MANUALDEPWAIT.txt.gz

decibel (0.5.0+svn737972-2) experimental; urgency=low

   * Add depends on libqttapioca-dev and libqttelepathy-dev for
     libdecibel-dev.

 -- Ana Beatriz Guerrero Lopez <email address hidden> Thu, 22 Nov 2007 08:19:54 +0100

Changed in decibel:
assignee: nobody → gothicx
importance: Undecided → Wishlist
status: New → In Progress
description: updated
Changed in decibel:
assignee: gothicx → nobody
status: In Progress → New
Revision history for this message
Laurent Bigonville (bigon) wrote :

I've uploaded new snapshot of tapioca-qt and telepathy-qt in the archive, hope it will do the trick

Changed in decibel:
assignee: nobody → bigon
status: New → In Progress
Revision history for this message
Daniel Holbach (dholbach) wrote :

What's the status of this one? Did it fix the bug?

Revision history for this message
Marco Rodrigues (gothicx) wrote :

It still FTBFS, but now with other error...

cp: cannot stat `debian/tmp//usr/share/Decibel/components/de.basyskom.simpleclient.textchannel.component': No such file or directory
dh_install: command returned error code 256
make: *** [binary-install/libdecibel0.6.0] Error 1

Revision history for this message
Laurent Bigonville (bigon) wrote :

This is due to the location where kde4 is installed. I'm really not sure where the files must be installed, if a kubuntu guy could have a look at this bug

Changed in decibel:
assignee: bigon → nobody
status: In Progress → Confirmed
Changed in decibel:
importance: Wishlist → Low
Revision history for this message
Rich Johnson (nixternal) wrote :

Looking into this now. Thanks

Changed in decibel:
assignee: nobody → nixternal
status: Confirmed → In Progress
Revision history for this message
Rich Johnson (nixternal) wrote :

I am wondering about the whole decibel-kde4 part, as I don't believe Decibel is KDE 4 only, considering the CMakeLists.txt file doesn't even list KDE4 as REQUIRED. I can confirm that removing the kde4 bit out of the package fixes the FTBFS, but I need to confirm that with Jonathan first.

Revision history for this message
hunger (hunger) wrote : Re: [Bug 180344] Re: [FTBFS] decibel (0.5.0+svn737972-2) fails to build in hardy

On Saturday 23 February 2008, Richard Johnson wrote:
> I am wondering about the whole decibel-kde4 part, as I don't believe
> Decibel is KDE 4 only, considering the CMakeLists.txt file doesn't even
> list KDE4 as REQUIRED. I can confirm that removing the kde4 bit out of
> the package fixes the FTBFS, but I need to confirm that with Jonathan
> first.

Decibel is mainly a Qt4 Core only daemon process. To work it needs to
integrate with the users desktop environment. Currently there is
a "simplistic" integration and a kde4 one (which should not differ too much
from the simplistic one in the version you are packaging). The kde4 one had a
build problem for a while, maybe that is the reason why it does FTBFS for
you?

Please feel free to contact me if you have any questions on decibel. I wrote
most of it:-)

Best Regards,
Tobias

Revision history for this message
Marco Rodrigues (gothicx) wrote :

It was been fixed for Hardy by Riddel. Thanks!

Changed in decibel:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers